summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-09-30 12:36:56 +0100
committerMarek Szuba <marecki@gentoo.org>2019-09-30 12:36:56 +0100
commit936416152db6d1a2bd3eade680bae27ab759105b (patch)
tree6daf10fa2b82ae87523e133d9b735482b6e4a4c8 /dev-libs/hsa-ext-rocr
parentprofiles/thirdpartymirrors: Update ubuntu (diff)
downloadgentoo-936416152db6d1a2bd3eade680bae27ab759105b.tar.gz
gentoo-936416152db6d1a2bd3eade680bae27ab759105b.tar.bz2
gentoo-936416152db6d1a2bd3eade680bae27ab759105b.zip
dev-libs/hsa-ext-rocr: bump to 1.1.9.112
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/hsa-ext-rocr')
-rw-r--r--dev-libs/hsa-ext-rocr/Manifest1
-rw-r--r--dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.112.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/hsa-ext-rocr/Manifest b/dev-libs/hsa-ext-rocr/Manifest
index a8f257eb375e..5fe40ccb9ec4 100644
--- a/dev-libs/hsa-ext-rocr/Manifest
+++ b/dev-libs/hsa-ext-rocr/Manifest
@@ -1 +1,2 @@
+DIST hsa-ext-rocr-dev_1.1.9-112-g3d9d98f_amd64.deb 1120410 BLAKE2B 653480e4209f7f6a0d8dfe0f8a8948ef44d2aa2a415f33ce9c4ca8ec8dc3b3e0dd78dac9a3d80bb45f5202df49dc2aa5b329e285968853e0bcaf6673f76d714e SHA512 28fb2ecedb2094782376efcab2a5292cb4f3e58dbdd8ba8b520dfca7d230d30326939dc3964f6e1be841e41829bef44b96573ffdbcad187f02adb11ac70401fd
DIST hsa-ext-rocr-dev_1.1.9-99-g835b876_amd64.deb 1113746 BLAKE2B ff1d3418febdde505e12a3a41b39a15d6ed28e97f62700ffa4b7bfbc618b23253026e3978e1293cfa2c06742c78574510e08969e1e1524b82b94a45d98efd2af SHA512 e7c799e218eaee6f926fe309b470af00e0ef7e4974a3dd67231c1c904a0a036e62b1ce3b176bb0c13c0fa65a718443f06e7472e3e66225d818074620e46350b1
diff --git a/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.112.ebuild b/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.112.ebuild
new file mode 100644
index 000000000000..f423e5899b06
--- /dev/null
+++ b/dev-libs/hsa-ext-rocr/hsa-ext-rocr-1.1.9.112.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+MY_PV=$(ver_rs 3 '-')
+
+DESCRIPTION="Proprietary image-support library for Radeon Open Compute"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCm#closed-source-components"
+SRC_URI="http://repo.radeon.com/rocm/apt/debian/pool/main/h/${PN}-dev/${PN}-dev_${MY_PV}-g3d9d98f_amd64.deb"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="-deprecated"
+
+RESTRICT="bindist strip"
+
+QA_PREBUILT="/opt/${PN}/lib*/*"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local destdir="/opt/${PN}"
+ local soversion=$(ver_cut 1-3)
+ local somajor=$(ver_cut 1)
+
+ local solibs_to_install=( "libhsa-ext-image64.so" )
+ if use deprecated; then
+ solibs_to_install+=( "libhsa-runtime-tools64.so" )
+ fi
+
+ into "${destdir}"
+ for solib in ${solibs_to_install[@]}; do
+ dolib.so "opt/rocm/hsa/lib/${solib}.${soversion}"
+ dosym "${EPREFIX}${destdir}/$(get_libdir)/${solib}.${soversion}" "${EPREFIX}usr/$(get_libdir)/${solib}.${soversion}"
+ dosym "${solib}.${soversion}" "${EPREFIX}usr/$(get_libdir)/${solib}.${somajor}"
+ done
+}