summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-02-21 11:41:18 -0300
committerMatt Turner <mattst88@gentoo.org>2023-02-22 17:02:48 -0500
commit43842b917dd3378033bd0dc4e413464653a10715 (patch)
tree74ff787dafa2d5a1779f10966786fc954d74fd31 /dev-libs/gjs
parentapp-office/libreoffice: add 7.5.1.2, drop 7.5.1.1 (diff)
downloadgentoo-43842b917dd3378033bd0dc4e413464653a10715.tar.gz
gentoo-43842b917dd3378033bd0dc4e413464653a10715.tar.bz2
gentoo-43842b917dd3378033bd0dc4e413464653a10715.zip
dev-libs/gjs: Version bump to 1.74.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29704 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.74.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 5ffaae812bbb..54d19e351bc8 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1 +1,2 @@
DIST gjs-1.74.1.tar.xz 638536 BLAKE2B 375abcaa20a538cfa271f7dcf6f3715e4324ff5a4a9482ce0dd7f78213598a715ebc034f701fe458876f841f72802db4ae2aabf0abc04dc4ac5bb39c917741fd SHA512 346667accb589df0e6a045e30782017eab928115f263d36d521b61b0af38fd268bc518b8ab5ec78e5d25e0194b744a2ee59e65668da679e138b2122858ce0614
+DIST gjs-1.74.2.tar.xz 639012 BLAKE2B 12f6f60b801d96a4cff260a0abc5da96c30a5b77d69d31b646b16db20a586761b36b2601c8da8ab7b313c96b8fb2319ed65cb53f3f3ca2d3d255648ceccdbc7c SHA512 738176aabcc8d0147cf77b7af3271c93ca4e8a473b2d35722b4cf9a15dcdc9f87962a29dd949607d947256df9ffcfd499d7189b6eff7ac416bbad594a2bc8ea9
diff --git a/dev-libs/gjs/gjs-1.74.2.ebuild b/dev-libs/gjs/gjs-1.74.2.ebuild
new file mode 100644
index 000000000000..3c494fc4f0f8
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.74.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.66.1:=
+ >=dev-lang/spidermonkey-102.2.0:102
+ cairo? ( x11-libs/cairo[X,glib] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}