summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-09-08 09:51:15 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-09-08 09:51:15 +0300
commit6527420a375b7def6c697aace2a85b7340c11e8c (patch)
treedcc88ed41c5c8ecfd448ebb428949737000af15f /dev-libs/foma/files
parentdev-util/hfstospell: new package (diff)
downloadgentoo-6527420a375b7def6c697aace2a85b7340c11e8c.tar.gz
gentoo-6527420a375b7def6c697aace2a85b7340c11e8c.tar.bz2
gentoo-6527420a375b7def6c697aace2a85b7340c11e8c.zip
dev-libs/foma: new package
- A set of utilities for constructing finite-state automata and transducers, dependency of libreoffice-voikko Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/foma/files')
-rw-r--r--dev-libs/foma/files/foma-0.9.18-clean-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/foma/files/foma-0.9.18-clean-makefile.patch b/dev-libs/foma/files/foma-0.9.18-clean-makefile.patch
new file mode 100644
index 000000000000..0ed1b811fc67
--- /dev/null
+++ b/dev-libs/foma/files/foma-0.9.18-clean-makefile.patch
@@ -0,0 +1,35 @@
+diff -Naur a/Makefile b/Makefile
+--- a/Makefile 2015-06-13 06:24:02.000000000 +0300
++++ b/Makefile 2019-09-08 09:24:22.127655912 +0300
+@@ -1,21 +1,16 @@
+-prefix = /usr/local
++prefix = /usr
+ exec_prefix = $(prefix)
+ libdir = $(exec_prefix)/lib
+ bindir = $(exec_prefix)/bin
+ includedir = $(prefix)/include
+
+ VERSION = 0.9.18
+-CC = gcc
+-RANLIB = ranlib
+ YACC = bison -v
+ LEX = flex -8
+ LEXCLEX = flex -8 --prefix=lexc
+ LEXIFACE = flex -8 --prefix=interface
+ LEXCMATRIX = flex -8 --prefix=cmatrix
+ RM = /bin/rm -f
+-LDFLAGS = -lreadline -lz -ltermcap
+-FLOOKUPLDFLAGS = libfoma.a -lz
+-CFLAGS = -O3 -Wall -D_GNU_SOURCE -std=c99 -fvisibility=hidden -fPIC
+ FOMAOBJS = foma.o stack.o iface.o lex.interface.o
+ LIBOBJS = int_stack.o define.o determinize.o apply.o rewrite.o lexcread.o topsort.o flags.o minimize.o reverse.o extract.o sigma.o io.o structures.o constructions.o coaccessible.o utf8.o spelling.o dynarray.o mem.o stringhash.o trie.o lex.lexc.o lex.yy.o lex.cmatrix.o regex.o
+
+@@ -82,7 +77,7 @@
+ if test -f $(libdir)/$(SHAREDLIB); then rm $(libdir)/$(SHAREDLIB); fi
+ if test -f $(libdir)/$(SHAREDLIBM); then rm $(libdir)/$(SHAREDLIBM); fi
+ cd $(libdir); ln -s $(SHAREDLIBV) $(SHAREDLIB); cd $(libdir); \
+- ln -s $(SHAREDLIBV) $(SHAREDLIBM); (ldconfig || true) \
++ ln -s $(SHAREDLIBV) $(SHAREDLIBM); \
+ >/dev/null 2>&1; \
+
+ $(OBJS): foma.h