summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild')
-rw-r--r--dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild b/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild
new file mode 100644
index 000000000000..aac4535f37b0
--- /dev/null
+++ b/dev-libs/clearsilver/clearsilver-0.10.5-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Please note: apache, java, mono and ruby support disabled for now.
+# Fill a bug if you need it.
+#
+# dju@gentoo.org, 4th July 2005
+
+EAPI=5
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? 2"
+
+inherit autotools eutils multilib perl-app python
+
+DESCRIPTION="Clearsilver is a fast, powerful, and language-neutral HTML template system"
+HOMEPAGE="http://www.clearsilver.net/"
+SRC_URI="http://www.clearsilver.net/downloads/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="perl python zlib"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+DOCS=(README INSTALL)
+
+pkg_setup() {
+ if use python; then
+ DOCS+=(README.python)
+
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-perl_installdir.patch
+
+ use zlib && epatch "${FILESDIR}"/${P}-libz.patch
+
+ epatch "${FILESDIR}"/${P}-libdir.patch
+ sed -i -e "s:GENTOO_LIBDIR:$(get_libdir):" configure.in
+ eautoreconf
+
+ # Fix for Gentoo/Freebsd
+ [[ "${ARCH}" == FreeBSD ]] && touch ${S}/features.h ${S}/cgi/features.h
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl) \
+ $(use_with perl perl /usr/bin/perl) \
+ $(use_enable python) \
+ $(use_with python python /usr/bin/python) \
+ $(use_enable zlib compression) \
+ "--disable-apache" \
+ "--disable-ruby" \
+ "--disable-java" \
+ "--disable-csharp"
+}
+
+src_compile() {
+ default
+}
+
+src_install () {
+ default
+
+ if use perl ; then
+ perl_delete_localpod || die "perl_delete_localpod failed"
+ fi
+}