summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/cgicc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/cgicc')
-rw-r--r--dev-libs/cgicc/Manifest2
-rw-r--r--dev-libs/cgicc/cgicc-3.2.10.ebuild50
-rw-r--r--dev-libs/cgicc/cgicc-3.2.9.ebuild44
-rw-r--r--dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch13
-rw-r--r--dev-libs/cgicc/metadata.xml21
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-libs/cgicc/Manifest b/dev-libs/cgicc/Manifest
new file mode 100644
index 000000000000..b5591059f7b0
--- /dev/null
+++ b/dev-libs/cgicc/Manifest
@@ -0,0 +1,2 @@
+DIST cgicc-3.2.10.tar.gz 2385130 SHA256 87680cb303e65bee2816b9f0e3d0a3c3258efc4f908ec3cad620d01f0b597ce0 SHA512 78a62b7af9d8bee1b7bf278a0596151733af2adca8bdf6c7b752cebcffb330a5211cc9190a2e29d053afecca076bddb06ecb510caafd51b51d7d29199b06dc19 WHIRLPOOL 1fd73ce034ebaf3b481f30078ae9995dc9feb0e64dc52f963aeb7322e71d69dd8ffee59c8706a877ea8c986ebd1ce16de375e322c146c0f087e2c6ffcc11c442
+DIST cgicc-3.2.9.tar.gz 2087796 SHA256 7bf392da75787e848ddf04395a5ed08fc472411deaa07cbae2c3edbea8fbeed4 SHA512 bd02750a0ad81a64c017e8ccf6cee0c6801506bdc00ea4b0a5e4ea28e35e453122e3e25b3578cb1cb7b22011d5147b99ed79bf7c4702d4c7ab404096aabca623 WHIRLPOOL 01f0da6ca0c28415ed44ab37f3ea56892d18c1dd57a9724bbc0c86bac20e6954bb29b826c96a72cbe8ea99bddcba12b18f9d21c17e5216a20406d931224b6a07
diff --git a/dev-libs/cgicc/cgicc-3.2.10.ebuild b/dev-libs/cgicc/cgicc-3.2.10.ebuild
new file mode 100644
index 000000000000..8045d28016d4
--- /dev/null
+++ b/dev-libs/cgicc/cgicc-3.2.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A C++ class library for writing CGI applications"
+HOMEPAGE="http://www.gnu.org/software/cgicc/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3 doc? ( FDL-1.2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-fix-pkgconfig.patch"
+}
+
+src_configure() {
+ if ! use doc; then
+ sed -i \
+ -e 's/^\(SUBDIRS = .*\) doc \(.*\)/\1 \2/' \
+ Makefile.in || die
+ fi
+
+ econf \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --disable-dependency-tracking \
+ --disable-demos \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{cpp,h} contrib/README
+
+ insinto /usr/share/doc/${PF}/demo
+ doins -r demo/*.{cpp,h} demo/images demo/README
+ fi
+}
diff --git a/dev-libs/cgicc/cgicc-3.2.9.ebuild b/dev-libs/cgicc/cgicc-3.2.9.ebuild
new file mode 100644
index 000000000000..0be1e445a123
--- /dev/null
+++ b/dev-libs/cgicc/cgicc-3.2.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="A C++ class library for writing CGI applications"
+HOMEPAGE="http://www.gnu.org/software/cgicc/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3 doc? ( FDL-1.2 )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ if ! use doc; then
+ sed -i \
+ -e 's/^\(SUBDIRS = .*\) doc \(.*\)/\1 \2/' \
+ Makefile.in || die
+ fi
+
+ econf \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --disable-dependency-tracking \
+ --disable-demos
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{cpp,h} contrib/README
+
+ insinto /usr/share/doc/${PF}/demo
+ doins -r demo/*.{cpp,h} demo/images demo/README
+ fi
+}
diff --git a/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch b/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch
new file mode 100644
index 000000000000..af1c069334e9
--- /dev/null
+++ b/dev-libs/cgicc/files/3.2.10-fix-pkgconfig.patch
@@ -0,0 +1,13 @@
+diff --git a/cgicc.pc.in b/cgicc.pc.in
+index 2006be8..e42c9bf 100644
+--- a/cgicc.pc.in
++++ b/cgicc.pc.in
+@@ -7,5 +7,5 @@ Name: cgicc
+ Description: GNU cgicc is an ANSI C++ compliant class library that greatly simplifies the creation of CGI applications for the World Wide Web.
+ Requires:
+ Version: @VERSION@
+-Libs: -L${libdir}
+-Cflags:
+\ No newline at end of file
++Libs: -L${libdir} -lcgicc
++Cflags: -I${includedir}
diff --git a/dev-libs/cgicc/metadata.xml b/dev-libs/cgicc/metadata.xml
new file mode 100644
index 000000000000..d11428dcb527
--- /dev/null
+++ b/dev-libs/cgicc/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <longdescription lang="en">
+GNU cgicc is an ANSI C++ compliant class library that greatly
+simplifies the creation of CGI applications for the World Wide
+Web. cgicc performs the following functions:
+
+ - Parses both GET and POST form data transparently
+ - Provides string, integer, floating-point and single- and
+ multiple-choice retrieval methods for form data
+ - Provides methods for saving and restoring CGI environments to aid
+ in application debugging
+ - Provides full on-the-fly HTML 4.0 generation capabilities, with support
+ for cookies
+ - Supports HTTP file upload
+ - Compatible with FastCGI
+ </longdescription>
+</pkgmetadata>
+