summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-12 22:18:20 +0200
committerDavid Seifert <soap@gentoo.org>2023-08-12 22:18:20 +0200
commit6d008b0de933e108110eabe3f2764fc8f79ba1c4 (patch)
tree595068e6a49f8d95dd72700367e8a899d71a5551 /dev-libs/boost
parentwww-servers/nginx-unit: Remove masked php7.4 dependency (diff)
downloadgentoo-6d008b0de933e108110eabe3f2764fc8f79ba1c4.tar.gz
gentoo-6d008b0de933e108110eabe3f2764fc8f79ba1c4.tar.bz2
gentoo-6d008b0de933e108110eabe3f2764fc8f79ba1c4.zip
dev-libs/boost: add USE=stacktrace
* required for media-gfx/inkscape-1.3 Bug: https://bugs.gentoo.org/689300 Bug: https://bugs.gentoo.org/911267 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.83.0-r1.ebuild (renamed from dev-libs/boost/boost-1.83.0.ebuild)4
-rw-r--r--dev-libs/boost/metadata.xml1
2 files changed, 3 insertions, 2 deletions
diff --git a/dev-libs/boost/boost-1.83.0.ebuild b/dev-libs/boost/boost-1.83.0-r1.ebuild
index 8d2a073b2795..8e14335b1d96 100644
--- a/dev-libs/boost/boost-1.83.0.ebuild
+++ b/dev-libs/boost/boost-1.83.0-r1.ebuild
@@ -17,7 +17,7 @@ S="${WORKDIR}/${PN}_${MY_PV}"
LICENSE="Boost-1.0"
SLOT="0/${PV}" # ${PV} instead of the major version due to bug 486122
#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="bzip2 context debug doc icu lzma +nls mpi numpy python tools zlib zstd"
+IUSE="bzip2 context debug doc icu lzma +nls mpi numpy python stacktrace tools zlib zstd"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# the tests will never fail because these are not intended as sanity
# tests at all. They are more a way for upstream to check their own code
@@ -162,7 +162,7 @@ src_configure() {
$(usev !mpi --without-mpi)
$(usev !nls --without-locale)
$(usev !context '--without-context --without-coroutine --without-fiber')
- --without-stacktrace
+ $(usev !stacktrace --without-stacktrace)
--boost-build="${BROOT}"/usr/share/b2/src
--layout=system
# building with threading=single is currently not possible
diff --git a/dev-libs/boost/metadata.xml b/dev-libs/boost/metadata.xml
index 98eea6f8a059..ba1a98dcc43b 100644
--- a/dev-libs/boost/metadata.xml
+++ b/dev-libs/boost/metadata.xml
@@ -15,6 +15,7 @@
<flag name="doc">Install the full API documentation documentation. This takes over 200MB of extra disk space.</flag>
<flag name="nls">Build libboost_locale. This library requires compatible C library interfaces, which might not be provided by uClibc or other embedded libraries.</flag>
<flag name="numpy">Optionally build NumPy extensions when Boost.Python is enabled</flag>
+ <flag name="stacktrace">Build the full Boost.Stacktrace dynamic library instead of relying on the header-only implementation</flag>
<flag name="tools">Build and install the boost tools (bcp, quickbook, inspect, wave)</flag>
</use>
<upstream>