summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 09:43:46 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:21:34 +0200
commitb766bcfeeb40ced7e46ec044f7cead0b61d6130b (patch)
tree31ccd51cffbd5dd67692bd52eecad718548dac0c /dev-libs/boost-numpy
parentdev-libs/beecrypt: [QA] Add missing python metadata variables (diff)
downloadgentoo-b766bcfeeb40ced7e46ec044f7cead0b61d6130b.tar.gz
gentoo-b766bcfeeb40ced7e46ec044f7cead0b61d6130b.tar.bz2
gentoo-b766bcfeeb40ced7e46ec044f7cead0b61d6130b.zip
dev-libs/boost-numpy: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/boost-numpy')
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
index 91b8d05c2885..1b24caed83e7 100644
--- a/dev-libs/boost-numpy/boost-numpy-9999.ebuild
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
inherit cmake-utils python-single-r1
DESCRIPTION="Boost.Python interface for NumPy"
HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
-if [ ${PV} == 9999 ]; then
+
+if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/ndarray/Boost.NumPy.git \
https://github.com/ndarray/Boost.NumPy.git"
@@ -21,11 +23,13 @@ SLOT=0
KEYWORDS=""
IUSE="doc examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-CDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
dev-libs/boost[python,${PYTHON_USEDEP}]"
-DEPEND="${CDEPEND}"
-RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
src_prepare() {
# Make sure that new Python ABI names are searched too