summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-10-11 13:20:21 +0100
committerMatthew Smith <matthew@gentoo.org>2023-10-11 13:21:49 +0100
commitf8943e7ddc1668226fd2ba1da0b1837c44d558c3 (patch)
tree8b1ee33eb16a65b79920544e1c6a70d4298aa45f /dev-lang
parentdev-python/graph-tool: drop 2.57 (diff)
downloadgentoo-f8943e7ddc1668226fd2ba1da0b1837c44d558c3.tar.gz
gentoo-f8943e7ddc1668226fd2ba1da0b1837c44d558c3.tar.bz2
gentoo-f8943e7ddc1668226fd2ba1da0b1837c44d558c3.zip
dev-lang/erlang: add libei fix to erlang-25.3
Closes: https://bugs.gentoo.org/915566 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/erlang-25.3.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-lang/erlang/erlang-25.3.ebuild b/dev-lang/erlang/erlang-25.3.ebuild
index 71f106edbf6a..554952363897 100644
--- a/dev-lang/erlang/erlang-25.3.ebuild
+++ b/dev-lang/erlang/erlang-25.3.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER="3.0-gtk3"
-inherit elisp-common flag-o-matic java-pkg-opt-2 systemd toolchain-funcs wxwidgets
+inherit autotools elisp-common flag-o-matic java-pkg-opt-2 systemd toolchain-funcs wxwidgets
# NOTE: If you need symlinks for binaries please tell maintainers or
# open up a bug to let it be created.
@@ -60,6 +60,14 @@ src_prepare() {
# bug #797886: erlang's VM does unsafe casts for ints
# to pointers and back. This breaks on gcc-11 -flto.
append-flags -fno-strict-aliasing
+
+ # Ensure that we use erl_interface's libei.a, and not the system
+ # libei.so from dev-libs/libei. Bug #912888.
+ sed -i 's/-lei$/-l:libei.a/' \
+ "${S}"/lib/odbc/c_src/Makefile.in || die
+ (cd "${S}"/lib/odbc &&
+ eautoconf -B "${S}"/make/autoconf &&
+ eautoheader -B "${S}"/make/autoconf) || die
}
src_configure() {