summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-10-22 23:22:29 +0600
committerSam James <sam@gentoo.org>2023-10-27 03:53:04 +0100
commiteded707d05b3a2ad50ee8c5c9682cd9617bf2a92 (patch)
treea375d9aeb92db67be60782843f0d1f26f2d8e98f /dev-lang
parentdev-lang/zig: add simple `zig env` invocation to check if compiler built itse... (diff)
downloadgentoo-eded707d05b3a2ad50ee8c5c9682cd9617bf2a92.tar.gz
gentoo-eded707d05b3a2ad50ee8c5c9682cd9617bf2a92.tar.bz2
gentoo-eded707d05b3a2ad50ee8c5c9682cd9617bf2a92.zip
dev-lang/zig: explicitly set locations for build cache
Useful for debugging and a little bit more deterministic than before. Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/33272 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/zig/zig-0.11.0-r1.ebuild4
-rw-r--r--dev-lang/zig/zig-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/zig/zig-0.11.0-r1.ebuild b/dev-lang/zig/zig-0.11.0-r1.ebuild
index 90ffaa485d7e..633b6e1c6399 100644
--- a/dev-lang/zig/zig-0.11.0-r1.ebuild
+++ b/dev-lang/zig/zig-0.11.0-r1.ebuild
@@ -112,6 +112,10 @@ pkg_setup() {
}
src_configure() {
+ # Useful for debugging and a little bit more deterministic.
+ export ZIG_LOCAL_CACHE_DIR="${T}/zig-local-cache"
+ export ZIG_GLOBAL_CACHE_DIR="${T}/zig-global-cache"
+
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
-DZIG_SHARED_LLVM=ON
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index 026d60e5a854..9605234cfc43 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -108,6 +108,10 @@ pkg_setup() {
}
src_configure() {
+ # Useful for debugging and a little bit more deterministic.
+ export ZIG_LOCAL_CACHE_DIR="${T}/zig-local-cache"
+ export ZIG_GLOBAL_CACHE_DIR="${T}/zig-global-cache"
+
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
-DZIG_SHARED_LLVM=ON