summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-21 14:39:26 -0500
committerMatt Turner <mattst88@gentoo.org>2019-11-23 16:41:20 -0500
commite3633014ee6b3f8d556d44cc59b5ec6ebf516504 (patch)
tree257e0f759ed67c37e5e14d7ac41d3d84d9699ccf /dev-lang
parentx11-wm/mutter: Add patch to build with mesa-19.3 (diff)
downloadgentoo-e3633014ee6b3f8d556d44cc59b5ec6ebf516504.tar.gz
gentoo-e3633014ee6b3f8d556d44cc59b5ec6ebf516504.tar.bz2
gentoo-e3633014ee6b3f8d556d44cc59b5ec6ebf516504.zip
dev-lang/orc: Version bump to 0.4.31
- Convert to Meson (autotools build system was removed) - EAPI=7 - Drop Darwin hack - Drop IUSE=pax_kernel Bug: https://bugs.gentoo.org/691804 Closes: https://bugs.gentoo.org/554600 Closes: https://bugs.gentoo.org/645232 Closes: https://bugs.gentoo.org/698272 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/Manifest1
-rw-r--r--dev-lang/orc/orc-0.4.31.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
index 18a95f669b62..8df1a57c6ab0 100644
--- a/dev-lang/orc/Manifest
+++ b/dev-lang/orc/Manifest
@@ -1,2 +1,3 @@
DIST orc-0.4.28.tar.xz 469460 BLAKE2B 86fa2d10a33fbffbb2b96827adbddaa81d0baa8135fe21fba338cbcd25a1c1e853873ec1c4ef5c0a32d66ba95f855f1f16ddbc32f68a89e5a98c75b9b0261aa7 SHA512 2ae3100e7d0c03eba9a8a10a8924da4d729e1967b63e5dfdf88c4aee907d7ece82c782d74f4cb7e28a366dd74ce5e1ddc6e2b971e5a2f879b0501cc313b93410
DIST orc-0.4.29.tar.xz 465076 BLAKE2B f7c81429d95af7031f190a4c3d52959eda1835d3092493e3fa15e4b6719290c1c1f23459448f7c499ba4085ad8d7b9f49e687521d76823a1e8ce6d3916b39a37 SHA512 57aa75bbefa9ba9ffcce97affd504c13c57612e2409863c011555bed6ff6ba224d38ed66b715bf103679a8ee28ddae427db3d78c7b4a2ddfa7dbd72a4fa81726
+DIST orc-0.4.31.tar.xz 177768 BLAKE2B f06fd6be70063ebc82b45c1801a53aab66b5fc8a85c33991602488ec8ed29f2271df20c3780655953cabe33e865530b1218aafa0592261bcc5dccc4a4b3945e7 SHA512 4e97597e70982dbfc239d1ef9a8913b0155e5aaac15d91162d7f73a1095bd944e27fbe6d6194b9f74af07b985a44b1d9dddbe917425e1ad9e8da17ce86495696
diff --git a/dev-lang/orc/orc-0.4.31.ebuild b/dev-lang/orc/orc-0.4.31.ebuild
new file mode 100644
index 000000000000..44f4b73a4ed7
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.31.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs test"
+
+DEPEND=""
+RDEPEND=""
+
+multilib_src_configure() {
+ # FIXME: handle backends per arch? What about cross-compiling for the other arches?
+ local emesonargs=(
+ $(meson_feature test tests)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dorc-backend=all
+ -Dbenchmarks=disabled
+ -Dexamples=disabled
+ -Dgtk_doc=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}