summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-12-08 16:50:45 -0500
committerSam James <sam@gentoo.org>2024-12-12 05:14:40 +0000
commitbd3da2e7e03076dda7c5b42f9c8b33b70048582c (patch)
tree7128c0ec8c6b10b47c66b6caba2c96b58a1a2ca7 /dev-lang
parentmedia-libs/openjpeg: add 2.5.3 (diff)
downloadgentoo-bd3da2e7e03076dda7c5b42f9c8b33b70048582c.tar.gz
gentoo-bd3da2e7e03076dda7c5b42f9c8b33b70048582c.tar.bz2
gentoo-bd3da2e7e03076dda7c5b42f9c8b33b70048582c.zip
dev-lang/regina-rexx: add 3.9.6
Closes: https://bugs.gentoo.org/944237 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/39641 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/regina-rexx/Manifest1
-rw-r--r--dev-lang/regina-rexx/files/regina-rexx-3.9.6-makefile.patch211
-rw-r--r--dev-lang/regina-rexx/regina-rexx-3.9.6.ebuild54
3 files changed, 266 insertions, 0 deletions
diff --git a/dev-lang/regina-rexx/Manifest b/dev-lang/regina-rexx/Manifest
index 3d295cd2b71f..4c94788d0f43 100644
--- a/dev-lang/regina-rexx/Manifest
+++ b/dev-lang/regina-rexx/Manifest
@@ -1 +1,2 @@
DIST regina-rexx-3.9.5.tar.gz 2705272 BLAKE2B f26d4c7c582e1dafb97c2280651d07bba67549ccf9f58eb42e88e92ddbbb3184a36e5d3480977adccafdd1d9fdd1ca208950cd2700201600b6fbc0da7ebbd336 SHA512 bff25e5d218441306d021924582c19ed29c652b691e73988a4b53b9de4b51b758b1ee08704685967bd9bea469e93bf57b19875207fd4649d5af3e53dade39dd2
+DIST regina-rexx-3.9.6.tar.gz 2705800 BLAKE2B d869f9285e0fa0810b690d97932059aa6d3aaf0d99355bad18ffd480cc322a076928d08fce03893124a0ebd330a55ac9b6c580657e92601d8204a2a0b3c15406 SHA512 17f02afea59daa994f4ff1499914b80ed8da8109237e02ed18ab9194e532427f2f7f724be0e3345ca133e19a0501f7457f6248caf5de2ab158d17cb0e996db6a
diff --git a/dev-lang/regina-rexx/files/regina-rexx-3.9.6-makefile.patch b/dev-lang/regina-rexx/files/regina-rexx-3.9.6-makefile.patch
new file mode 100644
index 000000000000..7286c0df1d19
--- /dev/null
+++ b/dev-lang/regina-rexx/files/regina-rexx-3.9.6-makefile.patch
@@ -0,0 +1,211 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4ce427b..c2278ad 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -323,7 +323,7 @@ JUNK = *.o *.so.$(OBJ) $(STATICLIB) execiser$(binarybitprefix)$(EXE) threader$(b
+ #
+ .SUFFIXES:
+
+-all : rexx$(binarybitprefix)$(EXE) $(STATICLIB) execiser$(binarybitprefix)$(EXE) $(SHL_TARGETS) $(THREADSAFE_TARGET) rxstack$(binarybitprefix)$(EXE) rxqueue$(binarybitprefix)$(EXE) $(MTBFILES)
++all : rexx$(binarybitprefix)$(EXE) execiser$(binarybitprefix)$(EXE) $(SHL_TARGETS) $(THREADSAFE_TARGET) rxstack$(binarybitprefix)$(EXE) rxqueue$(binarybitprefix)$(EXE) $(MTBFILES)
+
+ $(srcdir)/rexx.h : $(srcdir)/extern.h $(srcdir)/strengs.h $(srcdir)/defs.h $(srcdir)/regina_t.h $(srcdir)/mt.h
+
+@@ -1070,11 +1070,6 @@ installbase: all
+ $(INSTALL) -m 644 -c $(srcdir)/regina-config.1 $(DESTDIR)$(mandir)/man1/regina-config.1
+ $(INSTALL) -m 644 -c $(srcdir)/rxstack.1 $(DESTDIR)$(mandir)/man1/rxstack.1
+ $(INSTALL) -m 644 -c $(srcdir)/rxqueue.1 $(DESTDIR)$(mandir)/man1/rxqueue.1
+- gzip -f $(DESTDIR)$(mandir)/man1/regina.1
+- gzip -f $(DESTDIR)$(mandir)/man1/rexx.1
+- gzip -f $(DESTDIR)$(mandir)/man1/regina-config.1
+- gzip -f $(DESTDIR)$(mandir)/man1/rxstack.1
+- gzip -f $(DESTDIR)$(mandir)/man1/rxqueue.1
+ $(INSTALL) -m 644 -c $(srcdir)/rexxsaa.h $(DESTDIR)$(includedir)/rexxsaa.h
+ $(INSTALL) -m 644 -c ./en.mtb $(DESTDIR)$(sharedir)/en.mtb
+ $(INSTALL) -m 644 -c ./pt.mtb $(DESTDIR)$(sharedir)/pt.mtb
+diff --git a/common/incdebug.m4 b/common/incdebug.m4
+index 14c106e..86e4135 100644
+--- a/common/incdebug.m4
++++ b/common/incdebug.m4
+@@ -15,67 +15,6 @@ DEBUGGING=""
+ cflags_g="`echo $CFLAGS | grep -c '\-g'`"
+ cflags_O="`echo $CFLAGS | grep -c '\-O'`"
+
+-if test "$with_debug" = yes; then
+- DEBUG="-DDEBUG"
+- DEBUGGING="-g"
+- if test "$cflags_g" = "0"; then
+- CFLAGS="${CFLAGS} -g"
+- fi
+- if test "$cflags_O" != "0"; then
+- CFLAGS="`echo ${CFLAGS} | sed -e s/-O.//`"
+- fi
+-else
+- DEBUG="-DNDEBUG"
+- if test "$cflags_O" = "0"; then
+- CFLAGS="${CFLAGS} -O"
+- fi
+- if test "$cflags_g" = "0"; then
+- CFLAGS="${CFLAGS} -g"
+- fi
+-fi
+-if test "$ac_cv_prog_CC" = "gcc" -o "$ac_cv_prog_CC" = "g++" -o "$ac_cv_prog_CC" = "clang"; then
+- if test "$with_debug" = yes; then
+- CFLAGS="${CFLAGS} -Wall"
+- else
+- CFLAGS="${CFLAGS} -O3 -Wall -fomit-frame-pointer -fno-strict-aliasing -Wno-char-subscripts"
+- fi
+-fi
+-if test "$on_qnx4" = yes; then
+- if test "$ac_cv_prog_CC" = "gcc"; then
+- QNX4_CFLAGS=""
+- else
+- if test "$SIMPLE_CFLAGS" = "yes"; then
+- QNX4_CFLAGS="-O"
+- else
+- QNX4_CFLAGS="-Wc,-r -b -j -Wc,-ei -N4096000 -mf -DNO_REGEX -DQNX -DQNX4 -D__QNX__ -DSTRINGS_ALIGNED -Q"
+- fi
+- fi
+- if test "$with_debug" = yes; then
+- CFLAGS="-g $QNX4_CFLAGS"
+- else
+- CFLAGS="-Otax $QNX4_CFLAGS"
+- fi
+-fi
+-if test "$on_beos" = yes; then
+- if test "$with_debug" = yes; then
+- CFLAGS="${CFLAGS} -Wall"
+- else
+- CFLAGS="${CFLAGS} -O2 -Wall"
+- fi
+- if test "$datadir" = "\${prefix}/share"; then
+- datadir="/boot/home/config/add-ons"
+- fi
+-fi
+-if test "$on_haiku" = yes; then
+- if test "$with_debug" = yes; then
+- CFLAGS="${CFLAGS} -Wall"
+- else
+- CFLAGS="${CFLAGS} -O2 -Wall"
+- fi
+- if test "$datadir" = "\${prefix}/share"; then
+- datadir="/boot/home/config/non-packaged/add-ons"
+- fi
+-fi
+ AC_SUBST(DEBUG)
+ AC_SUBST(DEBUGGING)
+
+diff --git a/common/inclibarch.m4 b/common/inclibarch.m4
+index 993daf2..6a0a11d 100644
+--- a/common/inclibarch.m4
++++ b/common/inclibarch.m4
+@@ -25,96 +25,7 @@ AC_ARG_ENABLE(64bit,
+ gcc_64bit="-m64"
+ gcc_32bit="-m32"
+ on_osx="no"
+-osis64bit=no
+-bitflag="32"
+ MACH_ARCH=`$ac_config_guess | cut -f1 -d-`
+-case "$target" in
+- *hp-hpux*)
+- ;;
+- *ibm-aix*)
+- rc=`lsconf -k | grep -c 64-bit`
+- if test $rc -eq 1; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- #
+- # AIX gcc has its own special bit switches :-(
+- #
+- gcc_64bit="-maix64"
+- gcc_32bit="-maix32"
+- ;;
+- powerpc-ibm-os400)
+- bitflag="64"
+- osis64bit=yes
+- gcc_64bit=""
+- ;;
+- *dec-osf4*)
+- ;;
+- *dec-osf*)
+- ;;
+- *sequent-dynix*)
+- ;;
+- i*86*solaris*)
+- ;;
+- *solaris*)
+- rc=`isainfo -v | grep -c 64-bit`
+- if test $rc -eq 1; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- ;;
+- sparc*sunos*)
+- ;;
+- *linux* | *kfreebsd*-gnu*)
+- mach="`uname -m`"
+- if test "$mach" = "x86_64" -o "$mach" = "ia86" -o "$mach" = "alpha" -o "$mach" = "ppc64" -o "$mach" = "s390x" -o "$mach" = "aarch64" -o "$mach" = "ppc64le"; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+-# if test -f "/etc/os-release"; then
+- # get Linux ID...
+-# fi
+- if test -f "/etc/apk/arch"; then
+- # get Alpine Linux architecture for APK
+- MACH_ARCH="`cat /etc/apk/arch`"
+- fi
+- ;;
+- *-freebsd* | *-openbsd* | *-netbsd*)
+- mach="`uname -m`"
+- if test "$mach" = "amd64"; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- ;;
+- *nto-qnx*)
+- ;;
+- *qnx*)
+- ;;
+- *beos*)
+- ;;
+- *haiku*)
+- mach="`uname -m`"
+- if test "$mach" = "x86_64"; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- ;;
+- *cygwin*)
+- mach="`uname -m`"
+- if test "$mach" = "x86_64"; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- ;;
+- *apple-darwin*)
+- on_osx="yes"
+- osx_64bit=`sysctl hw.cpu64bit_capable | cut -f2 -d' '`
+- if test $osx_64bit -eq 1; then
+- bitflag="64"
+- osis64bit=yes
+- fi
+- ;;
+-esac
+
+ if test "x$bitflag32" = "xyes" -a "x$bitflag64" = "xyes"; then
+ AC_MSG_ERROR(--enable-32bit and --enable-64bit flags cannot both be specified.)
+diff --git a/configure.in b/configure.in
+index bed60d6..ffc5b83 100644
+--- a/configure.in
++++ b/configure.in
+@@ -30,7 +30,7 @@ cp $srcdir/common/config.sub $srcdir
+
+ dnl ---------------------- check for C compiler -----------------
+ dnl Checks for one of the C compilers below - change if yours not there.
+-MH_PROG_CC
++AC_PROG_CC
+
+ AC_CONFIG_HEADER(config.h)
+ AC_ISC_POSIX
diff --git a/dev-lang/regina-rexx/regina-rexx-3.9.6.ebuild b/dev-lang/regina-rexx/regina-rexx-3.9.6.ebuild
new file mode 100644
index 000000000000..03382912c5a1
--- /dev/null
+++ b/dev-lang/regina-rexx/regina-rexx-3.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="Portable Rexx interpreter"
+HOMEPAGE="https://regina-rexx.sourceforge.io/"
+SRC_URI="https://downloads.sourceforge.net/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="virtual/libcrypt:=
+ !dev-lang/oorexx"
+
+PATCHES=( "${FILESDIR}/${PN}-3.9.6-makefile.patch" )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i "s/\$(INSTALL) -s/\$(INSTALL)/g" Makefile.in || die
+ sed -E -i "s/\\$\(INSTALL\) -m ([0-9]{3}) -c/\$\(INSTALL\) -m \1 -c -D/g" Makefile.in || die
+ sed -E -i "s/\\$\(INSTALL\) -c -m ([0-9]{3})/\$\(INSTALL\) -c -m \1 -D/g" Makefile.in || die
+ eautoconf
+}
+
+src_configure() {
+ append-cflags "$(test-flags-CC -std=gnu17)" # bug 944237
+ local bits="$(( "$(tc-get-ptr-size)" * 8))"
+ econf "bitflag=${bits}" "osis${bits}bit=yes" "--enable-${bits}bit"
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake -j1 INSTALL="$(command -v install)" DESTDIR="${D}" install
+ DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
+ einstalldocs
+
+ newinitd "${FILESDIR}/rxstack-r1" rxstack
+}
+
+pkg_postinst() {
+ elog "You may want to run"
+ elog
+ elog "\trc-update add rxstack default"
+ elog
+ elog "to enable Rexx queues (optional)."
+}