summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-24 10:55:57 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-24 12:17:05 +0100
commit8fc8ad0d748cd320ce825383c289ea3281c8cc2e (patch)
tree90aac0e4ca8ff2b67376a29df95e5e85ac45258a /dev-lang
parentprofiles: unmask open-cobol, I will take care of it (diff)
downloadgentoo-8fc8ad0d748cd320ce825383c289ea3281c8cc2e.tar.gz
gentoo-8fc8ad0d748cd320ce825383c289ea3281c8cc2e.tar.bz2
gentoo-8fc8ad0d748cd320ce825383c289ea3281c8cc2e.zip
dev-lang/open-cobol: prepare for move to gnucobol
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/open-cobol/metadata.xml12
-rw-r--r--dev-lang/open-cobol/open-cobol-1.1.ebuild7
2 files changed, 17 insertions, 2 deletions
diff --git a/dev-lang/open-cobol/metadata.xml b/dev-lang/open-cobol/metadata.xml
index e94ff8ae58cb..deafad69d61d 100644
--- a/dev-lang/open-cobol/metadata.xml
+++ b/dev-lang/open-cobol/metadata.xml
@@ -5,6 +5,18 @@
<email>patrick@gentoo.org</email>
<name>Patrick Lauer</name>
</maintainer>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Alfredo Tupone</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>anton.kochkov@gmail.com</email>
+ <name>Anton Kochkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">open-cobol</remote-id>
</upstream>
diff --git a/dev-lang/open-cobol/open-cobol-1.1.ebuild b/dev-lang/open-cobol/open-cobol-1.1.ebuild
index d7fd39c417a0..fa480cae9180 100644
--- a/dev-lang/open-cobol/open-cobol-1.1.ebuild
+++ b/dev-lang/open-cobol/open-cobol-1.1.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PN="open-cobol"
+MYP=${MY_PN}-${PV}
# Future proof pkg if maintainer or p-m want to bump to latest GNUCobol
DESCRIPTION="an open-source COBOL compiler"
HOMEPAGE="https://sourceforge.net/projects/open-cobol/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MYP}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
# License must be changed to GPL-3+ if/when pkgmove is done
@@ -25,6 +26,8 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS ChangeLog NEWS README )
+S="${WORKDIR}"/${MYP}
+
src_configure() {
econf \
$(use_with berkdb db) \