summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-07 09:02:54 +0100
committerSam James <sam@gentoo.org>2022-06-07 09:04:59 +0100
commit5f58c0be83b23be42aa2e6452c4b4bfd875fcbbb (patch)
treeb1e1ea7bf28bd209073b1773320672d47e6184ec /dev-lang
parentsci-libs/libsigrok: Stabilize 0.5.2-r3 x86, #849902 (diff)
downloadgentoo-5f58c0be83b23be42aa2e6452c4b4bfd875fcbbb.tar.gz
gentoo-5f58c0be83b23be42aa2e6452c4b4bfd875fcbbb.tar.bz2
gentoo-5f58c0be83b23be42aa2e6452c4b4bfd875fcbbb.zip
dev-lang/python: drop long-obsolete SSP / -O3 workaround
Everyone in Gentoo (unless they unforce defaults) had, for years now, -fstack-protector-all on, or nowadays, -fstack-protector-strong. This means that it won't have been explicitly in *FLAGS and hence the replacement won't have been triggered anyway. Plus, the hardened conditional is irrelevant given the above (it uses no more SSP than the default, because the default is what hardened used to be, many years ago). Bug: https://bugs.gentoo.org/50309 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.7.18_p15.ebuild6
-rw-r--r--dev-lang/python/python-3.10.5.ebuild6
-rw-r--r--dev-lang/python/python-3.11.0_beta3.ebuild6
-rw-r--r--dev-lang/python/python-3.8.13_p2.ebuild6
-rw-r--r--dev-lang/python/python-3.9.13.ebuild6
5 files changed, 0 insertions, 30 deletions
diff --git a/dev-lang/python/python-2.7.18_p15.ebuild b/dev-lang/python/python-2.7.18_p15.ebuild
index 97ebaf232b12..ae39dfe4b580 100644
--- a/dev-lang/python/python-2.7.18_p15.ebuild
+++ b/dev-lang/python/python-2.7.18_p15.ebuild
@@ -146,12 +146,6 @@ src_configure() {
filter-flags -malign-double
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
if tc-is-cross-compiler; then
# Force some tests that try to poke fs paths.
export ac_cv_file__dev_ptc=no
diff --git a/dev-lang/python/python-3.10.5.ebuild b/dev-lang/python/python-3.10.5.ebuild
index 87ba9d3a2e1d..18d079692b96 100644
--- a/dev-lang/python/python-3.10.5.ebuild
+++ b/dev-lang/python/python-3.10.5.ebuild
@@ -151,12 +151,6 @@ src_configure() {
filter-flags -malign-double
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
# https://bugs.gentoo.org/700012
if is-flagq -flto || is-flagq '-flto=*'; then
append-cflags $(test-flags-CC -ffat-lto-objects)
diff --git a/dev-lang/python/python-3.11.0_beta3.ebuild b/dev-lang/python/python-3.11.0_beta3.ebuild
index 57e6c4928123..155e017bf32a 100644
--- a/dev-lang/python/python-3.11.0_beta3.ebuild
+++ b/dev-lang/python/python-3.11.0_beta3.ebuild
@@ -138,12 +138,6 @@ src_configure() {
filter-flags -malign-double
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
# https://bugs.gentoo.org/700012
if is-flagq -flto || is-flagq '-flto=*'; then
append-cflags $(test-flags-CC -ffat-lto-objects)
diff --git a/dev-lang/python/python-3.8.13_p2.ebuild b/dev-lang/python/python-3.8.13_p2.ebuild
index ef56899f1fee..d207e46c5342 100644
--- a/dev-lang/python/python-3.8.13_p2.ebuild
+++ b/dev-lang/python/python-3.8.13_p2.ebuild
@@ -134,12 +134,6 @@ src_configure() {
filter-flags -malign-double
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
# https://bugs.gentoo.org/700012
if is-flagq -flto || is-flagq '-flto=*'; then
append-cflags $(test-flags-CC -ffat-lto-objects)
diff --git a/dev-lang/python/python-3.9.13.ebuild b/dev-lang/python/python-3.9.13.ebuild
index ace30db0b27b..5bf7ffed2667 100644
--- a/dev-lang/python/python-3.9.13.ebuild
+++ b/dev-lang/python/python-3.9.13.ebuild
@@ -146,12 +146,6 @@ src_configure() {
filter-flags -malign-double
- # https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flagq -O3; then
- is-flagq -fstack-protector-all && replace-flags -O3 -O2
- use hardened && replace-flags -O3 -O2
- fi
-
# https://bugs.gentoo.org/700012
if is-flagq -flto || is-flagq '-flto=*'; then
append-cflags $(test-flags-CC -ffat-lto-objects)