summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-lang
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gforth/gforth-0.7.3-r1.ebuild2
-rw-r--r--dev-lang/logtalk/logtalk-3.11.2.ebuild2
-rw-r--r--dev-lang/logtalk/logtalk-3.18.0.ebuild2
-rw-r--r--dev-lang/lua/lua-5.2.3.ebuild5
-rw-r--r--dev-lang/mercury-extras/mercury-extras-14.01.1.ebuild42
-rw-r--r--dev-lang/mercury/mercury-14.01.1-r1.ebuild19
-rw-r--r--dev-lang/mlton/mlton-20130715.ebuild10
-rw-r--r--dev-lang/opendylan/opendylan-2013.1-r1.ebuild6
-rw-r--r--dev-lang/opendylan/opendylan-2013.2.ebuild6
-rw-r--r--dev-lang/opendylan/opendylan-2014.1.ebuild6
-rw-r--r--dev-lang/opendylan/opendylan-9999.ebuild4
-rw-r--r--dev-lang/parrot/parrot-7.1.0-r1.ebuild16
-rw-r--r--dev-lang/parrot/parrot-7.11.0-r1.ebuild16
-rw-r--r--dev-lang/parrot/parrot-7.5.0-r1.ebuild16
-rw-r--r--dev-lang/parrot/parrot-8.1.0-r1.ebuild16
-rw-r--r--dev-lang/pcc/pcc-1.1.0-r1.ebuild4
-rw-r--r--dev-lang/pcc/pcc-9999.ebuild4
-rw-r--r--dev-lang/polyml/polyml-5.4.1.ebuild2
-rw-r--r--dev-lang/polyml/polyml-5.5.0.ebuild2
-rw-r--r--dev-lang/polyml/polyml-5.5.1.ebuild2
-rw-r--r--dev-lang/polyml/polyml-5.5.2.ebuild2
-rw-r--r--dev-lang/polyml/polyml-5.6.ebuild2
-rw-r--r--dev-lang/polyml/polyml-5.8.ebuild2
-rw-r--r--dev-lang/ruby/ruby-2.4.9.ebuild11
-rw-r--r--dev-lang/ruby/ruby-2.5.7.ebuild11
-rw-r--r--dev-lang/ruby/ruby-2.6.5.ebuild13
-rw-r--r--dev-lang/smlnj/smlnj-110.75.ebuild4
-rw-r--r--dev-lang/whitespace/whitespace-0.3.ebuild4
-rw-r--r--dev-lang/xsb/xsb-3.6.0.ebuild76
29 files changed, 151 insertions, 156 deletions
diff --git a/dev-lang/gforth/gforth-0.7.3-r1.ebuild b/dev-lang/gforth/gforth-0.7.3-r1.ebuild
index ef990ca837bc..0a50f9613e86 100644
--- a/dev-lang/gforth/gforth-0.7.3-r1.ebuild
+++ b/dev-lang/gforth/gforth-0.7.3-r1.ebuild
@@ -31,7 +31,7 @@ src_configure() {
src_compile() {
# Parallel make breaks here
- emake -j1 || die "emake failed"
+ emake -j1
}
src_install() {
diff --git a/dev-lang/logtalk/logtalk-3.11.2.ebuild b/dev-lang/logtalk/logtalk-3.11.2.ebuild
index a9cb4028bfed..6a29f2f8591b 100644
--- a/dev-lang/logtalk/logtalk-3.11.2.ebuild
+++ b/dev-lang/logtalk/logtalk-3.11.2.ebuild
@@ -46,7 +46,7 @@ src_install() {
rm -f man/man1/logtalk_backend_select.1
rm -f man/man1/logtalk_version_select.1
- doman man/man1/*.1 || die "Failed to install man pages"
+ doman man/man1/*.1
# Integration symlinks
dosym /usr/share/${P}/integration/logtalk_user_setup.sh \
diff --git a/dev-lang/logtalk/logtalk-3.18.0.ebuild b/dev-lang/logtalk/logtalk-3.18.0.ebuild
index f7bd2a861f1c..ebc48ba9a70b 100644
--- a/dev-lang/logtalk/logtalk-3.18.0.ebuild
+++ b/dev-lang/logtalk/logtalk-3.18.0.ebuild
@@ -48,7 +48,7 @@ src_install() {
rm -f man/man1/logtalk_backend_select.1
rm -f man/man1/logtalk_version_select.1
- doman man/man1/*.1 || die "Failed to install man pages"
+ doman man/man1/*.1
# Integration symlinks
dosym ../share/${P}/integration/logtalk_user_setup.sh \
diff --git a/dev-lang/lua/lua-5.2.3.ebuild b/dev-lang/lua/lua-5.2.3.ebuild
index 1dc833e32a07..06d5e005376f 100644
--- a/dev-lang/lua/lua-5.2.3.ebuild
+++ b/dev-lang/lua/lua-5.2.3.ebuild
@@ -86,13 +86,12 @@ src_compile() {
LUA_LIBS="${mylibs}" \
LIB_LIBS="${liblibs}" \
V=$(get_version_component_range 1-2) \
- gentoo_all || die "emake failed"
+ gentoo_all
}
src_install() {
emake INSTALL_TOP="${ED}/usr" INSTALL_LIB="${ED}/usr/$(get_libdir)" \
- V=${SLOT} gentoo_install \
- || die "emake install gentoo_install failed"
+ V=${SLOT} gentoo_install
dodoc README
dohtml doc/*.html doc/*.png doc/*.css doc/*.gif
diff --git a/dev-lang/mercury-extras/mercury-extras-14.01.1.ebuild b/dev-lang/mercury-extras/mercury-extras-14.01.1.ebuild
index cd9279191c5b..11bd6cc09b48 100644
--- a/dev-lang/mercury-extras/mercury-extras-14.01.1.ebuild
+++ b/dev-lang/mercury-extras/mercury-extras-14.01.1.ebuild
@@ -129,71 +129,71 @@ src_install() {
cd "${S}"
if use examples; then
insinto /usr/share/doc/${PF}/samples/base64
- doins base64/*.m || die
+ doins base64/*.m
insinto /usr/share/doc/${PF}/samples/complex_numbers
- doins complex_numbers/samples/* || die
+ doins complex_numbers/samples/*
insinto /usr/share/doc/${PF}/samples/dynamic_linking
- doins dynamic_linking/hello.m || die
+ doins dynamic_linking/hello.m
insinto /usr/share/doc/${PF}/samples/error
- doins error/* || die
+ doins error/*
insinto /usr/share/doc/${PF}/samples/fixed
- doins fixed/*.m || die
+ doins fixed/*.m
insinto /usr/share/doc/${PF}/samples/gator
- doins -r gator/* || die
+ doins -r gator/*
insinto /usr/share/doc/${PF}/samples/lex
- doins lex/samples/* || die
+ doins lex/samples/*
insinto /usr/share/doc/${PF}/samples/log4m
- doins log4m/*.m || die
+ doins log4m/*.m
insinto /usr/share/doc/${PF}/samples/monte
- doins monte/*.m || die
+ doins monte/*.m
insinto /usr/share/doc/${PF}/samples/moose
- doins moose/samples/* || die
+ doins moose/samples/*
insinto /usr/share/doc/${PF}/samples/net
- doins net/*.m || die
+ doins net/*.m
if use ncurses; then
insinto /usr/share/doc/${PF}/samples/curs
- doins curs/samples/* || die
+ doins curs/samples/*
insinto /usr/share/doc/${PF}/samples/curses
- doins curses/sample/* || die
+ doins curses/sample/*
fi
if use X; then
insinto /usr/share/doc/${PF}/samples/graphics
- doins graphics/easyx/samples/*.m || die
+ doins graphics/easyx/samples/*.m
fi
if use glut && use opengl; then
insinto /usr/share/doc/${PF}/samples/graphics
- doins graphics/samples/calc/* || die
- doins graphics/samples/gears/* || die
- doins graphics/samples/maze/* || die
- doins graphics/samples/pent/* || die
+ doins graphics/samples/calc/*
+ doins graphics/samples/gears/*
+ doins graphics/samples/maze/*
+ doins graphics/samples/pent/*
fi
if use opengl && use tcl && use tk; then
insinto /usr/share/doc/${PF}/samples/graphics
- doins graphics/samples/pent/*.m || die
+ doins graphics/samples/pent/*.m
fi
if use ssl; then
insinto /usr/share/doc/${PF}/samples/mopenssl
- doins mopenssl/*.m || die
+ doins mopenssl/*.m
fi
ecvs_clean
fi
- dodoc README || die
+ dodoc README
}
diff --git a/dev-lang/mercury/mercury-14.01.1-r1.ebuild b/dev-lang/mercury/mercury-14.01.1-r1.ebuild
index 21f002551abb..25c4317109dd 100644
--- a/dev-lang/mercury/mercury-14.01.1-r1.ebuild
+++ b/dev-lang/mercury/mercury-14.01.1-r1.ebuild
@@ -88,8 +88,7 @@ src_compile() {
# Build Mercury using bootstrap grade
emake \
PARALLEL="'${MAKEOPTS}'" \
- TEXI2DVI="" PDFTEX="" \
- || die "emake failed"
+ TEXI2DVI="" PDFTEX=""
# We can now patch .m Mercury compiler files since we
# have just built mercury_compiler.
@@ -109,7 +108,7 @@ src_compile() {
PARALLEL="'${MAKEOPTS}'" \
MERCURY_COMPILER="${S}"/compiler/mercury_compile \
TEXI2DVI="" PDFTEX="" \
- compiler || die "emake compiler failed"
+ compiler
# The default Mercury grade may not be the same as the bootstrap
# grade. Since src_test() is run before src_install() we compile
@@ -118,7 +117,7 @@ src_compile() {
PARALLEL="'${MAKEOPTS}'" \
MERCURY_COMPILER="${S}"/compiler/mercury_compile \
TEXI2DVI="" PDFTEX="" \
- default_grade || die "emake default_grade failed"
+ default_grade
}
src_test() {
@@ -169,7 +168,7 @@ src_install() {
INSTALL_INFO_DIR="${D}"/usr/share/info \
INSTALL_HTML_DIR="${D}"/usr/share/doc/${PF}/html \
INSTALL_ELISP_DIR="${D}/${SITELISP}"/${PN} \
- install || die "emake install failed"
+ install
if use java; then
keepdir /usr/$(get_libdir)/mercury/modules/java
@@ -190,25 +189,25 @@ src_install() {
RELEASE_NOTES TODO VERSION WORK_IN_PROGRESS || die
if use erlang; then
- dodoc README.Erlang || die
+ dodoc README.Erlang
fi
if use java; then
- dodoc README.Java || die
+ dodoc README.Java
fi
if use examples; then
insinto /usr/share/doc/${PF}/samples
- doins samples/{*.m,README,Mmakefile} || die
+ doins samples/{*.m,README,Mmakefile}
doins -r samples/c_interface \
samples/diff \
samples/muz \
samples/rot13 \
samples/solutions \
- samples/solver_types || die
+ samples/solver_types
if use java; then
- doins -r samples/java_interface || die
+ doins -r samples/java_interface
fi
ecvs_clean "${D}"/usr/share/doc/${PF}/samples
diff --git a/dev-lang/mlton/mlton-20130715.ebuild b/dev-lang/mlton/mlton-20130715.ebuild
index a306bfabb1c3..1e3533a37670 100644
--- a/dev-lang/mlton/mlton-20130715.ebuild
+++ b/dev-lang/mlton/mlton-20130715.ebuild
@@ -79,15 +79,15 @@ src_compile() {
sed -i 's@^MAN_PREFIX_EXTRA :=.*@MAN_PREFIX_EXTRA := /share@' \
Makefile || die 'sed Makefile failed'
- emake -j1 dirs runtime compiler CFLAGS="${CFLAGS}" || die
+ emake -j1 dirs runtime compiler CFLAGS="${CFLAGS}"
pax-mark m "${S}/mlton/mlton-compile"
pax-mark m "${S}/build/lib/mlton-compile"
# Does not support parallel make
- emake -j1 all-no-docs CFLAGS="${CFLAGS}" || die
+ emake -j1 all-no-docs CFLAGS="${CFLAGS}"
if use doc; then
export VARTEXFONTS="${T}/fonts"
- emake docs || die "failed to create documentation"
+ emake docs
fi
fi
}
@@ -101,8 +101,8 @@ src_install() {
pax-mark m "${S}/usr/bin/mlyacc"
mv "${S}/usr" "${D}" || die "mv failed"
else
- emake DESTDIR="${D}" install-no-docs || die
- if use doc; then emake DESTDIR="${D}" TDOC="${D}"/usr/share/doc/${P} install-docs || die; fi
+ emake DESTDIR="${D}" install-no-docs
+ use doc && emake DESTDIR="${D}" TDOC="${D}"/usr/share/doc/${P} install-docs
fi
}
diff --git a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild b/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
index a5a3a00fc97d..78ee3789828b 100644
--- a/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
+++ b/dev-lang/opendylan/opendylan-2013.1-r1.ebuild
@@ -71,9 +71,9 @@ src_configure() {
PATH=/opt/opendylan/bin:$PATH
fi
if use amd64; then
- econf --prefix=/opt/opendylan || die
+ econf --prefix=/opt/opendylan
else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
+ econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
fi
if use x86; then
# Includedir, pointing at something wrong
@@ -87,7 +87,7 @@ src_configure() {
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap || die
+ emake -j1 3-stage-bootstrap
}
src_install() {
diff --git a/dev-lang/opendylan/opendylan-2013.2.ebuild b/dev-lang/opendylan/opendylan-2013.2.ebuild
index 1d752a9bd300..60566f683474 100644
--- a/dev-lang/opendylan/opendylan-2013.2.ebuild
+++ b/dev-lang/opendylan/opendylan-2013.2.ebuild
@@ -76,9 +76,9 @@ src_configure() {
fi
if use amd64; then
- econf --prefix=/opt/opendylan || die
+ econf --prefix=/opt/opendylan
else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
+ econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
fi
if use x86; then
# Includedir, pointing at something wrong
@@ -92,7 +92,7 @@ src_configure() {
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap || die
+ emake -j1 3-stage-bootstrap
}
src_install() {
diff --git a/dev-lang/opendylan/opendylan-2014.1.ebuild b/dev-lang/opendylan/opendylan-2014.1.ebuild
index 6bced74464e6..9bf1ebb1bece 100644
--- a/dev-lang/opendylan/opendylan-2014.1.ebuild
+++ b/dev-lang/opendylan/opendylan-2014.1.ebuild
@@ -72,9 +72,9 @@ src_configure() {
fi
if use amd64; then
- econf --prefix=/opt/opendylan || die
+ econf --prefix=/opt/opendylan
else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
+ econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/
fi
if use x86; then
# Includedir, pointing at something wrong
@@ -88,7 +88,7 @@ src_configure() {
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake -j1 3-stage-bootstrap || die
+ emake -j1 3-stage-bootstrap
}
src_install() {
diff --git a/dev-lang/opendylan/opendylan-9999.ebuild b/dev-lang/opendylan/opendylan-9999.ebuild
index 6315b304da3b..adf7e63d28bd 100644
--- a/dev-lang/opendylan/opendylan-9999.ebuild
+++ b/dev-lang/opendylan/opendylan-9999.ebuild
@@ -46,12 +46,12 @@ src_configure() {
else
PATH=/opt/opendylan/bin/:$PATH
fi
- econf --prefix=/opt/opendylan || die
+ econf --prefix=/opt/opendylan
}
src_compile() {
ulimit -s 32000 # this is naughty build system
- emake -j1 || die
+ emake -j1
}
src_install() {
diff --git a/dev-lang/parrot/parrot-7.1.0-r1.ebuild b/dev-lang/parrot/parrot-7.1.0-r1.ebuild
index 3ba3c774a34c..4c68d410926e 100644
--- a/dev-lang/parrot/parrot-7.1.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-7.1.0-r1.ebuild
@@ -55,27 +55,27 @@ src_configure() {
src_compile() {
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
# occasionally dies in parallel make
- emake -j1 || die
+ emake -j1
if use doc ; then
- emake -j1 html || die
+ emake -j1 html
fi
}
src_test() {
- emake -j1 test || die
+ emake -j1 test
}
src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- dosym parrot-ops2c /usr/bin/ops2c || die
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO
+ dosym parrot-ops2c /usr/bin/ops2c
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
+ doins -r examples/*
fi
if use doc; then
insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
+ doins -r editor
cd docs/html
dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
pmc.html tools.html docs src tools || die
diff --git a/dev-lang/parrot/parrot-7.11.0-r1.ebuild b/dev-lang/parrot/parrot-7.11.0-r1.ebuild
index ecedd1c6ff5f..fe5c23fecbf8 100644
--- a/dev-lang/parrot/parrot-7.11.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-7.11.0-r1.ebuild
@@ -55,27 +55,27 @@ src_configure() {
src_compile() {
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
# occasionally dies in parallel make
- emake -j1 || die
+ emake -j1
if use doc ; then
- emake -j1 html || die
+ emake -j1 html
fi
}
src_test() {
- emake -j1 test || die
+ emake -j1 test
}
src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- dosym parrot-ops2c /usr/bin/ops2c || die
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO
+ dosym parrot-ops2c /usr/bin/ops2c
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
+ doins -r examples/*
fi
if use doc; then
insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
+ doins -r editor
cd docs/html
dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
pmc.html tools.html docs src tools || die
diff --git a/dev-lang/parrot/parrot-7.5.0-r1.ebuild b/dev-lang/parrot/parrot-7.5.0-r1.ebuild
index ecedd1c6ff5f..fe5c23fecbf8 100644
--- a/dev-lang/parrot/parrot-7.5.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-7.5.0-r1.ebuild
@@ -55,27 +55,27 @@ src_configure() {
src_compile() {
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
# occasionally dies in parallel make
- emake -j1 || die
+ emake -j1
if use doc ; then
- emake -j1 html || die
+ emake -j1 html
fi
}
src_test() {
- emake -j1 test || die
+ emake -j1 test
}
src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- dosym parrot-ops2c /usr/bin/ops2c || die
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO
+ dosym parrot-ops2c /usr/bin/ops2c
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
+ doins -r examples/*
fi
if use doc; then
insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
+ doins -r editor
cd docs/html
dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
pmc.html tools.html docs src tools || die
diff --git a/dev-lang/parrot/parrot-8.1.0-r1.ebuild b/dev-lang/parrot/parrot-8.1.0-r1.ebuild
index 271931b3b1af..741003d7549c 100644
--- a/dev-lang/parrot/parrot-8.1.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-8.1.0-r1.ebuild
@@ -56,27 +56,27 @@ src_configure() {
src_compile() {
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
# occasionally dies in parallel make
- emake -j1 || die
+ emake -j1
if use doc ; then
- emake -j1 html || die
+ emake -j1 html
fi
}
src_test() {
- emake -j1 test || die
+ emake -j1 test
}
src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- dosym parrot-ops2c /usr/bin/ops2c || die
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}"
+ dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO
+ dosym parrot-ops2c /usr/bin/ops2c
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
+ doins -r examples/*
fi
if use doc; then
insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
+ doins -r editor
cd docs/html
dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
pmc.html tools.html docs src tools || die
diff --git a/dev-lang/pcc/pcc-1.1.0-r1.ebuild b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
index ec8b8967851e..e360baaad232 100644
--- a/dev-lang/pcc/pcc-1.1.0-r1.ebuild
+++ b/dev-lang/pcc/pcc-1.1.0-r1.ebuild
@@ -29,9 +29,9 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
}
diff --git a/dev-lang/pcc/pcc-9999.ebuild b/dev-lang/pcc/pcc-9999.ebuild
index d2a776ab5d72..df09ab6d97d7 100644
--- a/dev-lang/pcc/pcc-9999.ebuild
+++ b/dev-lang/pcc/pcc-9999.ebuild
@@ -36,9 +36,9 @@ src_configure() {
}
src_compile() {
- emake || die "emake failed"
+ emake
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
}
diff --git a/dev-lang/polyml/polyml-5.4.1.ebuild b/dev-lang/polyml/polyml-5.4.1.ebuild
index 8909e4e033c2..022401f5434b 100644
--- a/dev-lang/polyml/polyml-5.4.1.ebuild
+++ b/dev-lang/polyml/polyml-5.4.1.ebuild
@@ -41,5 +41,5 @@ src_configure() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/polyml/polyml-5.5.0.ebuild b/dev-lang/polyml/polyml-5.5.0.ebuild
index 5a8e3e560661..3cde23196400 100644
--- a/dev-lang/polyml/polyml-5.5.0.ebuild
+++ b/dev-lang/polyml/polyml-5.5.0.ebuild
@@ -47,5 +47,5 @@ src_configure() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/polyml/polyml-5.5.1.ebuild b/dev-lang/polyml/polyml-5.5.1.ebuild
index 6b1bcd7ecab0..0ceb98cb5d9c 100644
--- a/dev-lang/polyml/polyml-5.5.1.ebuild
+++ b/dev-lang/polyml/polyml-5.5.1.ebuild
@@ -68,5 +68,5 @@ src_compile() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/polyml/polyml-5.5.2.ebuild b/dev-lang/polyml/polyml-5.5.2.ebuild
index a04a5c764f77..0cb11d7b3447 100644
--- a/dev-lang/polyml/polyml-5.5.2.ebuild
+++ b/dev-lang/polyml/polyml-5.5.2.ebuild
@@ -68,5 +68,5 @@ src_compile() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/polyml/polyml-5.6.ebuild b/dev-lang/polyml/polyml-5.6.ebuild
index 37fc5a07d0fe..6f30939f7d53 100644
--- a/dev-lang/polyml/polyml-5.6.ebuild
+++ b/dev-lang/polyml/polyml-5.6.ebuild
@@ -55,5 +55,5 @@ src_compile() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/polyml/polyml-5.8.ebuild b/dev-lang/polyml/polyml-5.8.ebuild
index 82e42d8d208d..37dc19e4e1db 100644
--- a/dev-lang/polyml/polyml-5.8.ebuild
+++ b/dev-lang/polyml/polyml-5.8.ebuild
@@ -55,5 +55,5 @@ src_compile() {
}
src_test() {
- emake tests || die "tests failed"
+ emake tests
}
diff --git a/dev-lang/ruby/ruby-2.4.9.ebuild b/dev-lang/ruby/ruby-2.4.9.ebuild
index 855960b6f5cf..8f8e27dd860f 100644
--- a/dev-lang/ruby/ruby-2.4.9.ebuild
+++ b/dev-lang/ruby/ruby-2.4.9.ebuild
@@ -143,16 +143,15 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}"
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -187,7 +186,7 @@ src_install() {
done
export LD_LIBRARY_PATH RUBYLIB
- emake V=1 DESTDIR="${D}" install || die "make install failed"
+ emake V=1 DESTDIR="${D}" install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -204,7 +203,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test
diff --git a/dev-lang/ruby/ruby-2.5.7.ebuild b/dev-lang/ruby/ruby-2.5.7.ebuild
index e63ff54b17b1..992d04bc501d 100644
--- a/dev-lang/ruby/ruby-2.5.7.ebuild
+++ b/dev-lang/ruby/ruby-2.5.7.ebuild
@@ -138,16 +138,15 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}"
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -182,7 +181,7 @@ src_install() {
done
export LD_LIBRARY_PATH RUBYLIB
- emake V=1 DESTDIR="${D}" install || die "make install failed"
+ emake V=1 DESTDIR="${D}" install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -199,7 +198,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test
diff --git a/dev-lang/ruby/ruby-2.6.5.ebuild b/dev-lang/ruby/ruby-2.6.5.ebuild
index 57bd24dcd4f5..563576964c50 100644
--- a/dev-lang/ruby/ruby-2.6.5.ebuild
+++ b/dev-lang/ruby/ruby-2.6.5.ebuild
@@ -142,19 +142,18 @@ src_configure() {
$(use_with static-libs static-linked-ext) \
$(use_enable debug) \
${myconf} \
- --enable-option-checking=no \
- || die "econf failed"
+ --enable-option-checking=no
# Makefile is broken because it lacks -ldl
rm -rf ext/-test-/popen_deadlock || die
}
src_compile() {
- emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS="" || die "emake failed"
+ emake V=1 EXTLDFLAGS="${LDFLAGS}" MJIT_CFLAGS="${CFLAGS}" MJIT_OPTFLAGS="" MJIT_DEBUGFLAGS=""
}
src_test() {
- emake -j1 V=1 test || die "make test failed"
+ emake -j1 V=1 test
elog "Ruby's make test has been run. Ruby also ships with a make check"
elog "that cannot be run until after ruby has been installed."
@@ -194,7 +193,7 @@ src_install() {
local gem_home="${EPREFIX}/usr/$(get_libdir)/ruby/gems/${RUBYVERSION}"
mkdir -p "${D}/${gem_home}" || die "mkdir gem home failed"
- emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install || die "make install failed"
+ emake V=1 DESTDIR="${D}" GEM_DESTDIR=${gem_home} install
# Remove installed rubygems and rdoc copy
rm -rf "${ED}/usr/$(get_libdir)/ruby/${RUBYVERSION}/rubygems" || die "rm rubygems failed"
@@ -203,7 +202,7 @@ src_install() {
rm -rf "${ED}/usr/bin/"{bundle,bundler,ri,rdoc}"${MY_SUFFIX}" || die "rm rdoc bins failed"
if use doc; then
- emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc || die "make install-doc failed"
+ emake DESTDIR="${D}" GEM_DESTDIR=${gem_home} install-doc
fi
if use examples; then
@@ -211,7 +210,7 @@ src_install() {
doins -r sample
fi
- dodoc ChangeLog NEWS doc/NEWS* README* || die
+ dodoc ChangeLog NEWS doc/NEWS* README*
if use rubytests; then
pushd test
diff --git a/dev-lang/smlnj/smlnj-110.75.ebuild b/dev-lang/smlnj/smlnj-110.75.ebuild
index 5a4ca406ed7a..9c8f42af0b28 100644
--- a/dev-lang/smlnj/smlnj-110.75.ebuild
+++ b/dev-lang/smlnj/smlnj-110.75.ebuild
@@ -98,11 +98,11 @@ src_install() {
mv bin lib "${D}"/${DIR} || die
# for file in "${D}"/${DIR}/bin/*; do
-# dosym /${DIR}/bin/$(basename "${file}") /usr/bin/$(basename "${file}") || die
+# dosym /${DIR}/bin/$(basename "${file}") /usr/bin/$(basename "${file}")
# done
# for file in $(find "${D}"/usr/lib/${PN}/bin/ -maxdepth 1 -type f ! -name ".*"); do
-# dosym /${DIR}/bin/$(basename "${file}") /usr/bin/$(basename "${file}") || die
+# dosym /${DIR}/bin/$(basename "${file}") /usr/bin/$(basename "${file}")
# done
for file in "${D}"/usr/bin/{*,.*}; do
diff --git a/dev-lang/whitespace/whitespace-0.3.ebuild b/dev-lang/whitespace/whitespace-0.3.ebuild
index a3d12e7590f6..92b1bb97583b 100644
--- a/dev-lang/whitespace/whitespace-0.3.ebuild
+++ b/dev-lang/whitespace/whitespace-0.3.ebuild
@@ -28,6 +28,6 @@ src_prepare() {
src_install() {
cabal_src_install
- dohtml docs/tutorial.html || die "dohtml failed"
- use examples && { dodoc -r examples || die "dodoc failed"; }
+ dohtml docs/tutorial.html
+ use examples && dodoc -r examples
}
diff --git a/dev-lang/xsb/xsb-3.6.0.ebuild b/dev-lang/xsb/xsb-3.6.0.ebuild
index f0ea2805b12f..033bb06053d6 100644
--- a/dev-lang/xsb/xsb-3.6.0.ebuild
+++ b/dev-lang/xsb/xsb-3.6.0.ebuild
@@ -81,120 +81,120 @@ src_configure() {
src_compile() {
cd "${S}"/build
- emake || die "emake failed"
+ emake
# All XSB Packages are compiled using a single Prolog engine.
# Consequently they must all be compiled using a single make job.
cd "${S}"/packages
rm -f *.xwam
- emake -j1 || die "emake packages failed"
+ emake -j1
if use curl ; then
- emake -j1 curl || die "emake curl package failed"
- emake -j1 sgml || die "emake sgml package failed"
+ emake -j1 curl
+ emake -j1 sgml
if use xml ; then
- emake -j1 xpath || die "emake xpath package failed"
+ emake -j1 xpath
fi
fi
if use mysql ; then
- emake -j1 mysql || die "emake mysql package failed"
+ emake -j1 mysql
fi
if use odbc ; then
- emake -j1 odbc || die "emake odbc package failed"
+ emake -j1 odbc
fi
if use pcre ; then
- emake -j1 pcre || die "emake pcre package failed"
+ emake -j1 pcre
fi
}
src_install() {
cd "${S}"/build
- emake DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install
local XSB_INSTALL_DIR=/usr/$(get_libdir)/xsb-${PV}
- dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb || die
+ dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb
cd "${S}"/packages
local PACKAGES=${XSB_INSTALL_DIR}/packages
insinto ${PACKAGES}
- doins *.xwam || die
+ doins *.xwam
insinto ${PACKAGES}/chr
- doins chr/*.xwam || die
+ doins chr/*.xwam
insinto ${PACKAGES}/clpqr
- doins clpqr/*.xwam || die
+ doins clpqr/*.xwam
insinto ${PACKAGES}/gap
- doins gap/*.xwam || die
+ doins gap/*.xwam
insinto ${PACKAGES}/justify
- doins justify/*.xwam || die
- doins justify/*.H || die
+ doins justify/*.xwam
+ doins justify/*.H
insinto ${PACKAGES}/regmatch
- doins regmatch/*.xwam || die
+ doins regmatch/*.xwam
insinto ${PACKAGES}/regmatch/cc
- doins regmatch/cc/*.H || die
+ doins regmatch/cc/*.H
insinto ${PACKAGES}/slx
- doins slx/*.xwam || die
+ doins slx/*.xwam
insinto ${PACKAGES}/wildmatch
- doins wildmatch/*.xwam || die
+ doins wildmatch/*.xwam
insinto ${PACKAGES}/wildmatch/cc
- doins wildmatch/cc/*.H || die
+ doins wildmatch/cc/*.H
if use curl ; then
insinto ${PACKAGES}/curl
- doins curl/*.xwam || die
+ doins curl/*.xwam
insinto ${PACKAGES}/curl/cc
- doins curl/cc/*.H || die
+ doins curl/cc/*.H
insinto ${PACKAGES}/sgml
- doins sgml/*.xwam || die
+ doins sgml/*.xwam
insinto ${PACKAGES}/sgml/cc
- doins sgml/cc/*.H || die
+ doins sgml/cc/*.H
insinto ${PACKAGES}/sgml/cc/dtd
- doins sgml/cc/dtd/* || die
+ doins sgml/cc/dtd/*
if use xml ; then
insinto ${PACKAGES}/xpath
- doins xpath/*xwam || die
+ doins xpath/*xwam
insinto ${PACKAGES}/xpath/cc
- doins xpath/cc/*.H || die
+ doins xpath/cc/*.H
fi
fi
if use mysql || use odbc ; then
insinto ${PACKAGES}/dbdrivers
- doins dbdrivers/*.xwam || die
- doins dbdrivers/*.H || die
+ doins dbdrivers/*.xwam
+ doins dbdrivers/*.H
insinto ${PACKAGES}/dbdrivers/cc
- doins dbdrivers/cc/*.H || die
+ doins dbdrivers/cc/*.H
if use mysql ; then
insinto ${PACKAGES}/dbdrivers/mysql
- doins dbdrivers/mysql/*.xwam || die
+ doins dbdrivers/mysql/*.xwam
insinto ${PACKAGES}/dbdrivers/mysql/cc
- doins dbdrivers/mysql/cc/*.H || die
+ doins dbdrivers/mysql/cc/*.H
fi
if use odbc ; then
insinto ${PACKAGES}/dbdrivers/odbc
- doins dbdrivers/odbc/*.xwam || die
+ doins dbdrivers/odbc/*.xwam
insinto ${PACKAGES}/dbdrivers/odbc/cc
- doins dbdrivers/odbc/cc/*.H || die
+ doins dbdrivers/odbc/cc/*.H
fi
fi
if use pcre ; then
insinto ${PACKAGES}/pcre
- doins pcre/*.xwam || die
+ doins pcre/*.xwam
insinto ${PACKAGES}/pcre/cc
- doins pcre/cc/*.H || die
+ doins pcre/cc/*.H
fi
cd "${S}"
- dodoc FAQ README || die
+ dodoc FAQ README
}