summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:03:58 -0600
committerSam James <sam@gentoo.org>2023-10-14 01:47:04 +0100
commit307c665cebec04fc97c708f4215fe11344291400 (patch)
tree4363518ed1c38b40bc3da28486db302bd8f2db4b /dev-lang
parentdev-lang/ghc: Turn USE=doc off by default (diff)
downloadgentoo-307c665cebec04fc97c708f4215fe11344291400.tar.gz
gentoo-307c665cebec04fc97c708f4215fe11344291400.tar.bz2
gentoo-307c665cebec04fc97c708f4215fe11344291400.zip
dev-lang/ghc: Update PYTHON_COMPAT
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ghc-8.10.6-r3.ebuild2
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r3.ebuild2
-rw-r--r--dev-lang/ghc/ghc-9.0.2-r4.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/ghc/ghc-8.10.6-r3.ebuild b/dev-lang/ghc/ghc-8.10.6-r3.ebuild
index f6e13533829c..37a70a60888b 100644
--- a/dev-lang/ghc/ghc-8.10.6-r3.ebuild
+++ b/dev-lang/ghc/ghc-8.10.6-r3.ebuild
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit python-any-r1
inherit autotools bash-completion-r1 flag-o-matic ghc-package
inherit multiprocessing pax-utils toolchain-funcs prefix
diff --git a/dev-lang/ghc/ghc-9.0.2-r3.ebuild b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
index efff65d4dd9a..6adec687c250 100644
--- a/dev-lang/ghc/ghc-9.0.2-r3.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r3.ebuild
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit python-any-r1
inherit autotools bash-completion-r1 flag-o-matic ghc-package
inherit multiprocessing pax-utils toolchain-funcs prefix
diff --git a/dev-lang/ghc/ghc-9.0.2-r4.ebuild b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
index a0423ff8e661..1691ba87bc87 100644
--- a/dev-lang/ghc/ghc-9.0.2-r4.ebuild
+++ b/dev-lang/ghc/ghc-9.0.2-r4.ebuild
@@ -13,7 +13,7 @@ if [[ ${CTARGET} = ${CHOST} ]] ; then
fi
fi
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit python-any-r1
inherit autotools bash-completion-r1 flag-o-matic ghc-package
inherit multiprocessing pax-utils toolchain-funcs prefix