summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:20:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 20:23:32 +0100
commit2f9c42cb12b476a78214e2f7d5bb3f984ce05de6 (patch)
treea090b49934af522bd3f29135d3c4f7bbfeb9c5dd /dev-lang
parentMove {dev-util → dev-build}/tinycmmc (diff)
downloadgentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.tar.gz
gentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.tar.bz2
gentoo-2f9c42cb12b476a78214e2f7d5bb3f984ce05de6.zip
Move {dev-util → dev-build}/cmake
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34792 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/julia/julia-1.8.3-r4.ebuild4
-rw-r--r--dev-lang/julia/julia-1.8.5-r1.ebuild6
-rw-r--r--dev-lang/julia/julia-1.9.0.ebuild6
-rw-r--r--dev-lang/julia/julia-1.9.4.ebuild6
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild2
-rw-r--r--dev-lang/mono/mono-6.12.0.182.ebuild2
-rw-r--r--dev-lang/mono/mono-6.12.0.199-r1.ebuild2
-rw-r--r--dev-lang/mono/mono-6.12.0.199-r2.ebuild2
-rw-r--r--dev-lang/mono/mono-6.12.0.199.ebuild2
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild2
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.71.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.71.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.72.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.73.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.74.1.ebuild2
20 files changed, 27 insertions, 27 deletions
diff --git a/dev-lang/julia/julia-1.8.3-r4.ebuild b/dev-lang/julia/julia-1.8.3-r4.ebuild
index a7496a13dbbd..c21a564cc460 100644
--- a/dev-lang/julia/julia-1.8.3-r4.ebuild
+++ b/dev-lang/julia/julia-1.8.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -48,7 +48,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.8.5-r1.ebuild b/dev-lang/julia/julia-1.8.5-r1.ebuild
index fbe4522110f4..c38278524dae 100644
--- a/dev-lang/julia/julia-1.8.5-r1.ebuild
+++ b/dev-lang/julia/julia-1.8.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -9,7 +9,7 @@ EAPI=8
# >=1.8.2 still sits on LLVM 13, bug: https://bugs.gentoo.org/876184
MY_LLVM_V=13.0.1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -59,7 +59,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.9.0.ebuild b/dev-lang/julia/julia-1.9.0.ebuild
index 302f4215540c..6dfef422bd55 100644
--- a/dev-lang/julia/julia-1.9.0.ebuild
+++ b/dev-lang/julia/julia-1.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -8,7 +8,7 @@ EAPI=8
MY_LLVM_V=14.0.6
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -55,7 +55,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/julia/julia-1.9.4.ebuild b/dev-lang/julia/julia-1.9.4.ebuild
index b0105c0e508f..82e0fb7987d9 100644
--- a/dev-lang/julia/julia-1.9.4.ebuild
+++ b/dev-lang/julia/julia-1.9.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# correct versions for stdlibs are in deps/checksums
@@ -8,7 +8,7 @@ EAPI=8
MY_LLVM_V=14.0.6
-PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit check-reqs flag-o-matic optfeature pax-utils python-any-r1 toolchain-funcs
@@ -54,7 +54,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
- dev-util/cmake
+ dev-build/cmake
virtual/pkgconfig
"
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
index 743b96a02c63..3d5515f9d05a 100644
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ b/dev-lang/mono/mono-6.12.0.122.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
"
# CMake is used for bundled deps
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
app-alternatives/bc
app-alternatives/yacc
pax-kernel? ( sys-apps/elfix )
diff --git a/dev-lang/mono/mono-6.12.0.182.ebuild b/dev-lang/mono/mono-6.12.0.182.ebuild
index 0641b48b5bc1..65b7e97c46ec 100644
--- a/dev-lang/mono/mono-6.12.0.182.ebuild
+++ b/dev-lang/mono/mono-6.12.0.182.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
"
# CMake is used for bundled deps
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
app-alternatives/bc
app-alternatives/yacc
pax-kernel? ( sys-apps/elfix )
diff --git a/dev-lang/mono/mono-6.12.0.199-r1.ebuild b/dev-lang/mono/mono-6.12.0.199-r1.ebuild
index 8a3656979102..a7c6af775271 100644
--- a/dev-lang/mono/mono-6.12.0.199-r1.ebuild
+++ b/dev-lang/mono/mono-6.12.0.199-r1.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
"
# CMake is used for bundled deps
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
app-alternatives/bc
app-alternatives/yacc
pax-kernel? ( sys-apps/elfix )
diff --git a/dev-lang/mono/mono-6.12.0.199-r2.ebuild b/dev-lang/mono/mono-6.12.0.199-r2.ebuild
index 97082284fc0c..77fe33df7cd8 100644
--- a/dev-lang/mono/mono-6.12.0.199-r2.ebuild
+++ b/dev-lang/mono/mono-6.12.0.199-r2.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
"
# CMake is used for bundled deps
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
app-alternatives/bc
app-alternatives/yacc
pax-kernel? ( sys-apps/elfix )
diff --git a/dev-lang/mono/mono-6.12.0.199.ebuild b/dev-lang/mono/mono-6.12.0.199.ebuild
index 49e4c7536d2d..a256d411e02c 100644
--- a/dev-lang/mono/mono-6.12.0.199.ebuild
+++ b/dev-lang/mono/mono-6.12.0.199.ebuild
@@ -31,7 +31,7 @@ RDEPEND="
"
# CMake is used for bundled deps
BDEPEND="
- dev-util/cmake
+ dev-build/cmake
app-alternatives/bc
app-alternatives/yacc
pax-kernel? ( sys-apps/elfix )
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index ce0870c0fcd2..b12ab0d6de08 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index 41c0c5939250..34c13db52dcf 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index 0c98ca1df404..c887478cbeda 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index 044e3b37f10b..70aaa2ddd1e6 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index 0cdbbbd94d91..4fdb4ca0f359 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index ea2d52be54aa..02c6210203cc 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.71.0.ebuild b/dev-lang/rust/rust-1.71.0.ebuild
index c11252d7920e..57547f28681f 100644
--- a/dev-lang/rust/rust-1.71.0.ebuild
+++ b/dev-lang/rust/rust-1.71.0.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.71.1.ebuild b/dev-lang/rust/rust-1.71.1.ebuild
index 31c61f2d0344..c9773385d9c4 100644
--- a/dev-lang/rust/rust-1.71.1.ebuild
+++ b/dev-lang/rust/rust-1.71.1.ebuild
@@ -93,7 +93,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.72.0-r1.ebuild b/dev-lang/rust/rust-1.72.0-r1.ebuild
index a05b40f0528a..eae036887f67 100644
--- a/dev-lang/rust/rust-1.72.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.72.0-r1.ebuild
@@ -95,7 +95,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.73.0.ebuild b/dev-lang/rust/rust-1.73.0.ebuild
index 045d69a9233a..f442f3a9deff 100644
--- a/dev-lang/rust/rust-1.73.0.ebuild
+++ b/dev-lang/rust/rust-1.73.0.ebuild
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )
diff --git a/dev-lang/rust/rust-1.74.1.ebuild b/dev-lang/rust/rust-1.74.1.ebuild
index 0f37c5bb1b80..fb96d627f31d 100644
--- a/dev-lang/rust/rust-1.74.1.ebuild
+++ b/dev-lang/rust/rust-1.74.1.ebuild
@@ -94,7 +94,7 @@ BDEPEND="${PYTHON_DEPS}
)
system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
!system-llvm? (
- >=dev-util/cmake-3.13.4
+ >=dev-build/cmake-3.13.4
app-alternatives/ninja
)
test? ( dev-debug/gdb )