summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-05 22:53:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-06-05 22:56:39 -0700
commite96cc4c5501c00acacf5f66e40d08c73af02d552 (patch)
treecb8600cf0e719d0d732e2cf33ae552bb04396336 /dev-lang/rust
parentdev-texlive/texlive-latexextra: fix a blocker typo (diff)
downloadgentoo-e96cc4c5501c00acacf5f66e40d08c73af02d552.tar.gz
gentoo-e96cc4c5501c00acacf5f66e40d08c73af02d552.tar.bz2
gentoo-e96cc4c5501c00acacf5f66e40d08c73af02d552.zip
dev-lang/rust: handle libdir workaround on arm as well
Bug: https://bugs.gentoo.org/672816 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/rust-1.34.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.34.2.ebuild b/dev-lang/rust/rust-1.34.2.ebuild
index c0d1a001cbc3..8973490b5aa2 100644
--- a/dev-lang/rust/rust-1.34.2.ebuild
+++ b/dev-lang/rust/rust-1.34.2.ebuild
@@ -267,12 +267,14 @@ src_install() {
done
# temp fix for https://bugs.gentoo.org/672816
- if use x86; then
+ # FIXME: this should handle libdir=lib, not exact arches
+ if { use x86 || use arm; }; then
local rust_target wrongdir rightdir
rust_target=$(rust_abi $(get_abi_CHOST ${v##*.}))
wrongdir="${ED}/usr/$(get_libdir)/${P}/${P}/rustlib/${rust_target}/codegen-backends"
rightdir="${ED}/usr/$(get_libdir)/${P}/rustlib/${rust_target}/codegen-backends"
if [[ -e ${wrongdir}/librustc_codegen_llvm-llvm.so ]]; then
+ einfo "fixing bug #672816"
mv "${wrongdir}" "${rightdir}" || die
rm -r "${ED}/usr/$(get_libdir)/${P}/${P}" || die
fi