summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-04-04 14:21:50 -0400
committerMike Gilbert <floppym@gentoo.org>2020-04-04 14:22:49 -0400
commit4ddeacea98c15971264056972cd6d03631c73aca (patch)
tree2a22f363584623dd74e05b85aba0b6f310c3ec72 /dev-lang/python
parentdev-lang/go: remove 1.13.8 (diff)
downloadgentoo-4ddeacea98c15971264056972cd6d03631c73aca.tar.gz
gentoo-4ddeacea98c15971264056972cd6d03631c73aca.tar.bz2
gentoo-4ddeacea98c15971264056972cd6d03631c73aca.zip
dev-lang/python: ignore EACCES instead of EPERM
Fixes: 212bc8ce91237d28de326e84ff8607863602d1f7 Closes: https://bugs.gentoo.org/679628 Package-Manager: Portage-2.3.96_p4, Repoman-2.3.22_p1 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/files/test.support.unlink-ignore-EACCES.patch (renamed from dev-lang/python/files/test.support.unlink-ignore-EPERM.patch)10
-rw-r--r--dev-lang/python/python-2.7.17-r2.ebuild2
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/files/test.support.unlink-ignore-EPERM.patch b/dev-lang/python/files/test.support.unlink-ignore-EACCES.patch
index 291398137c7b..865a914b4100 100644
--- a/dev-lang/python/files/test.support.unlink-ignore-EPERM.patch
+++ b/dev-lang/python/files/test.support.unlink-ignore-EACCES.patch
@@ -1,7 +1,7 @@
-From 789c61e1a1966241d274012cdbd5fb9716448952 Mon Sep 17 00:00:00 2001
+From b8dc49c87f29fa875bd24fe47c741d11962a33b6 Mon Sep 17 00:00:00 2001
From: Mike Gilbert <floppym@gentoo.org>
-Date: Fri, 3 Apr 2020 10:37:56 -0400
-Subject: [PATCH] test.support.unlink: ignore EPERM
+Date: Sat, 4 Apr 2020 14:11:25 -0400
+Subject: [PATCH] test.support.unlink: ignore EACCES
Resolves test errors when running in the Gentoo sandbox environment.
@@ -11,7 +11,7 @@ Bug: https://bugs.gentoo.org/679628
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Lib/test/support/__init__.py b/Lib/test/support/__init__.py
-index ccc11c1b4b0..c5ec06bb420 100644
+index ccc11c1b4b0..d47bdebda5c 100644
--- a/Lib/test/support/__init__.py
+++ b/Lib/test/support/__init__.py
@@ -291,7 +291,7 @@ def unlink(filename):
@@ -19,7 +19,7 @@ index ccc11c1b4b0..c5ec06bb420 100644
_unlink(filename)
except OSError as exc:
- if exc.errno not in (errno.ENOENT, errno.ENOTDIR):
-+ if exc.errno not in (errno.ENOENT, errno.ENOTDIR, errno.EPERM):
++ if exc.errno not in (errno.ENOENT, errno.ENOTDIR, errno.EACCES):
raise
def rmdir(dirname):
diff --git a/dev-lang/python/python-2.7.17-r2.ebuild b/dev-lang/python/python-2.7.17-r2.ebuild
index c38022f956b5..7cb8c9b155e4 100644
--- a/dev-lang/python/python-2.7.17-r2.ebuild
+++ b/dev-lang/python/python-2.7.17-r2.ebuild
@@ -88,7 +88,7 @@ src_prepare() {
local PATCHES=(
"${WORKDIR}/${PATCHSET}"
- "${FILESDIR}/test.support.unlink-ignore-EPERM.patch"
+ "${FILESDIR}/test.support.unlink-ignore-EACCES.patch"
)
default