summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-14 16:23:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-14 16:57:50 +0200
commit1c9427b0676b68f932a04dd88f48ca276433f7aa (patch)
tree0cdc0e66b574fd06b6c9fd6c40d08dfa728e85b2 /dev-lang/python-exec
parentdev-lang/python-exec: Add py3.12 to host test impls (diff)
downloadgentoo-1c9427b0676b68f932a04dd88f48ca276433f7aa.tar.gz
gentoo-1c9427b0676b68f932a04dd88f48ca276433f7aa.tar.bz2
gentoo-1c9427b0676b68f932a04dd88f48ca276433f7aa.zip
dev-lang/python-exec: Disable pytest plugin autoload
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/python-exec-2.4.10.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/python-exec/python-exec-2.4.10.ebuild b/dev-lang/python-exec/python-exec-2.4.10.ebuild
index 077b27e7d539..85085af14303 100644
--- a/dev-lang/python-exec/python-exec-2.4.10.ebuild
+++ b/dev-lang/python-exec/python-exec-2.4.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -53,6 +53,11 @@ src_configure() {
econf "${myconf[@]}"
}
+src_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ default
+}
+
src_install() {
default