summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2024-02-28 17:17:14 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-02-29 14:44:38 +0200
commit888388225a24e021a960694457ea0302dc417a90 (patch)
treea4b6b533b7860c3db4ffd17220383e2a7df02d15 /dev-lang/jimtcl
parentapp-editors/remarkable: fix custom css is not loaded on start (diff)
downloadgentoo-888388225a24e021a960694457ea0302dc417a90.tar.gz
gentoo-888388225a24e021a960694457ea0302dc417a90.tar.bz2
gentoo-888388225a24e021a960694457ea0302dc417a90.zip
dev-lang/jimtcl: Bump to 0.82
Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34890 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/jimtcl')
-rw-r--r--dev-lang/jimtcl/Manifest1
-rw-r--r--dev-lang/jimtcl/jimtcl-0.82.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-lang/jimtcl/Manifest b/dev-lang/jimtcl/Manifest
index a0a2b4b209a5..e88f0efc2798 100644
--- a/dev-lang/jimtcl/Manifest
+++ b/dev-lang/jimtcl/Manifest
@@ -1,2 +1,3 @@
DIST jimtcl-0.78.tar.gz 3073533 BLAKE2B f0cdaf2807c7dd0e7c64e37cbc8dd019d8460e6a0320c239b0d01549aede8c86a89d84d7a3c5200c8d8cea428dbd1038d57dc66f5b580bdea8fe39710f967bbb SHA512 2a2cff12d7fdc4cf36734e41727eef08f6d74fb13d70bb0a3e01839e66859e57dd927ddedc161a6a7928881d640bd4e20a1bb313ed24aa2bb7bcb00eaf64fbf6
DIST jimtcl-0.81.tar.gz 3977705 BLAKE2B d58a8f9d3a632e98a9737b57f9228e35f198eae47ff51b4a0401491f394980b95606e0986d0b79c84f9a8e77d562407882668c0d108275935fa65b21ce68b329 SHA512 5f798b15fd32673e2e2769e25c4dfeee43696e5bbd2d3ec3fd2f312fa49da9ef057fb4de81a10d3812dc07fb2e40ed79924b024e537e064d3213b10e06a416b6
+DIST jimtcl-0.82.tar.gz 4435258 BLAKE2B 4db820177db1660961f5af2311d02e1d3c32f92bba63b95cdc2933adf4b20cc1133319e411b9a4f23bd2f39ce7c8b5f064641df16ab82948b0266c0670c8744b SHA512 d0f8c8d515b9c7eee3ee2089a8fe9b8616b0541b7fca6b769132201c3a65a8216f9e8a333c6a3a4c2a8fa4754ab0c9d3c2bca3306b3b4db566d4f3e401a709fe
diff --git a/dev-lang/jimtcl/jimtcl-0.82.ebuild b/dev-lang/jimtcl/jimtcl-0.82.ebuild
new file mode 100644
index 000000000000..b639eeba52a5
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.82.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs edo
+
+SRC_URI="https://github.com/msteveb/jimtcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~x86"
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk/"
+
+LICENSE="LGPL-2"
+SLOT="0/${PV}"
+IUSE="doc static-libs"
+
+DEPEND="
+ dev-lang/tcl:0
+"
+
+src_prepare() {
+ # Avoid tests that need networking
+ rm tests/ssl.test || die
+ default
+}
+
+src_configure() {
+ # Use the provided bootstrap tclsh, avoiding the script picking a different one
+ edo $(tc-getCC) -o jimsh0 autosetup/jimsh0.c
+
+ export CCACHE=none
+ econf --disable-docs --shared
+ if use static-libs; then
+ # The build does not support doing both simultaneously.
+ mkdir static-libs || die
+ cd static-libs || die
+ ECONF_SOURCE="${S}" econf --disable-docs
+ fi
+}
+
+src_compile() {
+ # Must build static-libs first.
+ use static-libs && emake -C static-libs V=1 libjim.a
+ emake V=1 all
+}
+
+src_install() {
+ default
+ use static-libs && dolib.a static-libs/libjim.a
+ use doc && dodoc Tcl_shipped.html
+}