summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-01-08 22:21:43 +0100
committerMike Gilbert <floppym@gentoo.org>2018-01-08 16:29:38 -0500
commitc294ef70be585e14abf3043aa929c80b92fb42d8 (patch)
tree0a00bb017e7e5b37f92dc732469878130c7e88a6 /dev-java
parentdev-libs/protobuf: Version bump (3.5.1.1). (diff)
downloadgentoo-c294ef70be585e14abf3043aa929c80b92fb42d8.tar.gz
gentoo-c294ef70be585e14abf3043aa929c80b92fb42d8.tar.bz2
gentoo-c294ef70be585e14abf3043aa929c80b92fb42d8.zip
dev-java/protobuf-java: Version bump (3.5.1.1).
Closes: https://bugs.gentoo.org/639328
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/protobuf-java/Manifest1
-rw-r--r--dev-java/protobuf-java/protobuf-java-3.5.1.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-java/protobuf-java/Manifest b/dev-java/protobuf-java/Manifest
index 76f10ac22f20..d8a14832a896 100644
--- a/dev-java/protobuf-java/Manifest
+++ b/dev-java/protobuf-java/Manifest
@@ -3,3 +3,4 @@ DIST protobuf-3.0.2.tar.gz 3917853 BLAKE2B 542beb7b16de0da2cdc6f7981381b6de1ff2c
DIST protobuf-3.1.0.tar.gz 4051503 BLAKE2B af93f125a6b7b3e0be6f50ff5eaabe0db21f62b01a694d37c0b069956ef5d658df1beef68514b00a22005a36293b4a8a18654b5656f8c614309f0a744039c2fb SHA512 8d3289a16944c255bd1cceab696e515e52467f2bfe1cc10f6b32fabdf082d5acdc248ec9cadc572223a24d04d431f75921076153109cea2f90ee533f502ab47a
DIST protobuf-3.3.0.tar.gz 4336596 BLAKE2B 381b2961fe1de8a86225903d0cfe4c98c238336b8782e5191c57c6fcf60cf321f39163d50864bf9c119a90bd7796269dc7e34168a158f7affa7fa295ce5deae0 SHA512 0734a55ae92f0539dfb507e174539d290fd8e93633c1edd8810e0d51c37e67254337b75fc5ba9450316f6416e1f8f8cfb59415864657b55f2a1696fbcdfe7636
DIST protobuf-3.4.1.tar.gz 4490100 BLAKE2B e2bc1ef2ee1a0af44830b3c65a6c9e73883fe6ec0d07f6a6136f5564f0e85306005440ca6f8c4eb834c7c70f909792c9e2457a761f10f95431981263a9acd7a3 SHA512 471e52198fa878a79183dc8fbc39d9c65239be4d9dff799e12281ee9b1af61a427584534b1baae1773bc6e4c86467f89ca2e7911a21effd86bc5f40cc7d94c34
+DIST protobuf-3.5.1.1.tar.gz 4584489 BLAKE2B 995ee2f06a6358e9935b488269ee50f0dccede417c1757828b0108fbe8c67034301f3a9cb87517430acd9838ae71bb677f4edd8b59b2418f99c15d8ea3d33591 SHA512 f25ecf772facc8efd196b7c06012ce9ec24152b2c0cde38ed2e29ecded8f534221b008e649f4cbd991436ad3436130cd2e31d51e75019d08240d518111fb4496
diff --git a/dev-java/protobuf-java/protobuf-java-3.5.1.1.ebuild b/dev-java/protobuf-java/protobuf-java-3.5.1.1.ebuild
new file mode 100644
index 000000000000..0db08537169d
--- /dev/null
+++ b/dev-java/protobuf-java/protobuf-java-3.5.1.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Google's Protocol Buffers - Java bindings"
+HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/google/protobuf"
+SRC_URI="https://github.com/google/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/15"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~sh ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="nano"
+
+# Protobuf is only a build-time dep, but depends on the exact same version
+# (excluding revision), since we are using the same tarball.
+# But probably same subslot is sufficient.
+DEPEND=">=virtual/jdk-1.7
+ ~dev-libs/protobuf-${PV}"
+
+RDEPEND=">=virtual/jre-1.7
+ !<dev-libs/protobuf-3[java(-)]"
+
+S="${WORKDIR}/protobuf-${PV}"
+
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
+src_compile() {
+ pushd "${S}/java" >/dev/null || die
+ einfo "Compiling Java library ..."
+ "${EPREFIX}"/usr/bin/protoc --java_out=core/src/main/java -I../src ../src/google/protobuf/descriptor.proto || die
+ JAVA_SRC_DIR="${S}/java/core/src/main/java"
+ JAVA_JAR_FILENAME="protobuf.jar"
+ java-pkg-simple_src_compile
+ popd >/dev/null || die
+ if use nano; then
+ einfo "Compiling Java Nano library ..."
+ pushd "${S}/javanano" >/dev/null || die
+ "${EPREFIX}"/usr/bin/protoc --java_out=src/main/java -I../src ../src/google/protobuf/descriptor.proto || die
+ JAVA_SRC_DIR="${S}/javanano/src/main/java"
+ JAVA_GENTOO_CLASSPATH_EXTRA="${S}/java/core/src/main/java/"
+ JAVA_JAR_FILENAME="protobuf-nano.jar"
+ java-pkg-simple_src_compile
+ popd >/dev/null || die
+ fi
+}
+
+src_install() {
+ JAVA_JAR_FILENAME="${S}/java/protobuf.jar"
+ JAVA_SRC_DIR="${S}/java/core/src/main/java"
+ if use nano; then
+ JAVA_JAR_FILENAME="${JAVA_JAR_FILENAME} ${S}/javanano/protobuf-nano.jar"
+ JAVA_SRC_DIR="${JAVA_SRC_DIR} ${S}/javanano/src/main/java"
+ fi
+ mv "${S}/java/target" . || die
+ if use nano; then
+ cp -Rvf "${S}/javanano/target" . || die
+ fi
+ java-pkg-simple_src_install
+}