summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-16 09:49:33 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-12-08 08:30:19 +0100
commita9816c56de175b25c2e4b78033ec714f51f41d05 (patch)
tree5730a9cdb2f0fe60a6b0a631cf4821d42fb6f609 /dev-java
parentnet-firewall/iptables: fix race condition in init script (diff)
downloadgentoo-a9816c56de175b25c2e4b78033ec714f51f41d05.tar.gz
gentoo-a9816c56de175b25c2e4b78033ec714f51f41d05.tar.bz2
gentoo-a9816c56de175b25c2e4b78033ec714f51f41d05.zip
dev-java/javassist: solve four test exclusions by adding debug symbols
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/javassist/javassist-3.29.2.ebuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/dev-java/javassist/javassist-3.29.2.ebuild b/dev-java/javassist/javassist-3.29.2.ebuild
index a26a44d09cbc..0e43e4e7ea2a 100644
--- a/dev-java/javassist/javassist-3.29.2.ebuild
+++ b/dev-java/javassist/javassist-3.29.2.ebuild
@@ -50,24 +50,31 @@ src_prepare() {
java-pkg_clean javassist.jar
sed -e 's:\.\./\.\./::' -i src/test/javassist/JvstTest{4,Root}.java || die
- # Tests run: 432, Failures: 6
- # https://bugs.gentoo.org/856364
- # Cannot solve those test failures.
- # replacing test... with notTest... for those tests
+ # There were 2 failures:
+ # 1) testURL(javassist.JvstTest2)
+ # junit.framework.AssertionFailedError
+ # at junit.framework.Assert.fail(Assert.java:55)
+ # at junit.framework.Assert.assertTrue(Assert.java:22)
+ # at junit.framework.Assert.assertTrue(Assert.java:31)
+ # at junit.framework.TestCase.assertTrue(TestCase.java:200)
+ # at javassist.JvstTest2.testURL(JvstTest2.java:336)
+ # 2) testMethodParameters(javassist.JvstTest4)
+ # junit.framework.ComparisonFailure: expected:<[i]> but was:<[arg0]>
+ # at junit.framework.Assert.assertEquals(Assert.java:100)
+ # at junit.framework.Assert.assertEquals(Assert.java:107)
+ # at junit.framework.TestCase.assertEquals(TestCase.java:260)
+ # at javassist.JvstTest4.testMethodParameters(JvstTest4.java:1010)
+ #
+ # FAILURES!!!
+ # Tests run: 432, Failures: 2
+
sed \
- -e '/public void/s:testInsertAt:notTestInsertAt:' \
- -e '/public void/s:testInsertLocal:notTestInsertLocal:' \
- -e '/public void/s:testNewArray:notTestNewArray:' \
-e '/public void/s:testURL:notTestURL:' \
-i src/test/javassist/JvstTest2.java || die
sed \
-e '/public void/s:testMethodParameters:notTestMethodParameters:' \
-i src/test/javassist/JvstTest4.java || die
-
- sed \
- -e '/public void/s:testLocalVarAttribute:notTestLocalVarAttribute:' \
- -i src/test/javassist/bytecode/BytecodeTest.java || die
}
src_test() {
@@ -75,5 +82,6 @@ src_test() {
einfo "Testing"
JAVA_PKG_WANT_SOURCE=11
JAVA_PKG_WANT_TARGET=11
+ JAVAC_ARGS="-g"
java-pkg-simple_src_test
}