summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-23 09:54:44 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-23 10:13:01 +0200
commit8c4cf16616599f1ae4d5f336a5f1b264e9a1855e (patch)
tree5e969620584ec1ef4ed05c67826ecc773052e559 /dev-java
parentdev-java/jdbc-postgresql: removed obsolete (diff)
downloadgentoo-8c4cf16616599f1ae4d5f336a5f1b264e9a1855e.tar.gz
gentoo-8c4cf16616599f1ae4d5f336a5f1b264e9a1855e.tar.bz2
gentoo-8c4cf16616599f1ae4d5f336a5f1b264e9a1855e.zip
dev-java/jdbc-postgresql: eapi7, java 1.8, updated deps
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206-r1.ebuild (renamed from dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206.ebuild)32
1 files changed, 20 insertions, 12 deletions
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206-r1.ebuild
index cb6986cc6773..b5bfb41864b6 100644
--- a/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206.ebuild
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1206-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
JAVA_PKG_IUSE="doc source"
-inherit epatch java-pkg-2 java-ant-2
+inherit java-pkg-2 java-ant-2
MY_PN="postgresql-jdbc"
MY_PV="${PV/_p/-}"
@@ -20,28 +20,36 @@ SLOT="0"
KEYWORDS="amd64 ppc64 x86"
IUSE="test"
+# it does not compile with jdk 11, newer versions should be fine
+# BUILD FAILED
+# /var/tmp/portage/dev-java/jdbc-postgresql-9.4_p1206-r1/work/postgresql-jdbc-9.4-1206.src/build.xml:197: Unknown JDK version.
DEPEND="
- >=virtual/jdk-1.6
+ virtual/jdk:1.8
doc? (
dev-libs/libxslt
app-text/docbook-xsl-stylesheets
)
test? (
- >=dev-db/postgresql-9.3[server]
- dev-java/ant-junit
+ dev-db/postgresql[server]
+ dev-java/ant-junit:0
+ dev-java/hamcrest-core:1.3
dev-java/junit:4
- dev-java/xml-commons
+ dev-java/xml-commons-resolver:0
)"
-RDEPEND=">=virtual/jre-1.6"
+RDEPEND=">=virtual/jre-1.8:*"
RESTRICT="test" # Requires external postgresql server setup
S="${WORKDIR}/postgresql-jdbc-${MY_PV}.src"
+HTML_DOCS=( build/doc/pgjdbc.html )
+
JAVA_ANT_REWRITE_CLASSPATH="yes"
EANT_DOC_TARGET="publicapi"
-java_prepare() {
+src_prepare() {
+ default
+
# Strip build.xml of maven deps
sed -i -e '/<classpath.*dependency\.compile\.classpath/c\' build.xml || die
sed -i -e '/<classpath.*dependency\.runtime\.classpath/c\' build.xml || die
@@ -52,14 +60,14 @@ java_prepare() {
# Remove SSPI, it pulls in Waffle-JNA and is only used on Windows
sed -i -e '/<include.*sspi/c\' build.xml || die
rm -vrf org/postgresql/sspi || die "Error removing sspi"
- epatch "${FILESDIR}"/${PN}-9.4_p1204-remove-sspi.patch
+ eapply "${FILESDIR}"/${PN}-9.4_p1204-remove-sspi.patch
# FIXME @someone who cares: enable through osgi flag?
sed -i -e '/<include.*osgi/c\' build.xml || die
sed -i -e '/<test.*osgi/c\' build.xml || die
rm -vrf org/postgresql/osgi || die "Error removing osgi"
rm -vrf org/postgresql/test/osgi || die "Error removing osgi tests"
- epatch "${FILESDIR}"/${PN}-9.4_p1201-remove-osgi.patch
+ eapply "${FILESDIR}"/${PN}-9.4_p1201-remove-osgi.patch
java-pkg_clean
}
@@ -87,7 +95,7 @@ src_test() {
einfo "You can find a general info on how to perform these steps at"
einfo "https://wiki.gentoo.org/wiki/PostgreSQL"
- ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only "junit-4,xml-commons")
+ ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only "hamcrest-core-1.3,junit-4,xml-commons-resolver")
}
src_install() {
@@ -95,7 +103,7 @@ src_install() {
if use doc ; then
java-pkg_dojavadoc build/publicapi
- dohtml build/doc/pgjdbc.html
+ einstalldocs
fi
use source && java-pkg_dosrc org