summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-04-20 10:14:04 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-04-20 10:47:42 +0200
commit47fa7cc4d2d145b71fd3c12e555bd47e55072c68 (patch)
treee0cac0fb4f41809c6fc7178d27d6de4bf6f15b09 /dev-java
parentgames-simulation/EmptyEpsilon: drop 2022.03.16 (diff)
downloadgentoo-47fa7cc4d2d145b71fd3c12e555bd47e55072c68.tar.gz
gentoo-47fa7cc4d2d145b71fd3c12e555bd47e55072c68.tar.bz2
gentoo-47fa7cc4d2d145b71fd3c12e555bd47e55072c68.zip
dev-java/commons-logging: drop 1.2-r6
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-logging/Manifest1
-rw-r--r--dev-java/commons-logging/commons-logging-1.2-r6.ebuild122
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch26
-rw-r--r--dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch42
-rw-r--r--dev-java/commons-logging/metadata.xml6
5 files changed, 0 insertions, 197 deletions
diff --git a/dev-java/commons-logging/Manifest b/dev-java/commons-logging/Manifest
index 3ae886c05c09..25360c6e9487 100644
--- a/dev-java/commons-logging/Manifest
+++ b/dev-java/commons-logging/Manifest
@@ -1,2 +1 @@
-DIST commons-logging-1.2-src.tar.gz 188536 BLAKE2B 80613b78619f7b3429f60df4fb9b66dd4836e8b89fcf93a3a1bcd5cb7e410d474be010da16b325143e028a40ff4dd971753962c9d9145f85b1738f5dda13ba99 SHA512 9f3761184950f2f13e85d8bc447709ab8be631dfd231b4f053f8147468db1bf71fb116ddba95e39f4afc4cf28c742e07d40c7a637f28004a60dc13935f9609f9
DIST commons-logging-1.3.0_pre20230319.tar.gz 184984 BLAKE2B 01b46bdb657dfaf3ffb55b3440b416d61a419a3358e4d240cc7e25794f38e0061e14ee77e5578aedf1b50006d6ec65016c9e837bd13c4dab9a2182604fe85c72 SHA512 b586be5dd891572aa55c3066c3fb7d57ba5f31c0bfaa768b80cd8c1c5c659a8c718b4cb42e6c65332b52f073462432c0f81e4aaf1535afb781da9a7884cdc07e
diff --git a/dev-java/commons-logging/commons-logging-1.2-r6.ebuild b/dev-java/commons-logging/commons-logging-1.2-r6.ebuild
deleted file mode 100644
index 8c38a37bc9cb..000000000000
--- a/dev-java/commons-logging/commons-logging-1.2-r6.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="commons-logging:commons-logging:1.2"
-
-inherit java-pkg-2 java-ant-2 java-osgi
-
-DESCRIPTION="An ultra-thin bridge between different Java logging libraries"
-HOMEPAGE="https://commons.apache.org/logging/"
-SRC_URI="mirror://apache/commons/logging/source/${P}-src.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-IUSE="avalon-framework avalon-logkit log4j servletapi test"
-REQUIRED_USE="doc? ( avalon-framework avalon-logkit log4j servletapi )"
-RESTRICT="!test? ( test ) !servletapi? ( test )"
-
-CDEPEND="
- avalon-logkit? ( dev-java/avalon-logkit:2.0 )
- avalon-framework? ( dev-java/avalon-framework:4.2 )
- log4j? (
- dev-java/log4j-12-api:2
- dev-java/log4j-api:2
- dev-java/log4j-core:2
- )
- servletapi? ( dev-java/jakarta-servlet-api:4 )"
-
-RDEPEND="
- ${CDEPEND}
- >=virtual/jre-1.8:*"
-
-DEPEND="
- ${CDEPEND}
- >=virtual/jdk-1.8:*
- test? ( dev-java/ant-junit:0 )"
-
-S="${WORKDIR}/${P}-src"
-
-EANT_BUILD_TARGET="compile"
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-JAVA_ANT_IGNORE_SYSTEM_CLASSES="yes"
-
-DOCS=( RELEASE-NOTES.txt PROPOSAL.html )
-
-src_prepare() {
- default
-
- eapply "${FILESDIR}/${P}-gentoo.patch"
- # patch to make the build.xml respect no servletapi
- eapply "${FILESDIR}/${P}-servletapi.patch"
-
- # bug #208098
- echo "jdk.1.4.present=true" > build.properties || die
-
- if use avalon-framework; then
- echo "avalon-framework.jar=$(java-pkg_getjars avalon-framework-4.2)" >> build.properties || die
- fi
- if use avalon-logkit; then
- echo "logkit.jar=$(java-pkg_getjars avalon-logkit-2.0)" >> build.properties || die
- fi
- if use log4j; then
- # log4j12.jar can only contain path to one single file because
- # build.xml decides whether the Log4JLogger should be built with
- # <available file="${log4j12.jar}" property="log4j12.present"/>,
- # and a value that contains multiple file paths will cause the
- # test to return a negative result. However, classes from multiple
- # Log4j 2 JARs are needed to compile the sources. So, we combine
- # them into a single JAR on the go.
- # https://bugs.gentoo.org/834036
- mkdir -p "${T}/log4j-2" ||
- die "Failed to create temporary directory for Log4j 2 classes"
- pushd "${T}/log4j-2" > /dev/null ||
- die "Failed to enter temporary directory for Log4j 2 classes"
-
- local jar="$(java-config -j)"
- local dep
- for dep in log4j-{12-api,api,core}; do
- # Assuming SLOT="2" for Log4j 2 dependencies
- "${jar}" -xf "$(java-pkg_getjar "${dep}-2" "${dep}.jar")" ||
- die "Failed to extract files from ${dep}-2 installed on system"
- done
- "${jar}" -cf log4j-2.jar . || die "Failed to create JAR for Log4j"
-
- popd > /dev/null ||
- die "Failed to leave temporary directory for Log4j 2 classes"
-
- echo "log4j12.jar=${T}/log4j-2/log4j-2.jar" >> build.properties || die
- fi
-
- if use servletapi; then
- echo "servletapi.jar=$(java-pkg_getjars jakarta-servlet-api-4 )" >> build.properties || die
- fi
-}
-
-src_install() {
- local pkg=org.apache.commons.logging
- java-osgi_newjar "target/${P}.jar" "${pkg}" "Apache Commons Logging" "${pkg};version=\"${PV}\", ${pkg}.impl;version=\"${PV}\""
- java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
- java-pkg_newjar target/${PN}-adapters-${PV}.jar ${PN}-adapters.jar
-
- einstalldocs
- use doc && java-pkg_dojavadoc target/docs/
- use source && java-pkg_dosrc src/main/java/org
-}
-
-src_test() {
- # Do not run Log4j tests because these tests use an Appender to verify
- # logging correctness. The log4j-12-api bridge no longer supports using an
- # Appender for verifications since the methods for adding an Appender in
- # the bridge "are largely no-ops". This means an Appender's state would
- # never be changed by log4j-12-api after new messages are logged. The test
- # cases, however, expect changes to the Appender's state in such an event,
- # so they would fail with log4j-12-api.
- # https://logging.apache.org/log4j/log4j-2.8/log4j-1.2-api/index.html
- sed -i -e "/^log4j12\.jar=/d" build.properties ||
- die "Failed to skip Log4j tests by modifying build.properties"
- java-pkg-2_src_test
-}
diff --git a/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch b/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch
deleted file mode 100644
index a654ce1fc763..000000000000
--- a/dev-java/commons-logging/files/commons-logging-1.2-gentoo.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/build.xml
-+++ b/build.xml
-@@ -773,4 +773,23 @@
- </fail>
- </target>
-
-+ <target depends="" name="javadoc" description="o Generate javadoc" >
-+ <mkdir dir="${build.home}/docs" >
-+ </mkdir>
-+ <tstamp >
-+ <format pattern="2001-yyyy" property="year" >
-+ </format>
-+ </tstamp>
-+ <property name="copyright" value="Copyright &amp;copy; The Apache Software Foundation. All Rights Reserved." >
-+ </property>
-+ <property name="title" value="Logging 1.1 API" >
-+ </property>
-+ <javadoc use="true" author="true" sourcepath="src/main/java" destdir="${build.home}/docs" version="true" private="true" packagenames="org.apache.commons.logging.*" >
-+ <classpath >
-+ <path refid="javadoc.classpath" >
-+ </path>
-+ </classpath>
-+ </javadoc>
-+ </target>
-+
- </project>
diff --git a/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch b/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch
deleted file mode 100644
index a9fccba8d5c1..000000000000
--- a/dev-java/commons-logging/files/commons-logging-1.2-servletapi.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/build.xml
-+++ b/build.xml
-@@ -279,6 +279,8 @@
- classpathref="compile.classpath"
- classname="org.apache.log.Logger"/>
-
-+ <available classname="javax.servlet.ServletContextEvent" property="servletapi.present" classpathref="compile.classpath" ignoresystemclasses="true" ></available>
-+
- <available property="avalon-framework.present"
- classpathref="compile.classpath"
- classname="org.apache.avalon.framework.logger.Logger"/>
-@@ -315,6 +317,13 @@
- </echo>
- </target>
-
-+ <target depends="init,discovery" unless="servletapi.present" name="servletapi-warning" >
-+ <echo >
-+ *** WARNING ***
-+ ServletAPI not found: Cannot Build ServletContextCleaner
-+ </echo>
-+ </target>
-+
- <target name="avalon-framework-warning" unless='avalon-framework.present' depends='init,discovery'>
- <echo>
- *** WARNING ***
-@@ -337,7 +346,7 @@
- </target>
-
- <target name='warning'
-- depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,compile-1.4'/>
-+ depends='log4j12-warning,log4j13-warning,logkit-warning,jdk1.4-warning,avalon-framework-warning,servletapi-warning,compile-1.4'/>
-
- <target name="compile-only"
- depends="prepare,discovery,warning,show-lib-presence,compile-non-log4j,compile-log4j12,compile-log4j13,build-jar"/>
-@@ -365,6 +374,7 @@
-
- <exclude name="org/apache/commons/logging/impl/Log4J*.java"/>
-
-+ <exclude unless="servletapi.present" name="org/apache/commons/logging/impl/ServletContextCleaner.java" ></exclude>
- <exclude name="org/apache/commons/logging/impl/Jdk13LumberjackLogger.java"
- unless="jdk.1.4.present"/>
- <exclude name="org/apache/commons/logging/impl/Jdk14Logger.java"
diff --git a/dev-java/commons-logging/metadata.xml b/dev-java/commons-logging/metadata.xml
index 6d5d06dd2376..6f7f23a3f9e5 100644
--- a/dev-java/commons-logging/metadata.xml
+++ b/dev-java/commons-logging/metadata.xml
@@ -11,12 +11,6 @@
<remote-id type="github">apache/commons-logging</remote-id>
</upstream>
<use>
- <flag name="avalon-framework">Add optional support for avalon-framework</flag>
- <flag name="avalon-logkit">Add optional support for avalon-logkit</flag>
<flag name="log4j">Add optional support for log4j</flag>
- <flag name="servletapi">Add optional support for servletapi</flag>
</use>
- <longdescription>
- Apache Commons Logging is a thin adapter allowing configurable bridging to other, well known logging systems.
- </longdescription>
</pkgmetadata>