summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-07-22 10:58:33 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-23 07:31:17 +0200
commit22be474d52bd2ffcc699380d197a43b117aba662 (patch)
treefe660df9eb24cc15199c5bd68875b56c1174c94a /dev-java
parentdev-java/commons-vfs: remove obsolete version (diff)
downloadgentoo-22be474d52bd2ffcc699380d197a43b117aba662.tar.gz
gentoo-22be474d52bd2ffcc699380d197a43b117aba662.tar.bz2
gentoo-22be474d52bd2ffcc699380d197a43b117aba662.zip
dev-java/commons-collections: remove obsolete version
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/21743 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-collections/commons-collections-4.1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-java/commons-collections/commons-collections-4.1.ebuild b/dev-java/commons-collections/commons-collections-4.1.ebuild
deleted file mode 100644
index 3cb523c4cd89..000000000000
--- a/dev-java/commons-collections/commons-collections-4.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="org.apache.commons:commons-collections4:4.1"
-
-inherit java-pkg-2 java-pkg-simple
-
-SLOT="4"
-MY_P="${PN}${SLOT}-${PV}"
-
-DESCRIPTION="Extends the JCF classes with new interfaces, implementations and utilities"
-HOMEPAGE="https://commons.apache.org/collections/"
-SRC_URI="mirror://apache/${PN/-//}/source/${MY_P}-src.tar.gz"
-LICENSE="Apache-2.0"
-KEYWORDS="amd64 ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- >=virtual/jdk-1.7
- test? (
- dev-java/easymock:3.2
- dev-java/junit:4
- )"
-
-RDEPEND="
- >=virtual/jre-1.7"
-
-S="${WORKDIR}/${MY_P}-src"
-
-JAVA_SRC_DIR="src/main/java"
-
-src_install() {
- java-pkg-simple_src_install
- dodoc RELEASE-NOTES.txt
- docinto html
- dodoc {DEVELOPERS-GUIDE,PROPOSAL}.html
-}
-
-src_test() {
- local DIR=src/test/java
- local CP="${DIR}:${DIR}/../resources:${PN}.jar:$(java-pkg_getjars easymock-3.2,junit-4)"
- local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*" ! -name "BulkTest.*")
- TESTS="${TESTS//src\/test\/java\/}"
- TESTS="${TESTS//.java}"
- TESTS="${TESTS//\//.}"
-
- ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
- ejunit4 -classpath "${CP}" ${TESTS}
-}