summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-02 12:38:11 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-05 10:54:15 +0200
commit1e76dc4cdbe3398fa5abb282e9e838c733a1d723 (patch)
treeeeeda2068cee3fced3c8a8f1bb1db08b35659fd7 /dev-java
parentnet-dialup/ppp: Removed old (diff)
downloadgentoo-1e76dc4cdbe3398fa5abb282e9e838c733a1d723.tar.gz
gentoo-1e76dc4cdbe3398fa5abb282e9e838c733a1d723.tar.bz2
gentoo-1e76dc4cdbe3398fa5abb282e9e838c733a1d723.zip
dev-java/jopt-simple: add JAVA_RESOURCE_DIRS
Absence of resources causing test failures in jmh-core-1.35 update EAPI 6 -> 8 update SRC_URI update HOMEPAGE Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jopt-simple/jopt-simple-5.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-java/jopt-simple/jopt-simple-5.0-r1.ebuild b/dev-java/jopt-simple/jopt-simple-5.0-r1.ebuild
new file mode 100644
index 000000000000..7f09eeaea934
--- /dev/null
+++ b/dev-java/jopt-simple/jopt-simple-5.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A Java library for parsing command line options"
+HOMEPAGE="https://jopt-simple.github.io/jopt-simple/"
+SRC_URI="https://github.com/jopt-simple/jopt-simple/archive/jopt-simple-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/${PN}-${PN}-01719a6"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+src_install() {
+ einstalldocs
+ java-pkg-simple_src_install
+}