summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-12 09:29:57 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-12 09:33:06 +0000
commit096c6cd0dadf693c636d68727db44e262dfea043 (patch)
treeea1bd235b595fb740c9367e76a33e4be9351a7ba /dev-java
parentwww-client/chromium: Remove old (diff)
downloadgentoo-096c6cd0dadf693c636d68727db44e262dfea043.tar.gz
gentoo-096c6cd0dadf693c636d68727db44e262dfea043.tar.bz2
gentoo-096c6cd0dadf693c636d68727db44e262dfea043.zip
dev-java/osgi-compendium: Update SRC_URI and HOMEPAGE URLs. Lift fetch restrictions. Fixes bug 565498.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
index 96cb62778379..4207c291ebb0 100644
--- a/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
+++ b/dev-java/osgi-compendium/osgi-compendium-4.3.1.ebuild
@@ -9,38 +9,33 @@ JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-pkg-simple
DESCRIPTION="OSGi Service Platform Compendium API (Companion Code)"
-HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
-SRC_URI="http://www.osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
+HOMEPAGE="http://wiki.osgi.org/wiki/Release_4.3"
+SRC_URI="https://osgi.org/download/r4v43/osgi.cmpn-${PV}.jar"
LICENSE="Apache-2.0 OSGi-Specification-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-RESTRICT="bindist fetch"
-
-COMMON_DEPEND="dev-java/glassfish-persistence:0
+CDEPEND="dev-java/glassfish-persistence:0
dev-java/osgi-core-api:0
dev-java/osgi-foundation:0
dev-java/tomcat-servlet-api:3.0"
-DEPEND="${COMMON_DEPEND}
+DEPEND="${CDEPEND}
>=virtual/jdk-1.5
app-arch/unzip"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${CDEPEND}
>=virtual/jre-1.5"
JAVA_SRC_DIR="OSGI-OPT/src"
-JAVA_GENTOO_CLASSPATH="glassfish-persistence,osgi-core-api,osgi-foundation,tomcat-servlet-api-3.0"
-
-pkg_nofetch() {
- einfo "Please download osgi.cmpn-${PV}.jar from"
- einfo " http://www.osgi.org/Download/Release4V43"
- einfo "which you can find listed as"
- einfo " OSGi Service Platform Release 4 Version 4.3 Compendium Companion Code"
- einfo "after accepting the license."
-}
+JAVA_GENTOO_CLASSPATH="
+ osgi-core-api
+ osgi-foundation
+ glassfish-persistence
+ tomcat-servlet-api-3.0
+"
java_prepare() {
rm -r org || die