summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-01-06 09:44:21 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-01-06 10:08:34 +0000
commit4315b3edc94ae5e6f50269bc7175fb0eaacc23cf (patch)
treed9f35407fa24b16d1074f7d568f9f1800f6b9191 /dev-java/xstream
parentdev-java/dom4j: Stable for amd64. Retroactively mark stable for the remaining... (diff)
downloadgentoo-4315b3edc94ae5e6f50269bc7175fb0eaacc23cf.tar.gz
gentoo-4315b3edc94ae5e6f50269bc7175fb0eaacc23cf.tar.bz2
gentoo-4315b3edc94ae5e6f50269bc7175fb0eaacc23cf.zip
dev-java/xstream: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.26 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/xstream')
-rw-r--r--dev-java/xstream/xstream-1.3.1-r4.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/dev-java/xstream/xstream-1.3.1-r4.ebuild b/dev-java/xstream/xstream-1.3.1-r4.ebuild
index e0f82b3bb844..306f95876bfe 100644
--- a/dev-java/xstream/xstream-1.3.1-r4.ebuild
+++ b/dev-java/xstream/xstream-1.3.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,7 @@ HOMEPAGE="http://x-stream.github.io"
SRC_URI="http://repo.maven.apache.org/maven2/com/thoughtworks/${PN}/${PN}-distribution/${PV}/${PN}-distribution-${PV}-src.zip"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
# By default, these tests exit successfully on failure. Chewi has fixed
# that below but it's probably because they blow up spectacularly on
@@ -22,21 +22,24 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos
# last-rited, so we no longer bother to support them at all.
RESTRICT="test"
-CDEPEND="dev-java/cglib:3
- dev-java/dom4j:1
- dev-java/jdom:0
- dev-java/joda-time:0
+CDEPEND="
dev-java/xom:0
+ dev-java/jdom:0
dev-java/xpp3:0
- dev-java/xml-commons-external:1.3
- dev-java/jettison:0"
+ dev-java/cglib:3
+ dev-java/dom4j:1
+ dev-java/jettison:0
+ dev-java/joda-time:0
+ dev-java/xml-commons-external:1.3"
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=virtual/jre-1.6"
-DEPEND=">=virtual/jdk-1.6
+DEPEND="
+ ${CDEPEND}
app-arch/unzip
- ${CDEPEND}"
+ >=virtual/jdk-1.6"
S="${WORKDIR}/${P}/${PN}"
@@ -50,9 +53,9 @@ java_prepare() {
rm -rfv lib/jdk1.3 || die
}
-src_install(){
- java-pkg_newjar target/${P}.jar
- java-pkg_newjar target/${PN}-benchmark-${PV}.jar ${PN}-benchmark.jar
+src_install() {
+ java-pkg_newjar "target/${P}.jar"
+ java-pkg_newjar "target/${PN}-benchmark-${PV}.jar" "${PN}-benchmark.jar"
use doc && java-pkg_dojavadoc target/javadoc
use source && java-pkg_dosrc src/java/com