summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/logback/logback-1.0.13.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/logback/logback-1.0.13.ebuild')
-rw-r--r--dev-java/logback/logback-1.0.13.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-java/logback/logback-1.0.13.ebuild b/dev-java/logback/logback-1.0.13.ebuild
new file mode 100644
index 000000000000..9e8f4cbb74ea
--- /dev/null
+++ b/dev-java/logback/logback-1.0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A generic, reliable, fast & flexible logging framework for Java"
+HOMEPAGE="http://logback.qos.ch/"
+SRC_URI="http://logback.qos.ch/dist/${PN}-${PV}.tar.gz
+ http://dev.gentoo.org/~ercpe/distfiles/${CATEGORY}/${PN}/${P}-build.tar.bz2"
+
+LICENSE="|| ( EPL-1.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tomcat"
+
+CDEPEND="dev-java/janino:0
+ dev-java/jansi:0
+ java-virtuals/javamail:0
+ java-virtuals/servlet-api:2.5
+ dev-java/slf4j-api:0
+ tomcat? ( www-servers/tomcat:7 )
+"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="janino,jansi,javamail,servlet-api-2.5,slf4j-api"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/${PN}-core/target/${PN}-core.jar"
+
+java_prepare() {
+ find "${S}" -name "*.jar" -delete || die
+
+ use tomcat || rm -r "${S}"/${PN}-access/src/main/java/ch/qos/logback/access/tomcat/ || die
+ # remove the next line when we have jetty in the tree
+ rm -r "${S}"/${PN}-access/src/main/java/ch/qos/logback/access/jetty/ || die
+
+ use tomcat && EANT_GENTOO_CLASSPATH+=",tomcat-7"
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}-core/target/${PN}-core.jar
+ java-pkg_dojar "${S}"/${PN}-access/target/${PN}-access.jar
+
+ use source && java-pkg_dosrc "${S}"/${PN}-core/src/main/java "${S}"/${PN}-access/src/main/java
+ use doc && java-pkg_dojavadoc "${S}"/${PN}-core/target/site/apidocs
+ use examples && java-pkg_doexamples "${S}"/${PN}-examples/src/main/java/chapters/*
+}