summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/kryo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/kryo')
-rw-r--r--dev-java/kryo/Manifest3
-rw-r--r--dev-java/kryo/kryo-1.05.ebuild51
-rw-r--r--dev-java/kryo/kryo-2.21.ebuild51
-rw-r--r--dev-java/kryo/kryo-2.22.ebuild51
-rw-r--r--dev-java/kryo/metadata.xml13
5 files changed, 169 insertions, 0 deletions
diff --git a/dev-java/kryo/Manifest b/dev-java/kryo/Manifest
new file mode 100644
index 000000000000..1ef9e43bad0e
--- /dev/null
+++ b/dev-java/kryo/Manifest
@@ -0,0 +1,3 @@
+DIST kryo-1.05.zip 980393 SHA256 989c23c55fb5465cb4113f24fc728d17fa616bcf91bf4f8d9100c04c615b4a9e SHA512 b19aef102bf0e9a5980856ded3aaadd64616a0ed1d17488b5af1d349987c34603e641d2698712abba39a4fcaa2e9676ed11cc1902a8dfdaccba84a0a37161d40 WHIRLPOOL 4e007e5bb197e2269b9a970974937cbcb8c2905cb36885c2ea8a110f82524533c8e99875625d50155c8bb0b574fb4188404c1f0b9d7652ce4f101a4c2191be77
+DIST kryo-2.21.zip 1749241 SHA256 bab6232c7d07aa669fed19c15ecb4d319fb5072b3f7775d1d178d6c4fb8bd46e SHA512 e2bcf17b13e067b81951145981c091f3250c7c502fe30e9f41fcd0e62bb87bbf4373f5d367842e7b8966dad76f5580fa4e212edd1adf590a05b7e2f40e401c4a WHIRLPOOL 765875e8494de948a2cf594e5612b63504cddec9d91d7da6598cc69fb32b37925c4bfb4351650f9fe7a217535ae9882345d9194fb2dcef64dfec0b0b37371635
+DIST kryo-2.22.zip 2196334 SHA256 665c81ac37ff7912d3db94fcba766e9d9b14e920dea71be25f742b3c85202838 SHA512 4e2af99be7a251783886c717c2493f73c98faedc1bb5037d9a5344e539ed2a5eca1f1e02dec9adc68752d59ad07184bb4704f726f553261034a7287b83886b30 WHIRLPOOL 6fefa818d60fed4b4ea5672868e4a1f62e0bfcffafc5844943128db70195276b6b0074385abed1cc25ef583598b130a836ebf6d715851cf3eb73de8ba86d4ad2
diff --git a/dev-java/kryo/kryo-1.05.ebuild b/dev-java/kryo/kryo-1.05.ebuild
new file mode 100644
index 000000000000..d43141583b3b
--- /dev/null
+++ b/dev-java/kryo/kryo-1.05.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Fast, efficient Java serialization and cloning"
+HOMEPAGE="https://code.google.com/p/kryo/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/objenesis:0
+ dev-java/reflectasm:0
+ dev-java/minlog:0"
+
+DEPEND="${CDEPEND}
+ test? ( dev-java/junit:4 )
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="objenesis,reflectasm,minlog"
+JAVA_SRC_DIR="${PN}/src"
+
+src_prepare() {
+ rm "${S}"/${PN}/pom.xml || die
+ find "${S}" -name "*.jar" -delete || die
+}
+
+src_test() {
+ mkdir target/tests || die
+ local testcp="${S}/${PN}.jar:target/tests:$(java-pkg_getjars junit-4)"
+ testcp+=":$(java-pkg_getjars --with-dependencies ${JAVA_GENTOO_CLASSPATH})"
+
+ ejavac -cp "${testcp}" -d target/tests $(find ${PN}/test -name "*.java")
+ tests=$(find target/tests -name "*Test.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/kryo/kryo-2.21.ebuild b/dev-java/kryo/kryo-2.21.ebuild
new file mode 100644
index 000000000000..ad02e63465d2
--- /dev/null
+++ b/dev-java/kryo/kryo-2.21.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Fast, efficient Java serialization and cloning"
+HOMEPAGE="https://code.google.com/p/kryo/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/objenesis:0
+ dev-java/reflectasm:0
+ dev-java/minlog:0"
+
+DEPEND="${CDEPEND}
+ test? ( dev-java/junit:4 )
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}/java"
+
+JAVA_GENTOO_CLASSPATH="objenesis,reflectasm,minlog"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm "${S}"/pom.xml || die
+ find "${S}" -name "*.jar" -delete || die
+}
+
+src_test() {
+ mkdir target/tests || die
+ local testcp="${S}/${PN}.jar:target/tests:$(java-pkg_getjars junit-4)"
+ testcp+=":$(java-pkg_getjars --with-dependencies ${JAVA_GENTOO_CLASSPATH})"
+
+ ejavac -cp "${testcp}" -d target/tests $(find test/ -name "*.java")
+ tests=$(find target/tests -name "*Test.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/kryo/kryo-2.22.ebuild b/dev-java/kryo/kryo-2.22.ebuild
new file mode 100644
index 000000000000..ad02e63465d2
--- /dev/null
+++ b/dev-java/kryo/kryo-2.22.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source doc test"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Fast, efficient Java serialization and cloning"
+HOMEPAGE="https://code.google.com/p/kryo/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+CDEPEND="dev-java/objenesis:0
+ dev-java/reflectasm:0
+ dev-java/minlog:0"
+
+DEPEND="${CDEPEND}
+ test? ( dev-java/junit:4 )
+ >=virtual/jdk-1.5"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}/java"
+
+JAVA_GENTOO_CLASSPATH="objenesis,reflectasm,minlog"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm "${S}"/pom.xml || die
+ find "${S}" -name "*.jar" -delete || die
+}
+
+src_test() {
+ mkdir target/tests || die
+ local testcp="${S}/${PN}.jar:target/tests:$(java-pkg_getjars junit-4)"
+ testcp+=":$(java-pkg_getjars --with-dependencies ${JAVA_GENTOO_CLASSPATH})"
+
+ ejavac -cp "${testcp}" -d target/tests $(find test/ -name "*.java")
+ tests=$(find target/tests -name "*Test.class" \
+ | sed -e 's/target\/tests\///g' -e "s/\.class//" -e "s/\//./g" \
+ | grep -vP '\$');
+ ejunit4 -cp "${testcp}" ${tests}
+}
diff --git a/dev-java/kryo/metadata.xml b/dev-java/kryo/metadata.xml
new file mode 100644
index 000000000000..2d2ccc0795d8
--- /dev/null
+++ b/dev-java/kryo/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ Kryo is a fast and efficient object graph serialization framework for Java.
+ The goals of the project are speed, efficiency, and an easy to use API. The project
+ is useful any time objects need to be persisted, whether to a file, database, or over
+ the network. Kryo can also perform automatic deep and shallow copying/cloning. This is direct copying
+ from object to object, not object->bytes->object.
+ </longdescription>
+</pkgmetadata>
+