summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jgrapht
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jgrapht')
-rw-r--r--dev-java/jgrapht/Manifest1
-rw-r--r--dev-java/jgrapht/jgrapht-0.8.3.ebuild49
-rw-r--r--dev-java/jgrapht/metadata.xml8
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/jgrapht/Manifest b/dev-java/jgrapht/Manifest
new file mode 100644
index 000000000000..bcdcc18a4217
--- /dev/null
+++ b/dev-java/jgrapht/Manifest
@@ -0,0 +1 @@
+DIST jgrapht-0.8.3.tar.gz 1268147 SHA256 be8232508220773b7b94928da17547d32a68ba9697f7ff15f4f09bd9b2a7aa45 SHA512 964790dc74fea1d84f4a4cda4a253ede810725ee7173a2b376acb3f0e10baa2eefcbc38c76441600e0c282e0486243a464116cb803308eac134561181a2c28e6 WHIRLPOOL 53cc13347c092b70210b5246692cf71261c5014706dc6adcca16fbf8ed0b774b20a41a00c6f8e819d5e52e78ddcd84c48ae339cde45d7314f1ad39cfb2823670
diff --git a/dev-java/jgrapht/jgrapht-0.8.3.ebuild b/dev-java/jgrapht/jgrapht-0.8.3.ebuild
new file mode 100644
index 000000000000..e62efc8d3108
--- /dev/null
+++ b/dev-java/jgrapht/jgrapht-0.8.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Graph library that is a simpler and faster alternative to JGraph"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://jgrapht.sourceforge.net"
+
+KEYWORDS="amd64 ~ppc x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+CDEPEND="dev-java/touchgraph-graphlayout:0
+ dev-java/jgraph:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit:0
+ dev-java/xmlunit:1 )"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="touchgraph-graphlayout jgraph"
+EANT_DOC_TARGET="javadoc"
+
+java_prepare() {
+ rm -rf "${S}/lib" || die
+ rm -v "${S}"/*.jar || die
+}
+
+src_test() {
+ EANT_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH} xmlunit:1" ANT_TASKS="ant-junit" eant test
+}
+
+src_install() {
+ java-pkg_newjar ${PN}*.jar || die
+
+ dohtml README.html || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/org
+}
diff --git a/dev-java/jgrapht/metadata.xml b/dev-java/jgrapht/metadata.xml
new file mode 100644
index 000000000000..b6ac288e0445
--- /dev/null
+++ b/dev-java/jgrapht/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jgrapht</remote-id>
+ </upstream>
+</pkgmetadata>