summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/javahelp/javahelp-2.0.05_p63.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/javahelp/javahelp-2.0.05_p63.ebuild')
-rw-r--r--dev-java/javahelp/javahelp-2.0.05_p63.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/dev-java/javahelp/javahelp-2.0.05_p63.ebuild b/dev-java/javahelp/javahelp-2.0.05_p63.ebuild
new file mode 100644
index 000000000000..4bf1748c0ed4
--- /dev/null
+++ b/dev-java/javahelp/javahelp-2.0.05_p63.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+WANT_ANT_TASKS="ant-nodeps"
+JAVA_PKG_IUSE="doc examples source"
+
+inherit versionator java-pkg-2 java-ant-2
+
+DESCRIPTION="The JavaHelp system online help system"
+HOMEPAGE="https://javahelp.dev.java.net/"
+
+MY_PV="${PV/_p/_svn}"
+MY_PN="${PN}2"
+SRC_URI="https://${PN}.dev.java.net/files/documents/5985/145533/${MY_PN}-src-${MY_PV}.zip"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+COMMON_DEP="
+ java-virtuals/servlet-api:2.4"
+RDEPEND="
+ >=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND="
+ >=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}/"
+BDIR="${S}/javahelp_nbproject"
+
+src_unpack() {
+ unpack ${A}
+ # jdic does not currently build out of the box against the browsers we have
+ cd "${S}/jhMaster/JavaHelp/src/new/" || die
+ rm -v javax/help/plaf/basic/BasicNativeContentViewerUI.java || die
+ mkdir "${BDIR}/lib" && cd "${BDIR}/lib" || die
+ java-pkg_jar-from --virtual servlet-api-2.4
+ java-pkg_filter-compiler jikes
+}
+
+_eant() {
+ cd ${BDIR} || die
+ eant \
+ -Dservlet-jar="$(java-pkg_getjar --virtual servlet-api-2.4 servlet-api.jar)" \
+ -Djsp-jar="$(java-pkg_getjar --virtual servlet-api-2.4 jsp-api.jar)" \
+ -Djdic-jar-present=true \
+ -Djdic-zip-present=true \
+ -Dtomcat-zip-present=true \
+ -Dservlet-jar-present=true \
+ ${@}
+}
+
+src_compile() {
+ _eant release $(use_doc)
+}
+
+#Does not actually run anything
+#src_test() {
+# _eant test
+#}
+
+src_install() {
+ pushd jhMaster/JavaHelp >/dev/null || die
+ java-pkg_dojar "${BDIR}"/dist/lib/*.jar
+ java-pkg_dolauncher jhsearch \
+ --main com.sun.java.help.search.QueryEngine
+ java-pkg_dolauncher jhindexer \
+ --main com.sun.java.help.search.Indexer
+ use doc && java-pkg_dojavadoc "${BDIR}/dist/lib/javadoc"
+ popd >/dev/null || die
+
+ use source && java-pkg_dosrc \
+ ./jhMaster/JSearch/*/com \
+ ./jhMaster/JavaHelp/src/*/{javax,com}
+ use examples && java-pkg_doexamples jhMaster/JavaHelp/demos
+}
+
+pkg_postinst() {
+ elog "Native browser integration is disabled because it needs jdic"
+ elog "which does not build out of the box. See"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=53897 for progress"
+}