summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Ullmann <labre@posteo.de>2018-01-17 03:30:23 +0100
committerJames Le Cuirot <chewi@gentoo.org>2018-01-19 20:34:06 +0000
commit76c1a994a216e5081d611c1013a5176e73f15bcd (patch)
tree0e957d04d04dab0b94b769f3199c09e81fe3d977 /dev-java/java-sdk-docs
parentdev-java/oracle-jre-bin: Version bump to 9.0.4 (diff)
downloadgentoo-76c1a994a216e5081d611c1013a5176e73f15bcd.tar.gz
gentoo-76c1a994a216e5081d611c1013a5176e73f15bcd.tar.bz2
gentoo-76c1a994a216e5081d611c1013a5176e73f15bcd.zip
dev-java/java-sdk-docs: Version bump to 9.0.4
Closes: https://github.com/gentoo/gentoo/pull/6885
Diffstat (limited to 'dev-java/java-sdk-docs')
-rw-r--r--dev-java/java-sdk-docs/Manifest1
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-9.0.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/java-sdk-docs/Manifest b/dev-java/java-sdk-docs/Manifest
index f53ec1e5a615..dce988a23374 100644
--- a/dev-java/java-sdk-docs/Manifest
+++ b/dev-java/java-sdk-docs/Manifest
@@ -1,2 +1,3 @@
DIST jdk-8u152-docs-all.zip 93495668 BLAKE2B 9bb791ef4ace0fd180953e12501900a21583cf9cd8c256246c0d8b1fe139aa7c21fffd073cf6cfc27c206f00eb9d77fd510f8ced752f7c690a4762a9f52f3e8d SHA512 5aa49103685fc466bf2c5ff32aeee9ccf5b51359bb8e558bc8f23dc399fb108cba7fd282b669ce3b8062865fc4507afc809f8fb0ca844587eb168ad44c69ad77
DIST jdk-9.0.1_doc-all.zip 70497837 BLAKE2B 437aeae172d5a2133eb34f305925898aa80b52f15ae9860d148e3eda7de34b635c4defa0683009c4232658414c81d1f01fbea4201ea179347508caf63d13cd82 SHA512 c031497e5644abe9e9d72f9b2af6c11cf9842ee2f1001184704d994ec62b46a3620930e63944253c777d8ec9248418369579e439cf5c13c66805364669e54063
+DIST jdk-9.0.4_doc-all.zip 70500089 BLAKE2B 549da2c6baf1b39082f05d42d0fd02f7682a765c1d43a605063b155b3b3e2e20053b4044a238afb41c758700efa5de9ec53c29e2e8be1d682c2e9e7b221c0875 SHA512 7d8b40499a0ea91ac922c6916b19a061b39e73e54e123a943fcaa75fcfe66672ad445dbd789c2c9448c8cee0e7f72974ca6ad53bcaa5667547feca5791dab92b
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-9.0.4.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-9.0.4.ebuild
new file mode 100644
index 000000000000..865ee06d1665
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-9.0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk9-doc-downloads-3850606.html"
+
+SLOT="${PV%%.*}"
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="https://docs.oracle.com/javase/${SLOT}"
+SRC_URI="jdk-${PV}_doc-all.zip"
+LICENSE="oracle-java-documentation-${SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${SRC_URI} from"
+ einfo "${DOWNLOAD_URL}"
+ einfo "by agreeing to the license and place it in ${DISTDIR}"
+ einfo ""
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report it in bug #67266 (link below)."
+ einfo ""
+ einfo "If emerge fails because of a checksum error, it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "https://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install() {
+ insinto /usr/share/doc/${PN}-${SLOT}/html
+ doins -r index.html */
+}