summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jaffl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jaffl')
-rw-r--r--dev-java/jaffl/Manifest1
-rw-r--r--dev-java/jaffl/files/jaffl-0.5.11-GNUmakefile.patch11
-rw-r--r--dev-java/jaffl/files/jaffl-0.5.11-library-path.patch10
-rw-r--r--dev-java/jaffl/files/library-path-0.5.1.patch9
-rw-r--r--dev-java/jaffl/jaffl-0.5.11.ebuild87
-rw-r--r--dev-java/jaffl/metadata.xml12
6 files changed, 130 insertions, 0 deletions
diff --git a/dev-java/jaffl/Manifest b/dev-java/jaffl/Manifest
new file mode 100644
index 000000000000..fe59561e4016
--- /dev/null
+++ b/dev-java/jaffl/Manifest
@@ -0,0 +1 @@
+DIST jaffl-0.5.11.tar.gz 559465 SHA256 77a7e7bf0b98521ed749238fec8eb184426b074010874a9ee9f076e27b74ac6a SHA512 efa5479901ac6d21310af7d482298281189b7d91b806a273cf99faacb4ee0ec6862427077e2553153c3741a640371199cf78750cd4de9f9fdd92e3f1962d7728 WHIRLPOOL 6970de5819e6335c454584a5071290ed10ace121197a5f4396063dbc9eae388bffa573ab921c6896c018f4f3c1441a0dda54952de8a7527cb5aebefe0a7127f3
diff --git a/dev-java/jaffl/files/jaffl-0.5.11-GNUmakefile.patch b/dev-java/jaffl/files/jaffl-0.5.11-GNUmakefile.patch
new file mode 100644
index 000000000000..89e6dda90cc6
--- /dev/null
+++ b/dev-java/jaffl/files/jaffl-0.5.11-GNUmakefile.patch
@@ -0,0 +1,11 @@
+--- libtest/GNUmakefile.orig 2015-06-08 12:11:24.235000000 +0000
++++ libtest/GNUmakefile 2015-06-08 11:47:52.963000000 +0000
+@@ -38,7 +38,7 @@
+ # http://weblogs.java.net/blog/kellyohair/archive/2006/01/compilation_of_1.html
+ JFLAGS = -fno-omit-frame-pointer -fno-strict-aliasing
+ OFLAGS = -O2 $(JFLAGS)
+-WFLAGS = -W -Werror -Wall -Wno-unused -Wno-parentheses
++WFLAGS = -W -Wall -Wno-unused -Wno-parentheses
+ PICFLAGS = -fPIC
+ SOFLAGS = -shared -Wl,-O1
+ LDFLAGS += $(SOFLAGS)
diff --git a/dev-java/jaffl/files/jaffl-0.5.11-library-path.patch b/dev-java/jaffl/files/jaffl-0.5.11-library-path.patch
new file mode 100644
index 000000000000..4782f17111fd
--- /dev/null
+++ b/dev-java/jaffl/files/jaffl-0.5.11-library-path.patch
@@ -0,0 +1,10 @@
+--- src/com/kenai/jaffl/provider/Library.java.orig 2011-09-07 12:13:06.942731817 +0200
++++ src/com/kenai/jaffl/provider/Library.java 2011-09-07 12:13:08.983731771 +0200
+@@ -23,6 +23,7 @@
+ userLibraryPath.addAll(getPropertyPaths("jaffl.library.path"));
+ // Add JNA paths for compatibility
+ userLibraryPath.addAll(getPropertyPaths("jna.library.path"));
++ userLibraryPath.addAll(getPropertyPaths("java.library.path"));
+ }
+ };
+
diff --git a/dev-java/jaffl/files/library-path-0.5.1.patch b/dev-java/jaffl/files/library-path-0.5.1.patch
new file mode 100644
index 000000000000..2a0335ed65fe
--- /dev/null
+++ b/dev-java/jaffl/files/library-path-0.5.1.patch
@@ -0,0 +1,9 @@
+--- src/com/kenai/jaffl/provider/Library.java 2010-06-04 10:55:00.000000000 +1200
++++ src/com/kenai/jaffl/provider/Library.java 2010-06-04 10:55:49.000000000 +1200
+@@ -53,5 +53,6 @@
+ userLibraryPath.addAll(getPropertyPaths("jaffl.library.path"));
+ // Add JNA paths for compatibility
+ userLibraryPath.addAll(getPropertyPaths("jna.library.path"));
++ userLibraryPath.addAll(getPropertyPaths("java.library.path"));
+ }
+ }
diff --git a/dev-java/jaffl/jaffl-0.5.11.ebuild b/dev-java/jaffl/jaffl-0.5.11.ebuild
new file mode 100644
index 000000000000..742f5ee7b732
--- /dev/null
+++ b/dev-java/jaffl/jaffl-0.5.11.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit java-pkg-2 java-ant-2 versionator
+
+DESCRIPTION="An abstracted interface to invoking native functions from java"
+HOMEPAGE="http://kenai.com/projects/jaffl"
+SRC_URI="http://github.com/jnr/jnr-ffi/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+CDEPEND="dev-java/jffi:1.2
+ dev-java/jnr-x86asm:0
+ dev-java/asm:3"
+
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}
+ test? (
+ dev-java/junit:4
+ dev-java/ant-junit:0
+ dev-java/hamcrest-core:0
+ )"
+
+JAR_VERSION=$(get_version_component_range 1-2)
+
+src_unpack() {
+ default
+
+ mv * "${P}" || die
+}
+
+java_prepare() {
+ rm -vf lib/{.,junit*}/*.jar
+
+ epatch "${FILESDIR}"/${P}-library-path.patch
+ epatch "${FILESDIR}"/${P}-GNUmakefile.patch
+
+ # Don't choke on errors from generating the Javadoc
+ cd "${S}" || die
+ java-ant_xml-rewrite -f ./nbproject/build-impl.xml \
+ -c -e javadoc \
+ -a failonerror \
+ -v no
+
+ java-pkg_jar-from --into lib jffi-1.2
+ java-pkg_jar-from --into lib jnr-x86asm
+ java-pkg_jar-from --into lib asm-3 asm.jar asm-3.2.jar
+ java-pkg_jar-from --into lib asm-3 asm-analysis.jar asm-analysis-3.2.jar
+ java-pkg_jar-from --into lib asm-3 asm-commons.jar asm-commons-3.2.jar
+ java-pkg_jar-from --into lib asm-3 asm-tree.jar asm-tree-3.2.jar
+ java-pkg_jar-from --into lib asm-3 asm-util.jar asm-utils-3.2.jar
+ java-pkg_jar-from --into lib asm-3 asm-xml.jar asm-xml-3.2.jar
+}
+
+EANT_EXTRA_ARGS="-Dreference.jffi.jar=lib/jffi.jar \
+ -Dreference.jnr-x86asm.jar=lib/jnr-x86asm.jar \
+ -Dproject.jffi=\"${S}\" \
+ -Dproject.jnr-x86asm=\"${S}\"
+ -D\"already.built.${S}\"=true"
+
+src_test() {
+ local paths="$(java-config -di jnr-x86asm,jffi-1.2):${S}/build"
+
+ ANT_TASKS="ant-junit ant-nodeps" eant test \
+ -Drun.jvmargs="-Djava.library.path=${paths}" \
+ -Dlibs.junit_4.classpath="$(java-pkg_getjars junit-4,hamcrest-core)" ${EANT_EXTRA_ARGS}
+}
+
+src_install() {
+ java-pkg_newjar dist/${PN}-${JAR_VERSION}.jar
+
+ use doc && java-pkg_dojavadoc dist/javadoc
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jaffl/metadata.xml b/dev-java/jaffl/metadata.xml
new file mode 100644
index 000000000000..e5bc2e7bb499
--- /dev/null
+++ b/dev-java/jaffl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription lang="en">
+ A native function invocation interface that can have multiple different
+ low level implementations (e.g. JNA, JFFI or Maxine)
+ </longdescription>
+ <upstream>
+ <remote-id type="github">wmeissner/jaffl</remote-id>
+ </upstream>
+</pkgmetadata>