summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-17 13:43:29 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 16:50:13 +0300
commit33275e7369fbcc1bb980d6f5e81d3e91e450a614 (patch)
treea18d2df835d99cd6a4167b3402bc40dbed497ff8 /dev-java/guava
parentdev-java/jython: drop 2.7.0-r4 (diff)
downloadgentoo-33275e7369fbcc1bb980d6f5e81d3e91e450a614.tar.gz
gentoo-33275e7369fbcc1bb980d6f5e81d3e91e450a614.tar.bz2
gentoo-33275e7369fbcc1bb980d6f5e81d3e91e450a614.zip
dev-java/guava: drop 20.0, 20.0-r1
Closes: https://bugs.gentoo.org/833309 Closes: https://bugs.gentoo.org/657692 Bug: https://bugs.gentoo.org/760111 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25940 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-java/guava')
-rw-r--r--dev-java/guava/Manifest1
-rw-r--r--dev-java/guava/guava-20.0-r1.ebuild36
-rw-r--r--dev-java/guava/guava-20.0.ebuild36
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-java/guava/Manifest b/dev-java/guava/Manifest
index 23aa60425858..6cdfcc4ae4a4 100644
--- a/dev-java/guava/Manifest
+++ b/dev-java/guava/Manifest
@@ -1,2 +1 @@
-DIST guava-20.0.tar.gz 2522092 BLAKE2B 2ca76a71d0c169b80bfaa3e9847b2e465c57aabc0a67622a69519808fa8455146228747dc20e999ebc20ef7cd5fec1cfa82f6c025e9378011619cfedbc2c7d6c SHA512 e89eee8e66502f208878af286c660393712b12fb37647ec70719ca7c5184686c8dc5fc59d45c1813d792ecad9421e2c077dab075f76b1907c04f9f6e80567ac9
DIST guava-30.1.1.tar.gz 5404546 BLAKE2B 818ef4b17c4f0c8e92c327f046434a3bb428ac35d6e95edd6d6be558c755d138a8ac7f8ad2032073cad131890d8f838e896fff84ba217f8305be8bd65c619a48 SHA512 23b30d886a3200b8f998897ca7bc424b2d223a4fecb03ab644e08a989a85f008e30ef093055e6305c4148a1eb8919c407e35d19f492c5b189830bd115e9484f2
diff --git a/dev-java/guava/guava-20.0-r1.ebuild b/dev-java/guava/guava-20.0-r1.ebuild
deleted file mode 100644
index 91ac8943a4bd..000000000000
--- a/dev-java/guava/guava-20.0-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="com.google.guava:guava:20.0"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A collection of Google's core Java libraries"
-HOMEPAGE="https://github.com/google/guava"
-SRC_URI="https://github.com/google/guava/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="${PV%.*}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-
-CP_DEPEND="
- dev-java/animal-sniffer-annotations:0
- dev-java/error-prone-annotations:0
- dev-java/jsr305:0
-"
-
-RDEPEND="${CP_DEPEND}
- >=virtual/jre-1.8:*"
-
-DEPEND="${CP_DEPEND}
- >=virtual/jdk-1.8:*
- dev-java/j2objc-annotations:0"
-
-S="${WORKDIR}/${P}/${PN}"
-JAVA_SRC_DIR="src"
-
-src_configure() {
- JAVA_GENTOO_CLASSPATH_EXTRA=$(java-pkg_getjars --build-only j2objc-annotations)
-}
diff --git a/dev-java/guava/guava-20.0.ebuild b/dev-java/guava/guava-20.0.ebuild
deleted file mode 100644
index b81b0b0497d0..000000000000
--- a/dev-java/guava/guava-20.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-JAVA_PKG_IUSE="doc source"
-MAVEN_ID="com.google.guava:guava:20.0"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="A collection of Google's core Java libraries"
-HOMEPAGE="https://github.com/google/guava"
-SRC_URI="https://github.com/google/guava/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="${PV%.*}"
-KEYWORDS="amd64 ~arm arm64 ppc64 x86"
-
-CP_DEPEND="
- dev-java/animal-sniffer-annotations:0
- dev-java/error-prone-annotations:0
- dev-java/jsr305:0
-"
-
-RDEPEND="${CP_DEPEND}
- >=virtual/jre-1.7"
-
-DEPEND="${CP_DEPEND}
- >=virtual/jdk-1.7
- dev-java/j2objc-annotations:0"
-
-S="${WORKDIR}/${P}/${PN}"
-JAVA_SRC_DIR="src"
-
-src_configure() {
- JAVA_GENTOO_CLASSPATH_EXTRA=$(java-pkg_getjars --build-only j2objc-annotations)
-}