summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/glassfish-servlet-api
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/glassfish-servlet-api')
-rw-r--r--dev-java/glassfish-servlet-api/Manifest1
-rw-r--r--dev-java/glassfish-servlet-api/files/build_xml.patch12
-rw-r--r--dev-java/glassfish-servlet-api/glassfish-servlet-api-2_beta44.ebuild36
-rw-r--r--dev-java/glassfish-servlet-api/metadata.xml9
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-java/glassfish-servlet-api/Manifest b/dev-java/glassfish-servlet-api/Manifest
new file mode 100644
index 000000000000..f94e1b37ca23
--- /dev/null
+++ b/dev-java/glassfish-servlet-api/Manifest
@@ -0,0 +1 @@
+DIST glassfish-v2-b44-src.zip 35200817 SHA256 331f6a65aa94b9d79f5b0a726d71afc4726032b3e9d62f2c7ab6fc679790e1b7 SHA512 2c236f37c08ec465959e80c90e3a2f8cdf9d143dc93c7a6bbdcc6e015125f167153f6abfaba4390a5d179b43130458b996498d3f1390588477462bd45ea367ee WHIRLPOOL 71c9b9cbcc194ffe03f4a604b570d618f88b7f08955b573f6b218683fba854267ee83915d26d909d8caf92779a2e15752d6fbce6c402d8ca69b108d18042845b
diff --git a/dev-java/glassfish-servlet-api/files/build_xml.patch b/dev-java/glassfish-servlet-api/files/build_xml.patch
new file mode 100644
index 000000000000..033ebd625271
--- /dev/null
+++ b/dev-java/glassfish-servlet-api/files/build_xml.patch
@@ -0,0 +1,12 @@
+--- build.xml 2007-04-27 03:38:38.000000000 -0400
++++ build.xml 2007-04-27 03:39:17.000000000 -0400
+@@ -28,7 +28,9 @@
+ target="dist" inheritAll="false"/>
+ <ant dir="${servlet.api.home}/src/jsr245"
+ target="dist" inheritAll="false"/>
++<!--
+ <antcall target="prepare-jar"/>
++-->
+ </target>
+
+ <!-- build pwc-->
diff --git a/dev-java/glassfish-servlet-api/glassfish-servlet-api-2_beta44.ebuild b/dev-java/glassfish-servlet-api/glassfish-servlet-api-2_beta44.ebuild
new file mode 100644
index 000000000000..795b4314ad8c
--- /dev/null
+++ b/dev-java/glassfish-servlet-api/glassfish-servlet-api-2_beta44.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit base java-pkg-2 java-ant-2
+
+MY_PV="${PV/_beta/-b}"
+DESCRIPTION="Glassfish reference implementation of Servlet API 2.5 and JSP API 2.1"
+HOMEPAGE="https://glassfish.dev.java.net/javaee5/webtier/webtierhome.html"
+SRC_URI="http://download.java.net/javaee5/trunk/promoted/source/glassfish-v${MY_PV}-src.zip"
+LICENSE="CDDL"
+SLOT="2.5"
+KEYWORDS="amd64 x86"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/glassfish/servlet-api/"
+
+PATCHES=( "${FILESDIR}/build_xml.patch" )
+
+src_compile() {
+ eant build $(use doc || echo -Ddocs.uptodate=true)
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/src/jakarta-servletapi-5/jsr154/dist/lib/*.jar
+ java-pkg_dojar "${S}"/src/jsr245/dist/lib/*.jar
+
+ use doc && java-pkg_dojavadoc src/jsr245/build/docs/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/glassfish-servlet-api/metadata.xml b/dev-java/glassfish-servlet-api/metadata.xml
new file mode 100644
index 000000000000..0bd86abdd107
--- /dev/null
+++ b/dev-java/glassfish-servlet-api/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ The Glassfish Reference implementation of the Servlet/JSP API
+ specifications.
+ </longdescription>
+</pkgmetadata>