summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorValérian Rousset <tharvik@users.noreply.github.com>2023-05-08 22:24:54 +0200
committerSam James <sam@gentoo.org>2023-05-20 10:21:44 +0100
commit3698329f8548e8e70fc9ab6a245f9ba5f80b8f1b (patch)
tree70255395a03cef52d970cdc7813a2c71e56782d0 /dev-java/cache2k-api/cache2k-api-0.23.1.ebuild
parentnet-libs/nativebiginteger: drop 1.7.0 (diff)
downloadgentoo-3698329f8548e8e70fc9ab6a245f9ba5f80b8f1b.tar.gz
gentoo-3698329f8548e8e70fc9ab6a245f9ba5f80b8f1b.tar.bz2
gentoo-3698329f8548e8e70fc9ab6a245f9ba5f80b8f1b.zip
dev-java/cache2k-api: new package, add 0.23.1
Signed-off-by: Valérian Rousset <tharvik@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/cache2k-api/cache2k-api-0.23.1.ebuild')
-rw-r--r--dev-java/cache2k-api/cache2k-api-0.23.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-java/cache2k-api/cache2k-api-0.23.1.ebuild b/dev-java/cache2k-api/cache2k-api-0.23.1.ebuild
new file mode 100644
index 000000000000..3acd23e1f290
--- /dev/null
+++ b/dev-java/cache2k-api/cache2k-api-0.23.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.cache2k:cache2k-api:0.23.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="light weight and high performance Java caching library: API"
+HOMEPAGE="https://cache2k.org"
+SRC_URI="https://github.com/cache2k/cache2k/archive/v${PV}.tar.gz -> cache2k-${PV}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/cache2k-${PV}/api"
+
+JAVA_SRC_DIR="src/main/java"