summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-06-29 18:00:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-06-29 18:00:40 +0100
commitea9dc89429895886047a1b1ddcd8eeddbf345352 (patch)
tree8bd350233741de9de45ca63d96775da4d2a4a10f /dev-haskell
parentnet-misc/sipp: add net-misc/lksctp-tools to DEPEND (diff)
downloadgentoo-ea9dc89429895886047a1b1ddcd8eeddbf345352.tar.gz
gentoo-ea9dc89429895886047a1b1ddcd8eeddbf345352.tar.bz2
gentoo-ea9dc89429895886047a1b1ddcd8eeddbf345352.zip
dev-haskell/http-streams: bump up to 0.8.7.2
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/799233 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/http-streams/Manifest1
-rw-r--r--dev-haskell/http-streams/http-streams-0.8.7.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/http-streams/Manifest b/dev-haskell/http-streams/Manifest
index 59b47bc871cc..c0d37d520c74 100644
--- a/dev-haskell/http-streams/Manifest
+++ b/dev-haskell/http-streams/Manifest
@@ -1 +1,2 @@
DIST http-streams-0.8.7.1.tar.gz 35149 BLAKE2B c7b754b694b612f167b072e17abf14a537aa36422ee4a55695c25b84e8780a6acff61ad9d2041b0ee2cc2cf51f77cdee732021870418d506cbf07a80cbb1b88e SHA512 6c2613cc6bcc1b54916c484834779fb3388085082df33216beb12685eb8e56c0f45b2bf24d657acc6c0295ea429c0e1947213a1235c4373cfdcf10899c93bee1
+DIST http-streams-0.8.7.2.tar.gz 35163 BLAKE2B 80b5a12bd95379009993efe1eb3f484c54e143d2d132a9b7a4faa64fd59fcacdade0b388138de7357692c49bffbdf508ccf05dc2e919e56c59e52191bf1b7f8c SHA512 1028e7a102fc189ddd20d353492306d506f24f0408a234e0ec2b01c11737bc9ffec76a5609e18e355ef838663ec412ce3b358d8223deea7dd4c35ada5223f3ea
diff --git a/dev-haskell/http-streams/http-streams-0.8.7.2.ebuild b/dev-haskell/http-streams/http-streams-0.8.7.2.ebuild
new file mode 100644
index 000000000000..e2e1e9367992
--- /dev/null
+++ b/dev-haskell/http-streams/http-streams-0.8.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Drop 'test-suite' to avoid circular depend
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client using io-streams"
+HOMEPAGE="https://github.com/afcowie/http-streams/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RESTRICT=test #circular test depend: http-streams -> snap-server -> http-streams
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/blaze-builder-0.4:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ >=dev-haskell/hsopenssl-0.11.2:=[profile?]
+ >=dev-haskell/http-common-0.8.2:=[profile?]
+ >=dev-haskell/io-streams-1.3:=[zlib,profile?] <dev-haskell/io-streams-1.6:=[zlib,profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/openssl-streams-1.1:=[profile?] <dev-haskell/openssl-streams-1.4:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?]
+ <dev-haskell/network-uri-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}