summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 12:31:48 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:03:16 +0100
commit35dd58673e2f39bc87d950d6b35404d25f249e38 (patch)
tree69b301ff3c7eab65ccbb43ce9eefc8092798c06a /dev-haskell/zip-archive/zip-archive-0.4.1.ebuild
parentdev-haskell/streaming-commons: bump up to 0.2.1.2 (diff)
downloadgentoo-35dd58673e2f39bc87d950d6b35404d25f249e38.tar.gz
gentoo-35dd58673e2f39bc87d950d6b35404d25f249e38.tar.bz2
gentoo-35dd58673e2f39bc87d950d6b35404d25f249e38.zip
dev-haskell/zip-archive: bump up to 0.4.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/zip-archive/zip-archive-0.4.1.ebuild')
-rw-r--r--dev-haskell/zip-archive/zip-archive-0.4.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/zip-archive/zip-archive-0.4.1.ebuild b/dev-haskell/zip-archive/zip-archive-0.4.1.ebuild
new file mode 100644
index 000000000000..8774d5580de2
--- /dev/null
+++ b/dev-haskell/zip-archive/zip-archive-0.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Library for creating and modifying zip archives"
+HOMEPAGE="https://github.com/jgm/zip-archive"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+RDEPEND=">=dev-haskell/digest-0.0.0.1:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.0
+ test? ( dev-haskell/hunit
+ dev-haskell/temporary )
+"
+# non-haskell depend
+DEPEND="${DEPEND}
+ test? ( app-arch/zip )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable)
+}