summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:40 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:08 +0100
commita8d8ea176955bb50c43fcb1f04e47f24d0da98b4 (patch)
tree19f99b8a9501a4f38eb7a1886a91eec27f2a96d3 /dev-haskell/wai-websockets
parentdev-haskell/websockets: new package, add 0.12.7.3 (diff)
downloadgentoo-a8d8ea176955bb50c43fcb1f04e47f24d0da98b4.tar.gz
gentoo-a8d8ea176955bb50c43fcb1f04e47f24d0da98b4.tar.bz2
gentoo-a8d8ea176955bb50c43fcb1f04e47f24d0da98b4.zip
dev-haskell/wai-websockets: new package, add 3.0.1.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/wai-websockets')
-rw-r--r--dev-haskell/wai-websockets/Manifest1
-rw-r--r--dev-haskell/wai-websockets/metadata.xml12
-rw-r--r--dev-haskell/wai-websockets/wai-websockets-3.0.1.2.ebuild38
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/wai-websockets/Manifest b/dev-haskell/wai-websockets/Manifest
new file mode 100644
index 000000000000..7977d725540e
--- /dev/null
+++ b/dev-haskell/wai-websockets/Manifest
@@ -0,0 +1 @@
+DIST wai-websockets-3.0.1.2.tar.gz 7051 BLAKE2B 0c39cd9917e1c340413e48737e4fd5ada23056189a6aad9de1aaf551f12b45b9544b99b54bbf078ccf88aea816f025c3508e07212ca05a2e9a2d779fd1edeee9 SHA512 c3415d1a36ca2f063fb1ae0ff7d3d9d271d8ff2c6099a754baed45f1c36f24cf1fa346e8e6403499cbeb329bcdf89326a9ed95f8e60111b4a879f5e51967ecc0
diff --git a/dev-haskell/wai-websockets/metadata.xml b/dev-haskell/wai-websockets/metadata.xml
new file mode 100644
index 000000000000..3d76fcca496a
--- /dev/null
+++ b/dev-haskell/wai-websockets/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="hackage">wai-websockets</remote-id>
+ <remote-id type="github">yesodweb/wai</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/wai-websockets/wai-websockets-3.0.1.2.ebuild b/dev-haskell/wai-websockets/wai-websockets-3.0.1.2.ebuild
new file mode 100644
index 000000000000..5c63f00f4c2f
--- /dev/null
+++ b/dev-haskell/wai-websockets/wai-websockets-3.0.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: example:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Provide a bridge between WAI and the websockets package"
+HOMEPAGE="https://github.com/yesodweb/wai"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+examples"
+
+RDEPEND=">=dev-haskell/case-insensitive-0.2:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ >=dev-haskell/network-2.2.1.5:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
+ >=dev-haskell/websockets-0.9:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ examples? ( dev-haskell/file-embed:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/wai-app-static:=[profile?]
+ dev-haskell/warp:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples example)
+}