summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-12-22 16:50:07 +1100
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-22 08:03:00 +0000
commit85448bce840233af018f6a21c41b5d9662d1e848 (patch)
treecca93a32dbb857ab684fd16a339af963635cc4ec /dev-haskell/text/text-1.2.4.0-r1.ebuild
parentdev-python/pytest-xdist: keyworded 2.2.0-r1 for hppa, bug #752237 (diff)
downloadgentoo-85448bce840233af018f6a21c41b5d9662d1e848.tar.gz
gentoo-85448bce840233af018f6a21c41b5d9662d1e848.tar.bz2
gentoo-85448bce840233af018f6a21c41b5d9662d1e848.zip
dev-haskell/text: tighten ghc upper bound
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/18758 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/text/text-1.2.4.0-r1.ebuild')
-rw-r--r--dev-haskell/text/text-1.2.4.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/text/text-1.2.4.0-r1.ebuild b/dev-haskell/text/text-1.2.4.0-r1.ebuild
new file mode 100644
index 000000000000..32cb6fed33fa
--- /dev/null
+++ b/dev-haskell/text/text-1.2.4.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -bytestring-builder,-developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # broken test-suite
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/haskell/text"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.8
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+# break cyclic dependencies, test suite requires porting to >=QC-2.11
+RESTRICT=test
+
+RDEPEND=">=dev-lang/ghc-8.8.1:= <dev-lang/ghc-8.10:="
+
+DEPEND="${RDEPEND}
+"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.8.1 PM:8.8.2 PM:8.8.3 PM:8.8.4 PM:9999"
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bytestring-builder \
+ --flag=-developer \
+ --flag=-integer-simple
+}