summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 08:41:13 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:56 +0000
commitf07ac18fbdee2b96ca7bfe3899545a2ba8529ac7 (patch)
tree7e5e9585439b9f2f57acd7249f81f8e800c921d1 /dev-haskell/text-show
parentdev-haskell/deriving-compat: new package, a depend of dev-haskell/persistent-2.6 (diff)
downloadgentoo-f07ac18fbdee2b96ca7bfe3899545a2ba8529ac7.tar.gz
gentoo-f07ac18fbdee2b96ca7bfe3899545a2ba8529ac7.tar.bz2
gentoo-f07ac18fbdee2b96ca7bfe3899545a2ba8529ac7.zip
dev-haskell/text-show: new package, a depend of dev-haskell/persistent-2.6
Efficient conversion of values into Text Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/text-show')
-rw-r--r--dev-haskell/text-show/Manifest1
-rw-r--r--dev-haskell/text-show/metadata.xml44
-rw-r--r--dev-haskell/text-show/text-show-3.4.ebuild50
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-haskell/text-show/Manifest b/dev-haskell/text-show/Manifest
new file mode 100644
index 000000000000..72edb9f9695d
--- /dev/null
+++ b/dev-haskell/text-show/Manifest
@@ -0,0 +1 @@
+DIST text-show-3.4.tar.gz 105127 SHA256 ce8a7adcca87617766a4c988808ff41fee20a2c84ac5442d6f3d8c5cec55d7c7 SHA512 48b7fdd801c4fc31e12f14a9ba0589e0971481a2f8562d00c697a9fd48f6420e73df0a7318ff4579a786cd606a1fda2287eab3f8c423810c0d00919c68eeebed WHIRLPOOL 16a71ec9985d0714e964c69a444d3664fc67ce095b4d6950ae1cecd6b79533f30a4a785876ec0f37590deec36727e33c15f0298fc481a3cea5dab29ef9631015
diff --git a/dev-haskell/text-show/metadata.xml b/dev-haskell/text-show/metadata.xml
new file mode 100644
index 000000000000..3e79c8095cdb
--- /dev/null
+++ b/dev-haskell/text-show/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ @text-show@ offers a replacement for the @Show@ typeclass intended
+ for use with @Text@ instead of @String@s. This package was created
+ in the spirit of
+ @&lt;http://hackage.haskell.org/package/bytestring-show bytestring-show&gt;@.
+
+ At the moment, @text-show@ provides instances for most data
+ types in the @&lt;http://hackage.haskell.org/package/array array&gt;@,
+ @&lt;http://hackage.haskell.org/package/base base&gt;@,
+ @&lt;http://hackage.haskell.org/package/bytestring bytestring&gt;@, and
+ @&lt;http://hackage.haskell.org/package/text text&gt;@ packages.
+ Therefore, much of the source code for @text-show@ consists of
+ borrowed code from those packages in order to ensure that the
+ behaviors of @Show@ and @TextShow@ coincide.
+
+ For most uses, simply importing "TextShow"
+ will suffice:
+
+ @
+ module Main where
+
+ import TextShow
+
+ main :: IO ()
+ main = printT (Just \"Hello, World!\")
+ @
+
+ If you desire it, there are also monomorphic versions of the @showb@
+ function available in the submodules of "TextShow". See the
+ &lt;https://github.com/RyanGlScott/text-show/wiki/Naming-conventions naming conventions&gt;
+ page for more information.
+
+ Support for automatically deriving @TextShow@ instances can be found
+ in the "TextShow.TH" and "TextShow.Generic" modules. If you don't
+ know which one to use, use "TextShow.TH".
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/text-show/text-show-3.4.ebuild b/dev-haskell/text-show/text-show-3.4.ebuild
new file mode 100644
index 000000000000..0d2255745e14
--- /dev/null
+++ b/dev-haskell/text-show/text-show-3.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into Text"
+HOMEPAGE="https://github.com/RyanGlScott/text-show"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-compat-0.8.1:=[profile?] <dev-haskell/base-compat-1:=[profile?]
+ >=dev-haskell/bifunctors-5.1:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ >=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-haskell/generic-deriving-1.11:=[profile?] <dev-haskell/generic-deriving-2:=[profile?]
+ >=dev-haskell/nats-0.1:=[profile?] <dev-haskell/nats-2:=[profile?]
+ >=dev-haskell/semigroups-0.17:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.4.4:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/text-0.11.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/th-lift-0.7.6:=[profile?] <dev-haskell/th-lift-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-haskell/void-0.5:=[profile?] <dev-haskell/void-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/base-compat-0.8.2 <dev-haskell/base-compat-1
+ >=dev-haskell/base-orphans-0.5.2 <dev-haskell/base-orphans-1
+ >=dev-haskell/deriving-compat-0.3 <dev-haskell/deriving-compat-1
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.5 <dev-haskell/quickcheck-3
+ >=dev-haskell/quickcheck-instances-0.1 <dev-haskell/quickcheck-instances-0.4
+ >=dev-haskell/tagged-0.8.3 <dev-haskell/tagged-1 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer
+}