summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:10:11 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:14 +0100
commit373b9b32d50120a545a2b78e0dca8b57c68bf334 (patch)
tree51b43575c0302ed614ba46687db8ad66bac91982 /dev-haskell/text-show
parentdev-haskell/text-short: Hackage revision bump (diff)
downloadgentoo-373b9b32d50120a545a2b78e0dca8b57c68bf334.tar.gz
gentoo-373b9b32d50120a545a2b78e0dca8b57c68bf334.tar.bz2
gentoo-373b9b32d50120a545a2b78e0dca8b57c68bf334.zip
dev-haskell/text-show: add 3.10.4
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/text-show')
-rw-r--r--dev-haskell/text-show/Manifest1
-rw-r--r--dev-haskell/text-show/metadata.xml37
-rw-r--r--dev-haskell/text-show/text-show-3.10.4.ebuild42
3 files changed, 44 insertions, 36 deletions
diff --git a/dev-haskell/text-show/Manifest b/dev-haskell/text-show/Manifest
index e89c93f604ac..5e88ab12a7fa 100644
--- a/dev-haskell/text-show/Manifest
+++ b/dev-haskell/text-show/Manifest
@@ -1 +1,2 @@
+DIST text-show-3.10.4.tar.gz 101876 BLAKE2B a51a0a536dab520c924516171703ebe6a71cfdb22a46b4f4aaccab7f69b78aa3d07c14a2b7226f14ffa89ffff84adcc7abcb1646d3add7f2ff0fa7a494175ea3 SHA512 f74eec545cd2994b3ebde9552e15e8b26c60ff00f6438f0c7bc2d92148a34fa85d41b8c04de0a960d468bc928346a5a8cd676a604f9dd81fc14d2ad5667a9d7f
DIST text-show-3.9.7.tar.gz 96683 BLAKE2B 402b41fe0ea539fb2bc98f5271dda37605e86751622dda6136bca8b8ec92917b15ab69e606c4b8fbb6e055f1ee14aed2cd5d446be4c6f494662a0ce153075328 SHA512 d32c2c5c9ea833ac2b996ef299bc7fa2736dfb0ccd86117cd964512ccc25af5eda126fc6dee0537d4740bd38fa9a73ea899e1dd73a30bec775f9966f2121a748
diff --git a/dev-haskell/text-show/metadata.xml b/dev-haskell/text-show/metadata.xml
index eca7e7acbe42..4f3fc546038a 100644
--- a/dev-haskell/text-show/metadata.xml
+++ b/dev-haskell/text-show/metadata.xml
@@ -5,43 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- @text-show@ offers a replacement for the @Show@ typeclass intended
- for use with @Text@ instead of @String@s. This package was created
- in the spirit of
- @&lt;http://hackage.haskell.org/package/bytestring-show bytestring-show&gt;@.
-
- At the moment, @text-show@ provides instances for most data
- types in the @&lt;http://hackage.haskell.org/package/array array&gt;@,
- @&lt;http://hackage.haskell.org/package/base base&gt;@,
- @&lt;http://hackage.haskell.org/package/bytestring bytestring&gt;@, and
- @&lt;http://hackage.haskell.org/package/text text&gt;@ packages.
- Therefore, much of the source code for @text-show@ consists of
- borrowed code from those packages in order to ensure that the
- behaviors of @Show@ and @TextShow@ coincide.
-
- For most uses, simply importing "TextShow"
- will suffice:
-
- @
- module Main where
-
- import TextShow
-
- main :: IO ()
- main = printT (Just \"Hello, World!\")
- @
-
- If you desire it, there are also monomorphic versions of the @showb@
- function available in the submodules of "TextShow". See the
- &lt;https://github.com/RyanGlScott/text-show/wiki/Naming-conventions naming conventions&gt;
- page for more information.
-
- Support for automatically deriving @TextShow@ instances can be found
- in the "TextShow.TH" and "TextShow.Generic" modules. If you don't
- know which one to use, use "TextShow.TH".
- </longdescription>
<upstream>
+ <remote-id type="hackage">text-show</remote-id>
<remote-id type="github">RyanGlScott/text-show</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/text-show/text-show-3.10.4.ebuild b/dev-haskell/text-show/text-show-3.10.4.ebuild
new file mode 100644
index 000000000000..c40812157058
--- /dev/null
+++ b/dev-haskell/text-show/text-show-3.10.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: -developer,-integer-gmp
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient conversion of values into Text"
+HOMEPAGE="https://github.com/RyanGlScott/text-show"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/base-compat-batteries-0.11:=[profile?] <dev-haskell/base-compat-batteries-0.14:=[profile?]
+ >=dev-haskell/bifunctors-5.1:=[profile?] <dev-haskell/bifunctors-6:=[profile?]
+ dev-haskell/bytestring-builder:=[profile?]
+ >=dev-haskell/generic-deriving-1.14.1:=[profile?] <dev-haskell/generic-deriving-2:=[profile?]
+ >=dev-haskell/text-0.11.1:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/th-abstraction-0.4:=[profile?] <dev-haskell/th-abstraction-0.7:=[profile?]
+ >=dev-haskell/th-lift-0.7.6:=[profile?] <dev-haskell/th-lift-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.5:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/base-orphans-0.8.5 <dev-haskell/base-orphans-0.10
+ >=dev-haskell/deriving-compat-0.6.5 <dev-haskell/deriving-compat-1
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.14.3 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/quickcheck-instances-0.3.28 <dev-haskell/quickcheck-instances-0.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-developer \
+ --flag=-integer-gmp
+}