summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:13:15 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:44 +0100
commit30e611982dd79643149c6c1a89e914bea02b0eb2 (patch)
tree4ae916d8891bc68738d739350d00f347ae0f4c3b /dev-haskell/stack-bin/stack-bin-2.3.1.ebuild
parentdev-haskell/pandoc-citeproc: bump up to 0.17.0.1 (diff)
downloadgentoo-30e611982dd79643149c6c1a89e914bea02b0eb2.tar.gz
gentoo-30e611982dd79643149c6c1a89e914bea02b0eb2.tar.bz2
gentoo-30e611982dd79643149c6c1a89e914bea02b0eb2.zip
dev-haskell/stack-bin: bump up to 2.3.1
Closes: https://bugs.gentoo.org/724234 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/stack-bin/stack-bin-2.3.1.ebuild')
-rw-r--r--dev-haskell/stack-bin/stack-bin-2.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/stack-bin/stack-bin-2.3.1.ebuild b/dev-haskell/stack-bin/stack-bin-2.3.1.ebuild
new file mode 100644
index 000000000000..525043e12021
--- /dev/null
+++ b/dev-haskell/stack-bin/stack-bin-2.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The Haskell Tool Stack (Binary)"
+HOMEPAGE="https://github.com/commercialhaskell/stack"
+
+SRC_URI="https://github.com/commercialhaskell/stack/releases/download/v${PV}/stack-${PV}-linux-x86_64.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="symlink"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ sys-libs/zlib
+ dev-libs/gmp:0
+"
+RDEPEND+=" symlink? ( !dev-haskell/stack )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="/usr/bin/stack-bin"
+QA_PRESTRIPPED="/usr/bin/stack-bin"
+
+src_prepare() {
+ default
+
+ mv stack-${PV}-*/doc doc || die
+ mv stack-${PV}-*/stack stack-bin || die
+}
+
+src_install() {
+ dodoc -r doc/*
+ dobin stack-bin
+ use symlink && dosym stack-bin /usr/bin/stack
+}