summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:04 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:57 +0100
commit19e1da81c8e9406dda8a5f19636c6fb9613d6f0a (patch)
treea0bf132097148c2f52a0fa39c1ff4e227e7d8b9b /dev-haskell/parsers
parentdev-haskell/parsec1: add 1.0.0.8 (diff)
downloadgentoo-19e1da81c8e9406dda8a5f19636c6fb9613d6f0a.tar.gz
gentoo-19e1da81c8e9406dda8a5f19636c6fb9613d6f0a.tar.bz2
gentoo-19e1da81c8e9406dda8a5f19636c6fb9613d6f0a.zip
dev-haskell/parsers: add 0.12.11
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/parsers')
-rw-r--r--dev-haskell/parsers/Manifest1
-rw-r--r--dev-haskell/parsers/metadata.xml15
-rw-r--r--dev-haskell/parsers/parsers-0.12.11.ebuild37
3 files changed, 44 insertions, 9 deletions
diff --git a/dev-haskell/parsers/Manifest b/dev-haskell/parsers/Manifest
index 4036465f8724..3458589c17f8 100644
--- a/dev-haskell/parsers/Manifest
+++ b/dev-haskell/parsers/Manifest
@@ -1,2 +1,3 @@
DIST parsers-0.12.10-rev2.cabal 3428 BLAKE2B ff4fa52451f5f85a76dc8a3cd7fecfacfd74bfc5836b46b1c463ff7d021c0f680feedb5816f0cc1e66bc32fddde491c58108fde60d7073bd150b33185c218c76 SHA512 3861ecd2139dadc721b3e3a0ae45f83e488c48b067fc600cffe7b194102e9ac135ce1bbdc8094f10d670367dd5d2571c88b2943be136a682b53d0408d50836b8
DIST parsers-0.12.10.tar.gz 26215 BLAKE2B 35303f6f4919e07b77490f5bcbc2a45efe8fda5edf169ade7dd7cd3bd080f2d24d5470ecb47f8a6428be1176faa8d138616e8f2635f9974ed473c8a61145e8ee SHA512 99ff90de4e60be3c03c8e1e5ae7902a37424c3139ccf566ff1cbc363d176787bd60bb709ef6c56f5b446f1f1b7eca65aa5d431897a0f82a9d6f7fe77fd2ee49f
+DIST parsers-0.12.11.tar.gz 24004 BLAKE2B 4d5d700e1dd8e89b3025b9d659c9bb35ede45c327359ea18d4db2961bec2ad05c44c7484ca6a8aff8f10679107996bb989516889df311c44de464b2d593b0928 SHA512 7ffa8b092aa731dc263151f755b52126924a8dd0a6c51aa52b044937976ad6410dd0755af5d361f5255c212e6cadc5793d15fa3a3fe26514c1324eeee71b4019
diff --git a/dev-haskell/parsers/metadata.xml b/dev-haskell/parsers/metadata.xml
index aa88907fe7af..88974e5372c2 100644
--- a/dev-haskell/parsers/metadata.xml
+++ b/dev-haskell/parsers/metadata.xml
@@ -6,15 +6,12 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="parsec">Enable the use of the `parsec` package</flag>
+ <flag name="attoparsec">You can disable the use of the `attoparsec` package using `-f-attoparsec`.</flag>
<flag name="binary">You can disable the use of the `binary` package using `-f-binary`.</flag>
- <flag name="attoparsec">Enable the use of the `attoparsec` package</flag>
+ <flag name="parsec">You can disable the use of the `parsec` package using `-f-parsec`.</flag>
</use>
- <longdescription>
- This library provides convenient combinators for working with and building parsing combinator libraries.
-
- Given a few simple instances, e.g. for the class 'Text.Parser.Combinators.Parsing' in "Text.Parser.Combinators.Parsing" you
- get access to a large number of canned definitions. Instances exist for the parsers provided by @parsec@,
- @attoparsec@ and base’s "Text.Read".
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">parsers</remote-id>
+ <remote-id type="github">ekmett/parsers</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/parsers/parsers-0.12.11.ebuild b/dev-haskell/parsers/parsers-0.12.11.ebuild
new file mode 100644
index 000000000000..a635ff0fbc7d
--- /dev/null
+++ b/dev-haskell/parsers/parsers-0.12.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Parsing combinators"
+HOMEPAGE="https://github.com/ekmett/parsers/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+attoparsec +binary +parsec"
+
+RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag attoparsec attoparsec) \
+ $(cabal_flag binary binary) \
+ $(cabal_flag parsec parsec)
+}