summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-09-30 08:30:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-09-30 08:31:15 +0100
commitfca878ac5e5a1e073a74254568077d5b40f4a083 (patch)
tree132fe8a8d99b72c588d7e5e34d7dc09e6546b5a0 /dev-haskell/pandoc-citeproc
parentnet-libs/libnet: Add live ebuild (diff)
downloadgentoo-fca878ac5e5a1e073a74254568077d5b40f4a083.tar.gz
gentoo-fca878ac5e5a1e073a74254568077d5b40f4a083.tar.bz2
gentoo-fca878ac5e5a1e073a74254568077d5b40f4a083.zip
dev-haskell/pandoc-citeproc: convert IUSE underscore to dash
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/695034 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/pandoc-citeproc')
-rw-r--r--dev-haskell/pandoc-citeproc/metadata.xml6
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild8
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.1.ebuild16
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild16
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild8
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild8
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild8
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild8
-rw-r--r--dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild10
9 files changed, 44 insertions, 44 deletions
diff --git a/dev-haskell/pandoc-citeproc/metadata.xml b/dev-haskell/pandoc-citeproc/metadata.xml
index cc43b3deba93..44fca18984bd 100644
--- a/dev-haskell/pandoc-citeproc/metadata.xml
+++ b/dev-haskell/pandoc-citeproc/metadata.xml
@@ -7,11 +7,11 @@
</maintainer>
<use>
<flag name="bibutils">use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
- <flag name="embed_data_files">Embed locale files into the library (needed for windows packaging)</flag>
+ <flag name="embed-data-files">Embed locale files into the library (needed for windows packaging)</flag>
<flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
<flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
- <flag name="small_base">Choose the new smaller, split-up base package.</flag>
- <flag name="test_citeproc">Build the test-citeproc program</flag>
+ <flag name="small-base">Choose the new smaller, split-up base package.</flag>
+ <flag name="test-citeproc">Build the test-citeproc program</flag>
<flag name="unicode_collation">Use Haskell bindings to the <pkg>dev-libs/icu</pkg></flag>
</use>
<longdescription>
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
index ccaee0e55d7e..f6d16965a96e 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+IUSE="+bibutils embed-data-files +hexpat +network +small-base unicode_collation"
RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
RDEPEND=">=app-text/pandoc-1.12.0.2:=[profile?]
@@ -56,9 +56,9 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
$(cabal_flag hexpat hexpat) \
$(cabal_flag network network) \
- $(cabal_flag small_base small_base) \
+ $(cabal_flag small-base small_base) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.1.ebuild
index e2d63fc8aa19..533ce8a18a8c 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.1.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
RESTRICT=test # execs a process dropping environment (with LD_PRELOAD)
@@ -40,24 +40,24 @@ RDEPEND=">=app-text/pandoc-1.16:=[profile?] <app-text/pandoc-2.1:=[profile?]
>=dev-lang/ghc-7.4.1:=
bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
debug? ( dev-haskell/pretty-show:=[profile?] )
- test_citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
+ test-citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
>=dev-haskell/vector-0.10:=[profile?] )
- !test_citeproc? ( dev-haskell/vector:=[profile?] )
+ !test-citeproc? ( dev-haskell/vector:=[profile?] )
unicode_collation? ( dev-haskell/text-icu:=[profile?] )
!unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
- test? ( !test_citeproc? ( >=dev-haskell/temporary-1.1 ) )
- embed_data_files? ( dev-haskell/hsb2hs )
+ test? ( !test-citeproc? ( >=dev-haskell/temporary-1.1 ) )
+ embed-data-files? ( dev-haskell/hsb2hs )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
$(cabal_flag debug debug) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
index 64db508e0edf..a89de2bce4e4 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.10.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
RESTRICT=test # execs a process dropping environment (with LD_PRELOAD)
@@ -40,24 +40,24 @@ RDEPEND=">=app-text/pandoc-1.16:=[profile?] <app-text/pandoc-2.1:=[profile?]
>=dev-lang/ghc-7.4.1:=
bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
debug? ( dev-haskell/pretty-show:=[profile?] )
- test_citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
+ test-citeproc? ( >=dev-haskell/temporary-1.1:=[profile?]
>=dev-haskell/vector-0.10:=[profile?] )
- !test_citeproc? ( dev-haskell/vector:=[profile?] )
+ !test-citeproc? ( dev-haskell/vector:=[profile?] )
unicode_collation? ( dev-haskell/text-icu:=[profile?] )
!unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
- test? ( !test_citeproc? ( >=dev-haskell/temporary-1.1 ) )
- embed_data_files? ( dev-haskell/hsb2hs )
+ test? ( !test-citeproc? ( >=dev-haskell/temporary-1.1 ) )
+ embed-data-files? ( dev-haskell/hsb2hs )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
$(cabal_flag debug debug) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild
index 72658455f8d1..d94d2d871709 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed_data_files +hexpat +network +small_base unicode_collation"
+IUSE="+bibutils embed-data-files +hexpat +network +small-base unicode_collation"
RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
@@ -54,9 +54,9 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
$(cabal_flag hexpat hexpat) \
$(cabal_flag network network) \
- $(cabal_flag small_base small_base) \
+ $(cabal_flag small-base small_base) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild
index 6db5f10ed771..76125b177592 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="+bibutils embed_data_files +hexpat +network test_citeproc unicode_collation"
+IUSE="+bibutils embed-data-files +hexpat +network test-citeproc unicode_collation"
RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
dev-haskell/aeson:=[profile?]
@@ -66,10 +66,10 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
$(cabal_flag hexpat hexpat) \
$(cabal_flag network network) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
index 1172030256f2..0b2a203a2fd0 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils embed-data-files test-citeproc unicode_collation"
RESTRICT=test # missing files
@@ -56,8 +56,8 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild
index 332e82c6e28d..03c9c514fe35 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
RESTRICT=test # fd:8: hClose: resource vanished (Broken pipe)
@@ -56,8 +56,8 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
$(cabal_flag debug debug) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test-citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}
diff --git a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild
index 51b893fd6c45..dac020cd335f 100644
--- a/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild
+++ b/dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
+IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
RESTRICT=test # execs a process dropping environment (with LD_PRELOAD)
@@ -47,7 +47,7 @@ RDEPEND=">=app-text/pandoc-1.13:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
- embed_data_files? ( dev-haskell/hsb2hs )
+ embed-data-files? ( dev-haskell/hsb2hs )
"
src_prepare() {
@@ -58,8 +58,8 @@ src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
$(cabal_flag debug debug) \
- $(cabal_flag embed_data_files embed_data_files) \
+ $(cabal_flag embed-data-files embed_data_files) \
--flag=-small_base \
- $(cabal_flag test_citeproc test_citeproc) \
+ $(cabal_flag test-citeproc test_citeproc) \
$(cabal_flag unicode_collation unicode_collation)
}