summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:50 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:54 +0100
commit767101bf113156effd95466ca5b470078c7d8b57 (patch)
tree6f71e2fe972c722408391ac5cc5c725177c25293 /dev-haskell/monads-tf
parentdev-haskell/monad-logger: add 0.3.40 (diff)
downloadgentoo-767101bf113156effd95466ca5b470078c7d8b57.tar.gz
gentoo-767101bf113156effd95466ca5b470078c7d8b57.tar.bz2
gentoo-767101bf113156effd95466ca5b470078c7d8b57.zip
dev-haskell/monads-tf: add 0.3.0.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/monads-tf')
-rw-r--r--dev-haskell/monads-tf/Manifest1
-rw-r--r--dev-haskell/monads-tf/metadata.xml13
-rw-r--r--dev-haskell/monads-tf/monads-tf-0.3.0.1.ebuild27
3 files changed, 32 insertions, 9 deletions
diff --git a/dev-haskell/monads-tf/Manifest b/dev-haskell/monads-tf/Manifest
index 0d3719722467..f37299557660 100644
--- a/dev-haskell/monads-tf/Manifest
+++ b/dev-haskell/monads-tf/Manifest
@@ -1 +1,2 @@
DIST monads-tf-0.1.0.3.tar.gz 14159 BLAKE2B e77b87e274ab8a29af6033fdc69a965b4013f43556bbc65e16eea35d49899e022294a87196a8e7c086659874a939010449102f5c9fa2f17b128212e567bcd588 SHA512 e1be602c584b42390b617cee164c8cb1c4bb17093c44033275924f273c94212e53faceb35aeabadf43e68f9631830e41266858daa10aa2f3af6300ebc20f3ea4
+DIST monads-tf-0.3.0.1.tar.gz 13675 BLAKE2B a363832f9d092708bbdf778acda8fd6c86904c6f43cfc4c596f19c804a33e3450ad6cdd4a3d5cc004cbdfc28086ea1ae6a0156db8a3ff27fb81236f2b0d3e058 SHA512 4074094c1eafa9a4739fd04e183841ac36314c03022f7cacb324d5fa6e6eab4eb6b10efbe9b89181814485a76a3aa64fcf99801c39c831e63e24e88115dbf438
diff --git a/dev-haskell/monads-tf/metadata.xml b/dev-haskell/monads-tf/metadata.xml
index ee84b9d844cb..f9cb3771ae43 100644
--- a/dev-haskell/monads-tf/metadata.xml
+++ b/dev-haskell/monads-tf/metadata.xml
@@ -5,13 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Monad classes using type families, with instances for various
- monad transformers, inspired by the paper /Functional Programming
- with Overloading and Higher-Order Polymorphism/, by Mark P
- Jones, in /Advanced School of Functional Programming/, 1995
- (&lt;http://web.cecs.pdx.edu/~mpj/pubs/springschool.html&gt;).
-
- This package is almost a compatible replacement for the @mtl-tf@ package.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">monads-tf</remote-id>
+ <remote-id type="github">typeclasses/monads-tf</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/monads-tf/monads-tf-0.3.0.1.ebuild b/dev-haskell/monads-tf/monads-tf-0.3.0.1.ebuild
new file mode 100644
index 000000000000..2c384616557c
--- /dev/null
+++ b/dev-haskell/monads-tf/monads-tf-0.3.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Monad classes, using type families"
+HOMEPAGE="https://github.com/typeclasses/monads-tf"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+CABAL_CHDEPS=(
+ 'base ^>= 4.16 || ^>= 4.17 || ^>= 4.18' 'base >= 4.14 && < 5'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"