summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 10:03:00 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:41 +0100
commit2f3eaf88701d48ed4bef5d7a7dc160ca4b30410a (patch)
tree3d643b6bebfad585c8302eb9fa9846ae0fc1e73d /dev-haskell/lrucache
parentdev-haskell/yesod-test: bump up to 1.6.10 (diff)
downloadgentoo-2f3eaf88701d48ed4bef5d7a7dc160ca4b30410a.tar.gz
gentoo-2f3eaf88701d48ed4bef5d7a7dc160ca4b30410a.tar.bz2
gentoo-2f3eaf88701d48ed4bef5d7a7dc160ca4b30410a.zip
dev-haskell/lrucache: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/lrucache')
-rw-r--r--dev-haskell/lrucache/Manifest1
-rw-r--r--dev-haskell/lrucache/lrucache-1.2.0.1.ebuild25
-rw-r--r--dev-haskell/lrucache/metadata.xml48
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/lrucache/Manifest b/dev-haskell/lrucache/Manifest
new file mode 100644
index 000000000000..0a5230e75708
--- /dev/null
+++ b/dev-haskell/lrucache/Manifest
@@ -0,0 +1 @@
+DIST lrucache-1.2.0.1.tar.gz 9224 BLAKE2B d29cfee3d21fcf66318f272011551a1a04e17ccac5ba58da0a80591502488ab7446a5b2137c57c91ded80b2486d95c28f5449c5417c88a99f2e121dd17841eea SHA512 fae5c8a10bb7ee781ed84ccf9c342bd583e112eb840d07aa72803affe3fa7dd394b3d6b73212e45005ec9155a409539902c4893ce20dc0a2a0e3f4a44b2c715b
diff --git a/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild b/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild
new file mode 100644
index 000000000000..48b8f20f6e50
--- /dev/null
+++ b/dev-haskell/lrucache/lrucache-1.2.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="a simple, pure LRU cache"
+HOMEPAGE="https://github.com/chowells79/lrucache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/contravariant-0.5:=[profile?] <dev-haskell/contravariant-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/lrucache/metadata.xml b/dev-haskell/lrucache/metadata.xml
new file mode 100644
index 000000000000..832a2c27f608
--- /dev/null
+++ b/dev-haskell/lrucache/metadata.xml
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package contains a simple, pure LRU cache, implemented in
+ terms of "Data.Map".
+
+ It also contains a mutable IO wrapper providing atomic updates to
+ an LRU cache.
+
+ Version History:
+
+ 1.1.1 - Add an additional modification function for AtomicLRUCache.
+
+ 1.1.0.1 - Update containers constraint to allow containers from ghc-7
+
+ 1.1 - Add a Functor instance for LRUCache.
+ Add a generic modification function for AtomicLRUCache.
+
+ 1.0 - Breaking API changes:
+ 1) The newLRU smart constructor now makes the maximum
+ size optional.
+ 2) The delete function now returns the value removed, if
+ one was.
+ Additionally, a function was added to remove the least-recently
+ used element in the LRU.
+
+ 0.3 - Added a Show instance for LRU. (Requested by Ben Lee)
+
+ 0.2.0.1 - Increase strictness slightly.
+ Remove cabal target for test executable.
+ (Just include test sources instead.)
+
+ 0.2 - Added an Eq instance for LRU.
+ Added strictness to eliminate space leaks in common use patterns.
+
+ 0.1.1 - Add the Data.Cache.LRU.IO.Internal module.
+ Clean up build warnings on GHC 6.12.1.
+
+ 0.1.0.1 - Minor refactoring
+
+ 0.1 - First release
+ </longdescription>
+</pkgmetadata>