summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/http-client-multipart
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/http-client-multipart')
-rw-r--r--dev-haskell/http-client-multipart/Manifest2
-rw-r--r--dev-haskell/http-client-multipart/http-client-multipart-0.2.0.0.ebuild32
-rw-r--r--dev-haskell/http-client-multipart/http-client-multipart-0.3.0.0.ebuild26
-rw-r--r--dev-haskell/http-client-multipart/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/http-client-multipart/Manifest b/dev-haskell/http-client-multipart/Manifest
new file mode 100644
index 000000000000..af5f16b12bfd
--- /dev/null
+++ b/dev-haskell/http-client-multipart/Manifest
@@ -0,0 +1,2 @@
+DIST http-client-multipart-0.2.0.0.tar.gz 4006 SHA256 e8a04ae3e22fc0d3adce44ad53e6e0c2742f4dad2f58e5721d379c03b59f50ad SHA512 7f3bc5b1b2dce4a8b5645b87a6f16e4baa3b61fbe71a7ba90a6c225af4a8d27b956280ab01805547d93378b32d5b4ab482e610f9423ccfda53d937d56586c497 WHIRLPOOL 51176a6669e01b860ee0abb7afe13cf61f81d2210bfd4cd7c3a7ae869b7f77be17d05fb1971ed578bb33e9e4884d9a434aab12cdd80aa8133291a2dabe0bafd9
+DIST http-client-multipart-0.3.0.0.tar.gz 1130 SHA256 2fb33407176843b1495835aa3fed618398057e86eff99c4baa0fa2628636eaa3 SHA512 4d0985d6cbc5e6ec4fe79b5037a4e378afd4b14382f2b26d62870ac091de661cf80be827851a8a8de014d6cd846867ea54ac7722deb6f97ecd70bee61fc1caeb WHIRLPOOL 6e225318bd662ca19dc1a0e88bae43736342f799d8a163227e7749dad3c32414407b5a0312a228720b91914427e982a1229146da62c1ae01e811f7ab942972b7
diff --git a/dev-haskell/http-client-multipart/http-client-multipart-0.2.0.0.ebuild b/dev-haskell/http-client-multipart/http-client-multipart-0.2.0.0.ebuild
new file mode 100644
index 000000000000..b549ef3b5d4c
--- /dev/null
+++ b/dev-haskell/http-client-multipart/http-client-multipart-0.2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate multipart uploads for http-client"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-multipart/http-client-multipart-0.3.0.0.ebuild b/dev-haskell/http-client-multipart/http-client-multipart-0.3.0.0.ebuild
new file mode 100644
index 000000000000..9b3247549f36
--- /dev/null
+++ b/dev-haskell/http-client-multipart/http-client-multipart-0.3.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile" # haddock hoogle hscolour" no files
+inherit haskell-cabal
+
+DESCRIPTION="Generate multipart uploads for http-client. (deprecated)"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/http-client-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
diff --git a/dev-haskell/http-client-multipart/metadata.xml b/dev-haskell/http-client-multipart/metadata.xml
new file mode 100644
index 000000000000..3ff0ce47cb9a
--- /dev/null
+++ b/dev-haskell/http-client-multipart/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Generate multipart uploads for http-client.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">snoyberg/http-client</remote-id>
+ </upstream>
+</pkgmetadata>