summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 20:54:40 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:17 +0000
commitdef3bd270219a7db86414984e9d990bcfb4cfd5a (patch)
treea4d7d9c7a31f537915dbd6391d1f5410703b17be /dev-haskell/hslua-objectorientation
parentdev-haskell/hslua-objectorientation: new package, add 2.2.0 (diff)
downloadgentoo-def3bd270219a7db86414984e9d990bcfb4cfd5a.tar.gz
gentoo-def3bd270219a7db86414984e9d990bcfb4cfd5a.tar.bz2
gentoo-def3bd270219a7db86414984e9d990bcfb4cfd5a.zip
dev-haskell/hslua-objectorientation: add 2.1.0
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hslua-objectorientation')
-rw-r--r--dev-haskell/hslua-objectorientation/Manifest1
-rw-r--r--dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hslua-objectorientation/Manifest b/dev-haskell/hslua-objectorientation/Manifest
index 3075db1cc447..519b6bacb408 100644
--- a/dev-haskell/hslua-objectorientation/Manifest
+++ b/dev-haskell/hslua-objectorientation/Manifest
@@ -1 +1,2 @@
+DIST hslua-objectorientation-2.1.0.tar.gz 15217 BLAKE2B 9505b1a40790518a9b7362636d0715ff53abfede550d606c1667b4b4812be8be55b2ee2c4d2510a5366fd89dfe0c46c89b81912a4af159b619808791b4418d87 SHA512 f7eac02ac6d1e6c18874d6ca5bdd1466ae670b264005b24e3dfccc31b8844dce4f17a9a7c5523ce332a4477bb67d2b520f97ff414352d68f1e11f59dc0cecf45
DIST hslua-objectorientation-2.2.0.tar.gz 15240 BLAKE2B 741298dd4d47b5b0bc4da565f9bae1004f13fccb4cb617ad1603821df884604a12f481626af9314f84f781a48bff836367d7fb71ce0ca5e2d3d8058c5899b394 SHA512 c40f0526264db229093f39deb9e77a44e575e6ebf97f257ff063b61279cd47aeecda4204db2ebc686b3e8ac467e2a0f4887608a54386f4afca2d47b469ee6107
diff --git a/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild
new file mode 100644
index 000000000000..cd06e87a53ed
--- /dev/null
+++ b/dev-haskell/hslua-objectorientation/hslua-objectorientation-2.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Object orientation tools for HsLua"
+HOMEPAGE="https://hslua.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/hslua-core-2.1:=[profile?] <dev-haskell/hslua-core-2.2:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.1:=[profile?] <dev-haskell/hslua-marshalling-2.2:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/text-1.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/lua-arbitrary-1.0
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hslua-1.0
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-quickcheck-0.8 )
+"